Trouble with WDS wifi bridge

Hi,

I've got my main router (WRT32X with openwrt 19.07.3) connected to my modem, and I'd like to connect my extra router (Archer c7 v2 with openwrt 19.07.3) via 2.4Ghz wifi to my main router. This will hopefully allow me to connect some computers to my Archer via ethernet or 5Ghz wifi, and then get online.

I reset my Archer and tried using the LUCI portion of the Atheros and MAC80211 WDS instructions several times, but was unsuccessful. I can't ping my my Archer from a computer plugged into it, even when the computer is set to assign its own IP manually. When I plug my Archer into the WRT32x I can ping everything from my computer, but I don't want the WRT32x and Archer to be wired together. I suspect the WDS connection is not working properly, but I'm having trouble figuring out what exactly to test or change. Any suggestions?

Here are my /etc/config files:

WRT32X 19.07.3, r11063-85e04e9f46

root@main:/etc/config# cat wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '36'
	option htmode 'VHT40'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr 'ends in :ac:fa'
	option ssid 'main_5g'
	option encryption 'psk2'
	option key 'password'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT20'
	option channel '1'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr 'ends in :ac:f9'
	option ssid 'main'
	option encryption 'psk2'
	option key 'password'
	option wds '1'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option country 'US'
	option hwmode '11g'
	option htmode 'HT20'
	option channel 'auto'
	option txpower '30'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option key 'password'
	option encryption 'psk2'
	option ssid 'main_backhaul'
	option wds '1'


root@main:/etc/config# cat network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'ends in ":8813::/48"'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'
	option peerdns '0'
	option dns '185.228.168.10'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	option vid '2'

Archer

root@second:/etc/config# cat wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option htmode 'HT20'

config wifi-iface 'wifinet2'
	option ssid 'main_backhaul'
	option device 'radio1'
	option mode 'sta'
	option key 'password'
	option wds '1'
	option encryption 'psk2'
	option network 'lan'

root@second:/etc/config# cat network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'ends in ":dc95::/48"'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.2'
	option gateway '192.168.1.1'
	option stp '1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 6t'

I haven't turned on the 5Ghz wifi on the Archer yet (currently using ethernet to connect to it), but that will be the next step.

Thanks
P.S. I really appreciate all the work you all put into Openwrt, I like the idea of being able to configure a standard router to my needs.

Can your main router (192.168.1.1) ping the secondary AP (192.168.1.2) and vice versa?

Does your PC have an IP address in the correct subnet (192.168.1.0/24), with the correct gateway (192.168.1.1, not .1.2)?

My configuration is very similar to yours. My second AP is basically stripped down, DHCP/DNS disabled, all firewall rules removed. Any wireless clients connected to the secondary AP get their network configuration via DHCP(IPv4 and 6) from the main router. You've got both devices in one network now, you don't need two separate DHCP servers running, just one. Any DHCP traffic will travel over the WDS link, both ways.

Is the WDS client connection successfully established between both APs? Any weird messages in the syslog? I notice Archer C7 doesn't have a regulatory country option or TX power option set. That's the only thing I've managed to spot, but I don't know if it makes any difference in this case.

My config for comparison, if anybody has an epiphany:

The dnsmasq settings for DNS/DHCP on the secondary AP:

1 Like

I ended up switching to radio1 (normal 2.4ghz) on my wrt32x instead of radio2 (2.4 or 5ghz radio, that seems to have a weird config settings). Now everything works fine.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.