Trouble with serial usbTtl

I haven’t used my serial cable in a while, and then recently my main router started hanging and becoming unresponsive, about once a week. So I figured I’d connect this up, but found I couldn’t get even basic functionality working from screen.

My environment is

  • Macbook host
  • Manjaro Linux vm
  • ftdi FT232 usb ttl cable
  • using screen to connect to the usbTTL

About 9months ago it was working fine. No issues.

Since then, following changes

  • macos upgrade to catalina
  • vmware fusion upgrade to 11.5
  • the majaro Linux vm does not appear to have had any significant changes in the updates list

Summary :

  1. I get gibberish output in the screen terminal, unless specify the baud as 115200
  2. With only the rx pin connected, the led on my usb ttl cable is blinking like crazy so it’s getting data, but the screen terminal remains blank
  3. Starting screen with sudo screen /dev/ttyUSB0 115200 I can see the bootloader of my device, but it never boots up the firmware (fritz7490) which seem to imply that something about the serial cable being connected is interrupting the auto boot of the image. The console is unresponsive to any keyboard input.
  4. If I fully disconnect the serial cable from the router and restart it, it does boot up fine (I can connect to it from WiFi )

Could anyone suggest what else I could try?

What are all the most common combinations of settings , that I could then test changing one by one?

Edit: just tested the usb ttl cable from one raspberry pi to another , and confirmed it’s working fine using following settings in miniterm

RTS: active   DTR: active  BREAK: inactive 
CTS: inactive  DSR: inactive   RI: inactive.  CD: inactive 
Software flow control: inactive
Hardware flow control: inactive 
Serial input encoding: latin1
Serial output encoding: latin1
Filters: default

Well, I suggest that you test the cable from your PC to the Raspberry Pi to rule out any driver or software issue from the PC/VM side.

As for the console not responding to your input, is it possibly a dodgy serial connection to the router's Rx?

Yeh, I gave that a shot yesterday, and ended up abandoning the VM altogether . I’m now connecting from one of the raspberry pies - but I still get the same results when connecting from raspberry pi to the routers (r7800 , and a fritz7490)

The r7800 came with presoldered headers so they should be ok.

I had a moment yesterday where I got a block of valid console text whiz by. But nothing else except snow/garbled text since then..

I unplugged and reconnected pi to pi , and serial cable and terminal still working perfectly...

In any case, I tried to resolder the ground pin on the r7800 which looked a bit suspicious , but still seeing same results.. the tx and rx pins looked very good - better than i could do :smiley:

Any other thoughts/ideas are welcome

Is it possible that the header pin doesn't fit well in the cable (e.g. too thick or too thin)? I mean why else would it work only once?

I completely agree- but I could not find any pattern with wiggling the pinout jumper wires.. I even swapped the jumper wires with the ones I used on the raspberry pi serial headers , but still the garbled text issues persist on the routers.

I have a friend who has some ossiliscope /diagnostics tools - will see if he can help figure it out.

1 Like