Trouble with OpenWrt - no DNS in new router

I'm feeling stupid. I am trying to configure a new OpenWrt router to replace an older OpenWrt device.

My connection to the internet is through a LTE bridge - my cell phone carrier provided a gizmo with an Ethernet port that is in bridge mode. It assigns a DHCP address of 10.19.x.x (through their CGNAT) to the router's WAN port.

The older OpenWrt device works just fine. My memory is that I used substantially the default configuration, then plugged it into the LTE Bridge. The WAN port got a DHCP address, and I was able to connect, finish configuration, and smile.

This new device (ArcherC7v2, flashed with 21.02.1) connects to the LTE Bridge, gets the correct DHCP address, but "nothing works". More specifically:

  • I can ping public IP addresses (,, and others addresses that I have memorized) Curiously, my cell carrier doesn't seem to be passing traffic for, so I won't use that for a DNS server.

  • No DNS lookups work. nslookup from the command line of the router fails.

    root:~# nslookup
    ;; connection timed out; no servers could be reached
  • In Network -> DHCP & DNS, I have

    • set DNS Forwardings to and
  • in Network -> WAN settings, I have

    • UNchecked the "Use DNS servers advertised by peers"
    • Use custom DNS servers of and

What am I missing? Many thanks.

try faking your old router's Wan mac to your new router mac. Some ISPs lock to that mac and require a call to release it. by faking it you can rule that out.

(edit - Is the new router using the same VLAN for connection?)

1 Like

Bingo! That seems to have made the difference. Thanks!

1 Like

Its an old cable modem trick. Glad it still works. And its usually faster than trying to call your ISP.

Yeah. I had to do it with my DSL provider as well.

At least they redirected everything to a "Walled Garden" webpage (they actually called it that) that said, essentially, you gotta call us before you can get on the air... Thanks again.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.