I recently installed OpenWRT on my Dynalink WRX36 router. While using the stock firmware, my devices on the same network could see each other without any issues. However, after installing OpenWRT, I’m encountering connectivity problems.
For instance, devices like the Philips Hue Bridge, connected via Ethernet, are not visible to other devices on the network. Consequently, I’m unable to establish remote connections using the Hue app. Additionally, my Google TV isn’t being recognized, preventing me from utilizing functions like remote power control and AirPlay from my phone.
I’ve confirmed that this issue doesn’t occur when using a router without OpenWRT. As a relatively new OpenWRT user, I’d appreciate any guidance or insights on troubleshooting this matter. Are there specific configurations or settings I should be checking?
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
Hello @eduperez
Apologies for the delay in my response. I have performed the SSH commands you requested and captured the outputs as images. You can find them attached to this message.
Please let me know if there’s anything else I can provide or any further assistance needed regarding the issue.
Thank you for your patience.
root@OpenWrt:~# ubus call system board
{
"kernel": "6.1.62",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 4",
"model": "Dynalink DL-WRX36",
"board_name": "dynalink,dl-wrx36",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "SNAPSHOT",
"revision": "r24433-2634d3f855",
"target": "qualcommax/ipq807x",
"description": "OpenWrt SNAPSHOT r24433-2634d3f855"
}
}
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'xxxxxxxxxxxx'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
option mtu '1492'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option delegate '0'
config interface 'wan'
option device 'wan'
option proto 'pppoe'
option username 'xxxxx@xxxxx'
option password 'xxxxxxxxxxxx'
option ipv6 '0'
option peerdns '0'
option mtu '1492'
list dns '1.1.1.1'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
option reqaddress 'none'
option reqprefix 'auto'
config device
option name 'pppoe-wan'
option mtu '1492'
option mtu6 '1492'
option acceptlocal '1'
option igmpversion '3'
option mldversion '2'
config device
option name 'wan'
option mtu '1492'
option ipv6 '0'
option acceptlocal '1'
config device
option name 'lan1'
option mtu '1492'
config device
option name 'lan2'
option mtu '1492'
config device
option name 'lan3'
option mtu '1492'
config device
option name 'lan4'
option mtu '1492'
option acceptlocal '0'
config device
option name 'phy0-ap0'
option mtu '1492'
config device
option name 'phy1-ap0'
option mtu '1492'
````root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/c000000.wifi'
option channel '56'
option band '5g'
option htmode 'HE160'
option country 'US'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Dynalink-E5'
option encryption 'psk2'
option key 'xxx'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/c000000.wifi+1'
option channel '9'
option band '2g'
option htmode 'HE40'
option country 'US'
option cell_density '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'Dynalik-E5-2.4'
option encryption 'psk2'
option key 'xxx'
option multicast_to_unicast_all '1' `
I see way too many "option mtu '1492'" lines there, and there seems to be an extra "'" at the end, but none of these should cause the issue you experience. I do not see anything else that calls my attention, not sure what could be causing that isolation.
Do you mean you cannot login to your wifi or do not get an IP address?
You are using 40 MHz for 2.4 and 160 Mhz for 5 Ghz that could be troublesome for some clients. Just use 20 Mhz and 80 MHz respectively
Furthermore for encryption try some other options e.g. WPA2-PSK (CCMP) or WPA2/WPA3 Mixed mode
Hello,
No, devices can connect to the Wi-Fi, and there’s no issue with internet access. However, smart devices like hubs, Google TV, etc., can’t utilize services like Airplay because devices connected to the same Wi-Fi network can’t detect each other. Therefore, I’m receiving an error prompting me to ensure that my devices are connected to the same Wi-Fi network.
Please try to reconfigure (delete && recreate) the wifi connection on one of the affected client devices (for a start), there may be subtle differences in the exact wireless (encryption) settings that may confuse some devices (typical IoT devices can be particularly bad at this), while others don't care. Also make sure to test with WPA2/CCMP and not any mixed modes (if you are positive that all your clients can do WPA3, try it, but that's rarely the case).