Trouble Pinging Through PPP Connection to Modem

Hello All,

I have my OpenWrt running on a custom IMx.6 based board. It has an embedded Sierra Wireless modem, which I am able to create the ppp interface and appear to connect to; however, I cant seem to ping out.

I have an IP and a gateway, but the only thing that looks wrong to me is the state of the interface is UNKNOWN when I run ip addr show.

Here are some relevant outputs:

cat /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd5:e02b:e279::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'usb0'
        option proto 'static'
        option ipaddr '192.168.5.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'ethernet'
        option proto 'dhcp'
        option ifname 'eth0'

config interface 'wan'
        option proto 'dhcp'
        option peerdns '1'

config interface 'ppp'
        option proto 'ppp'
        option device '/dev/ttyUSB2'
        option auto '0'

ifconfig ppp-ppp
ppp-ppp   Link encap:Point-to-Point Protocol  
          inet addr:100.100.140.151  P-t-P:10.64.64.64  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:786 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:62 (62.0 B)  TX bytes:55382 (54.0 KiB)
ip route show ppp-ppp
default via 10.64.64.64 dev ppp-ppp 
default dev usb0 scope link  src 169.254.45.58  metric 206
ip addr show ppp-ppp
10: ppp-ppp: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 3
    link/ppp 
    inet 100.100.140.151 peer 10.64.64.64/32 scope global ppp-ppp
       valid_lft forever preferred_lft forever

Notably, when I try to ping out from that interface ping -I ppp-ppp 8.8.8.8, it just seems to hang forever and I never get any output.

I really thought once I got the ppp interface made everything would work, so this is a real bummer at this point. Any Ideas would be greatly appreciated!