Trouble migrating from swconfig to dsa

Hi,
I took this weekend to finally upgrade the 2 EA8300s that power most of my network.The first one went without much issue and didn't require much effort but I am having a really hard time understanding how dsa works now. On my EA8300-2, I am unable to configure vlans. This is how I am trying to configure this:
wan - untagged traffic is management and is what I want luci on; also has vlans 10, 70, 80
Lan 1 - untagged should be the same as wan
Lan 2 - untagged should be 10
Lan 3 - untagged should be 80
Lan 4 - untagged should be 80 and it should also have 70 tagged
Any help is appreciated :smile:

Is this the main router or a switch/bridged AP?

Please post the following:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network

Both of them are just APs, but this one does a little bit of switching too with these vlans. (Eg. I only have a trunk coming from the wall when I need 3 separate networks)
I can post the config when I get home.

Ok... this should be pretty easy. When you post your config file, I'll show you how to make the VLANs work as desired.


        "kernel": "5.15.162",
        "hostname": "ea8300-2",
        "system": "ARMv7 Processor rev 5 (v7l)",
        "model": "Linksys EA8300 (Dallas)",
        "board_name": "linksys,ea8300",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.4",
                "revision": "r24012-d8dd03c46f",
                "target": "ipq40xx/generic",
                "description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
        }
}
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdef:959a:7465::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'wan'

config device
        option name 'lan1'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan2'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan3'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan4'
        option macaddr '24:f5:a2:##:##:##'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.90.0.5'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '10.90.0.1'
        list dns '10.90.0.1'
        list dns '1.0.0.1'

config device
        option name 'wan'
        option macaddr '24:f5:a2:##:##:##'

config interface 'lanv6'
        option proto 'dhcpv6'
        option device 'br-lan'
        option reqaddress 'force'
        option reqprefix 'auto'

config device
        option type '8021q'
        option ifname 'br-lan'
        option vid '10'
        option name 'br-lan.10'

config device
        option type 'bridge'
        option name 'br-ulan'
        list ports 'br-lan.10'
        list ports 'lan2'

config interface 'ulan'
        option proto 'none'
        option device 'br-ulan'

config device
        option type 'bridge'
        option name 'br-homelab'
        list ports 'br-lan.80'
        list ports 'lan3'
        list ports 'lan4'

config device
        option type 'bridge'
        option name 'br-virtualm'
        list ports 'lan4'
        list ports 'wan'

config bridge-vlan
        option device 'br-virtualm'
        option vlan '70'
        list ports 'lan4:t'
        list ports 'wan:t'

config device
        option type '8021q'
        option ifname 'br-lan'
        option vid '80'
        option name 'br-lan.80'

There are some leftover entries in my network file from trying to solve this myself.

Yes, I see that. I think it would be best/fastest to reset to defaults and then make only the minimum required changes before reposting...

So from the default config, edit your lan interface as you had done. Optionally enable wifi.

Then post your network config file again.

Here it is with all of that removed:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdef:959a:7465::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'wan'

config device
        option name 'lan1'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan2'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan3'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan4'
        option macaddr '24:f5:a2:##:##:##'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.90.0.5'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '10.90.0.1'
        list dns '10.90.0.1'
        list dns '1.0.0.1'

config device
        option name 'wan'
        option macaddr '24:f5:a2:##:##:##'

config interface 'lanv6'
        option proto 'dhcpv6'
        option device 'br-lan'
        option reqaddress 'force'
        option reqprefix 'auto'

config device
        option type '8021q'
        option ifname 'br-lan'
        option vid '10'
        option name 'br-lan.10'

config device
        option type 'bridge'
        option name 'br-ulan'
        list ports 'br-lan.10'
        list ports 'lan2'

config interface 'ulan'
        option proto 'none'
        option device 'br-ulan'

I have {,br-}ulan currently serving a wifi network, so I can't disable that.

I recommended a reset to defaults because there are other issues that need to be cleaned up. It will be far faster and less work to start from a near-default state.

1 Like

The only changes from default are the wan-lan bridge and the lan.10 for a wireless network. What are the other issues? Up until now, I've only ever used luci for configuration so I have not touched it by hand.

Everything needs to be in a single bridge, and then we will use bridge-vlans to setup the individual vlans as needed.

Currently, you've got several bridges and stuff -- let's get it back to default so we know that the edits will work.

1 Like
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdef:959a:7465::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'

config device
        option name 'lan1'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan2'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan3'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan4'
        option macaddr '24:f5:a2:##:##:##'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.90.0.5'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '10.90.0.1'
        list dns '10.90.0.1'
        list dns '1.0.0.1'

config device
        option name 'wan'
        option macaddr '24:f5:a2:##:##:##'

config interface 'lanv6'
        option proto 'dhcpv6'
        option device 'br-lan'
        option reqaddress 'force'
        option reqprefix 'auto'

Much better. Thanks.

We will start by creating bridge-vlans per your description:

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'
        list ports 'wan:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'lan2:u*'
        list ports 'wan:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '70'
        list ports 'lan4:t'
        list ports 'wan:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '80'
        list ports 'lan3:u*'
        list ports 'lan4:u*'
        list ports 'wan:t'

Next, edit the lan to use br-lan.1:

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '10.90.0.5'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '10.90.0.1'
        list dns '10.90.0.1'
        list dns '1.0.0.1'

And finally add unmanaged interfaces for the other 3 VLANs:

config interface 'vlan10'
        option device 'br-lan.10'
        option proto 'none'

config interface 'vlan70'
        option device 'br-lan.70'
        option proto 'none'

config interface 'vlan80'
        option device 'br-lan.80'
        option proto 'none'

At this point, you can restart your router and the ports should work as defined. If you are using this as an AP, create your SSIDs and then connect them with the respective networks (lan, vlan10, vlan70, vlan80).

1 Like

The AP didn't come back online after the changes so I am currently in failsafe trying to find the issue. Here is what my /etc/config/network looks like:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdef:959a:7465::/48'

config device
        option name 'lan1'
        option macaddr '24:f5:a2:##:##:##:'

config device
        option name 'lan2'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan3'
        option macaddr '24:f5:a2:##:##:##'

config device
        option name 'lan4'
        option macaddr '24:f5:a2:##:##:##:'

config device
        option name 'wan'
        option macaddr '24:f5:a2:##:##:##'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'
        list ports 'wan:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'lan2:u*'
        list ports 'wan:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '70'
        list ports 'lan4:t'
        list ports 'wan:t'

config bridge-vlan
        option device 'br-lan'
        option vlan '80'
        list ports 'lan3:u*'
        list ports 'lan4:u*'
        list ports 'wan:t'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '10.90.0.5'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '10.90.0.1'
        list dns '10.90.0.1'
        list dns '1.0.0.1'

config interface 'vlan10'
        option device 'br-lan.10'
        option proto 'none'

config interface 'vlan70'
        option device 'br-lan.70'
        option proto 'none'

config interface 'vlan80'
        option device 'br-lan.80'
        option proto 'none'

What am I missing?

What happened to the bridge device itself? You appear to have deleted it. It should look like this:

1 Like

Thank you very much! :grin: That was it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.