Trouble installing u-boot on ZyXEL P-2812HNU-F3

Unable to get CFG 04 UART mode. According to wiki
"Short the bootsel_0 pins (R24), and (R15) bootsel_2 and power on the router". My interpretation of this is to make a connection between the end of the two resistors at the end near the nand chip, so I tried this with a small screwdriver a lot of times but without success.
I also tried to connect R17 to ground, as in the wiki for F1, and immediately got CFG 02 UART. But after transferring the asc-file, nothing happens. I would expect some activity when u-boot starts.

Does anyone know the difference between 02 and 04 UART mode?
Any advice?

It's been a while since I did this but am fairly certain you need to use a pair of pins or something to short the two areas/pads. You don't touch any resistors. Use tape to mask it off.

Thanks for answering.
I suppose you used the pads at the ends of the resistors? That is what I tried, but I got only GFG 06 (normal boot). Used pins with some additional weight standing on the pads , and a lead between.

CFG 02 is what you want I think. It will be obvious when (or if at all) it works, you should see many *'s right before u-boot loads. If you see nothing or just a few *'s it could be serial freeze, wrong file, etc. Good luck

Thanks, you are right. CFG 02 seems to work. When using another u-boot.asc it loads after the file transfer.
The problem now is that this version of u-boot (from 18.06.5) is missing the 'protect' command, which (according to wiki) is the first I have to do.
Gets message "Unknown command 'protect' ", may be the option CONFIG_CMD_FLASH was not enabled when compiling u-boot (

In spite of label telling my router is a F3, I will say it is a F1.
I can get UART mode by shorting R17 to ground, and it is a RT3062 on board (no RT3092). Succeded installing 18.06.8

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.