Trouble getting IPV6 working

Hello I am using OpenWRT on a Pi CM 4 from "SeeedStudio" with the prebuilt image they provide here https://wiki.seeedstudio.com/OpenWrt-Getting-Started/ and I have everything working great through IPv4 but I can't seem to get IPv6 working. I have Spectrum as my ISP and a new Arris SB 8200 modem which should both support it. When I configured the router I believe there was no WAN6 interface by default but I've attempted to add it and configure the LAN as well using a number of different configurations. The status page reports to me I get a /64 prefix delegated and the router has an IPv6 address but if I try ping -6 google.com I get

PING google.com (2607:f8b0:4009:808::200e): 56 data bytes
ping: sendto: Network unreachable

and no devices report ipv6 detected on test-ipv6.com/

Network config:

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fddd::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option device 'br-lan'
        option ipaddr '192.168.1.1'
        option ip6assign '64'
        option dhcpv6 'server'
        option ra 'server'
        option ra_flags 'managed-config other-config'
        option defaultroute '0'
        option delegate '0'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'
        option ipv6 'auto'

config interface 'vpn0'
        option proto 'none'
        option device 'tun0'

config interface 'docker'
        option device 'docker0'
        option proto 'none'
        option auto '0'

config device
        option type 'bridge'
        option name 'docker0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        option promisc '1'

config interface 'BeckLinksys'
        option proto 'dhcp'

config device
        option name 'eth1'

config device
        option name 'eth0'

config device
        option name 'eth0'

config interface 'WAN6'
        option proto 'dhcpv6'
        option device '@wan'
        option reqaddress 'try'
        option reqprefix 'auto'

DHCP config:

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'Abwezi-PC'
        option dns '1'
        option mac '04:D9:F5:7E:18:54'
        option ip '192.168.1.140'

config host
        option dns '1'
        option mac '60:22:32:2E:8C:60'
        option ip '192.168.1.2'
        option name 'U6-LR'

config host
        option name 'TL-WPA8631P'
        option dns '1'
        option mac '54:AF:97:A8:F7:A8'
        option ip '192.168.1.4'

config host
        option dns '1'
        option mac '00:E4:21:44:1B:93'
        option ip '192.168.1.16'
        option name 'uknow'

config host
        option mac '64:B5:C6:B5:FC:04'
        option ip '192.168.1.13'
        option name 'uknow'
        option dns '1'

config host
        option name 'gbscontrol'
        option dns '1'
        option mac '3C:61:05:E3:63:39'
        option ip '192.168.1.5'

config host
        option name 'UAP-LR'
        option dns '1'
        option mac '04:18:D6:66:12:7D'
        option ip '192.168.1.3'

config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'

config dhcp 'WAN6'
        option interface 'WAN6'
        option ignore '1'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

Firewall config:

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option fullcone '1'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'ACCEPT'
        list network 'wan'
        list network 'wan6'
        list network 'BeckLinksys'
        list network 'WAN6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'
        list src_ip 'fc00::/6'
        list dest_ip 'fc00::/6'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option family 'ipv6'
        option target 'ACCEPT'
        list src_ip 'fe80::/10'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'
        list icmp_type 'bad-header'
        list icmp_type 'destination-unreachable'
        list icmp_type 'echo-reply'
        list icmp_type 'echo-request'
        list icmp_type 'neighbour-advertisement'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'packet-too-big'
        list icmp_type 'router-advertisement'
        list icmp_type 'router-solicitation'
        list icmp_type 'time-exceeded'
        list icmp_type 'unknown-header-type'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'
        list icmp_type 'bad-header'
        list icmp_type 'destination-unreachable'
        list icmp_type 'echo-reply'
        list icmp_type 'echo-request'
        list icmp_type 'neighbour-advertisement'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'unknown-header-type'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config include 'zerotier'
        option type 'script'
        option path '/etc/zerotier.start'
        option reload '1'

config include 'gowebdav'
        option type 'script'
        option path '/var/etc/gowebdav.include'
        option reload '1'

config include 'luci_app_ipsec_server'
        option type 'script'
        option path '/var/etc/ipsecvpn.include'
        option reload '1'

config include 'passwall'
        option type 'script'
        option path '/var/etc/passwall.include'
        option reload '1'

config include 'passwall_server'
        option type 'script'
        option path '/var/etc/passwall_server.include'
        option reload '1'

config include 'luci_app_pptp_server'
        option type 'script'
        option path '/var/etc/pptpd.include'
        option reload '1'

config include 'socat'
        option type 'script'
        option path '/var/etc/socat.include'
        option reload '1'

config include 'ssr_mudb_server'
        option type 'script'
        option path '/var/etc/ssr_mudb_server.include'
        option reload '1'

config rule 'kms'
        option name 'kms'
        option target 'ACCEPT'
        option src 'wan'
        option proto 'tcp'
        option dest_port '1688'

config include 'openclash'
        option type 'script'
        option path '/var/etc/openclash.include'
        option reload '1'

config include 'shadowsocksr'
        option type 'script'
        option path '/var/etc/shadowsocksr.include'
        option reload '1'

config rule 'openvpn'
        option name 'openvpn'
        option target 'ACCEPT'
        option src 'wan'
        option proto 'tcp udp'
        option dest_port '1194'

config zone 'vpn'
        option name 'vpn'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option masq '1'
        list network 'vpn0'

config forwarding 'vpntowan'
        option src 'vpn'
        option dest 'wan'

config forwarding 'vpntolan'
        option src 'vpn'
        option dest 'lan'

config forwarding 'lantovpn'
        option src 'lan'
        option dest 'vpn'

config include 'unblockmusic'
        option type 'script'
        option path '/var/etc/unblockmusic.include'
        option reload '1'

config include 'adbyby'
        option type 'script'
        option path '/var/etc/adbyby.include'
        option reload '1'

config rule 'adblock'
        option name 'adblock'
        option target 'DROP'
        option src 'wan'
        option proto 'tcp'
        option dest_port '8118'

config include 'mia'
        option type 'script'
        option path '/etc/mia.include'
        option reload '1'

config include 'softethervpn'
        option type 'script'
        option path '/usr/share/softethervpn/firewall.include'
        option reload '1'

config include 'v2ray_server'
        option type 'script'
        option path '/var/etc/v2ray_server.include'
        option reload '1'

config include 'wrtbwmon'
        option type 'script'
        option path '/etc/wrtbwmon.include'
        option reload '1'

config zone 'docker'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option name 'docker'
        list network 'docker'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'PS5 Remote Play'
        option src 'wan'
        option src_dport '987'
        option dest_ip '192.168.1.16'
        option dest_port '987'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'PS5 Remote Play 2'
        option src 'wan'
        option src_dport '9295-9297'
        option dest_ip '192.168.1.16'
        option dest_port '9295-9297'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'PS5 Remote Play 3'
        option src 'wan'
        option src_dport '9302-9304'
        option dest_ip '192.168.1.16'
        option dest_port '9302-9304'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'SFTP 1'
        option src 'wan'
        option src_dport '22'
        option dest_ip '192.168.1.140'
        option dest_port '22'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'SFTP 2'
        option src 'wan'
        option src_dport '137-139'
        option dest_ip '192.168.1.140'
        option dest_port '137-139'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'SFTP 3'
        option src 'wan'
        option src_dport '445'
        option dest_ip '192.168.1.140'
        option dest_port '445'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Plex'
        option src 'wan'
        option src_dport '32400'
        option dest_ip '192.168.1.140'
        option dest_port '32400'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Ubooquity'
        option src 'wan'
        option src_dport '2202-2203'
        option dest_ip '192.168.1.140'
        option dest_port '2202-2203'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Ubooquity 2'
        option src 'wan'
        option src_dport '6080'
        option dest_ip '192.168.1.140'
        option dest_port '6080'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'OMBI'
        option src 'wan'
        option src_dport '5000'
        option dest_ip '192.168.1.140'
        option dest_port '5000'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Skyrim Together'
        option src 'wan'
        option src_dport '10578'
        option dest_ip '192.168.1.140'
        option dest_port '10578'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'FoF'
        option src 'wan'
        option src_dport '27015'
        option dest_ip '192.168.1.140'
        option dest_port '27015'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Gamestream 1'
        option src 'wan'
        option src_dport '47984'
        option dest_ip '192.168.1.140'
        option dest_port '47984'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Gamestream 2'
        option src 'wan'
        option src_dport '47989'
        option dest_ip '192.168.1.140'
        option dest_port '47989'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Gamestream 3'
        option src 'wan'
        option src_dport '47998-48000'
        option dest_ip '192.168.1.140'
        option dest_port '47998-48000'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Gamestream 4'
        option src 'wan'
        option src_dport '48002'
        option dest_ip '192.168.1.140'
        option dest_port '48002'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Gamestream 5'
        option src 'wan'
        option src_dport '48010'
        option dest_port '48010'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Parsec 1'
        option src 'wan'
        option src_dport '31111'
        option dest_ip '192.168.1.140'
        option dest_port '31111'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option name 'Parsec 2'
        option src 'wan'
        option src_dport '22111'
        option dest_ip '192.168.1.140'
        option dest_port '22111'

config rule
        option name 'Allow-DHCPv6-replies'
        option family 'ipv6'
        list proto 'udp'
        list proto 'udp'
        option src 'wan'
        option src_port '547'
        option dest_port '546'
        option target 'ACCEPT'

Any help is really appreciated I just don't think I can figure this out on my own I've tried random solutions I see online, repeating the configs on the guide page here https://openwrt.org/docs/guide-user/network/ipv6/configuration and on this video https://www.youtube.com/watch?v=LJPXz8eA3b8 but nothing seems to change

See IPv6 doesn't work for connected devices

Please consider using official OpenWrt image.

Okay I've just attempted that so now my configs are as follows
Network:

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fddd::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option device 'br-lan'
        option ipaddr '192.168.1.1'
        option ip6assign '64'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'
        option ipv6 'auto'

config interface 'vpn0'
        option proto 'none'
        option device 'tun0'

config interface 'docker'
        option device 'docker0'
        option proto 'none'
        option auto '0'

config device
        option type 'bridge'
        option name 'docker0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        option promisc '1'

config device
        option name 'eth1'

config device
        option name 'eth0'

config device
        option name 'eth0'

config interface 'WAN6'
        option proto 'dhcpv6'
        option device '@wan'
        option reqaddress 'try'
        option reqprefix '64'

DHCP:

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '101'
        option limit '150'
        option leasetime '24h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'Abwezi-PC'
        option dns '1'
        option mac '04:D9:F5:7E:18:54'
        option ip '192.168.1.140'

config host
        option dns '1'
        option mac '60:22:32:2E:8C:60'
        option ip '192.168.1.2'
        option name 'U6-LR'

config host
        option name 'TL-WPA8631P'
        option dns '1'
        option mac '54:AF:97:A8:F7:A8'
        option ip '192.168.1.4'

config host
        option dns '1'
        option mac '00:E4:21:44:1B:93'
        option ip '192.168.1.16'
        option name 'uknow'

config host
        option mac '64:B5:C6:B5:FC:04'
        option ip '192.168.1.13'
        option name 'uknow'
        option dns '1'

config host
        option name 'gbscontrol'
        option dns '1'
        option mac '3C:61:05:E3:63:39'
        option ip '192.168.1.5'

config host
        option name 'UAP-LR'
        option dns '1'
        option mac '04:18:D6:66:12:7D'
        option ip '192.168.1.3'

config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'

config dhcp 'WAN6'
        option interface 'WAN6'
        option ignore '1'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

Still I cannot ping -6 google from router or run test-ipv6 website successfully. I will try the official image but was hoping to avoid obviously since everything else works fine so far. Do you have any other suggestions before that please?

There's a lot in those configs (a vpn and Docker etc) and a lot wrong like putting DHCP server options in the network file instead of /etc/config/dhcp. You may want to run another SD card with an official build in a near default configuration strictly to test IPv6 first.

A default wan6 is just this:

config interface 'wan6'
    option device '@wan'
    option proto 'dhcpv6'

After bringing this up, check ifstatus wan6 to see what the ISP sent you. If your service doesn't offer a routed prefix but the wan does get a full /64, you'll need to use relay mode. It looks like you were trying to do that but didn't designate wan6 as the relay master in /etc/config/dhcp.

Okay so I've went ahead and deleted all the unnecessary entries in the network config that I could since I don't use any of them, deleted wan6 and just added a basic one like you said so this is my config now:

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fddd::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option device 'br-lan'
        option ipaddr '192.168.1.1'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'
        option ipv6 'auto'

config interface 'wan6'
        option proto 'dhcpv6'
        option device '@wan'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        option promisc '1'

config device
        option name 'eth1'

config device
        option name 'eth0'

config interface 'docker'
        option device 'docker0'
        option proto 'none'
        option auto '0'

config device
        option type 'bridge'
        option name 'docker0'

and this is the result of ifstatus wan6

{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 130,
        "l3_device": "eth1",
        "proto": "dhcpv6",
        "device": "eth1",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2605:a000:ffc0:e7:29f1:33a0:187:9d74",
                        "mask": 128,
                        "preferred": 595388,
                        "valid": 595388
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2603:6011:3b03:4bc5::",
                        "mask": 64,
                        "preferred": 595388,
                        "valid": 595388,
                        "class": "wan6",
                        "assigned": {

                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::201:5cff:fe8d:1246",
                        "metric": 512,
                        "valid": 1796,
                        "source": "2603:6011:3b03:4bc5::/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::201:5cff:fe8d:1246",
                        "metric": 512,
                        "valid": 1796,
                        "source": "2605:a000:ffc0:e7:29f1:33a0:187:9d74/128"
                }
        ],
        "dns-server": [
                "2001:1998:f00:1::1",
                "2001:1998:f00:2::1"
        ],
        "dns-search": [
                "search.charter.com"
        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "00170020200119980f0000010000000000000001200119980f00000200000000000000010018001406736561726368076368617274657203636f6d00"
        }
}

ping -6 google still reports network unreachable. Should I attempt to use relay mode from here?

You need to add what is marked as solution in the topic I linked in my first response.

Okay I have added those entries as well so now they look like this
Nework:

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fddd::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option device 'br-lan'
        option ipaddr '192.168.1.1'
        option ip6assign '64'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'
        option ipv6 'auto'

config interface 'wan6'
        option proto 'dhcpv6'
        option device '@wan'
        option reqaddress 'try'
        option reqprefix '64'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        option promisc '1'

config device
        option name 'eth1'

config device
        option name 'eth0'

config interface 'docker'
        option device 'docker0'
        option proto 'none'
        option auto '0'

config device
        option type 'bridge'
        option name 'docker0'

DHCP:

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '101'
        option limit '150'
        option leasetime '24h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ra_default '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'Abwezi-PC'
        option dns '1'
        option mac '04:D9:F5:7E:18:54'
        option ip '192.168.1.140'

config host
        option dns '1'
        option mac '60:22:32:2E:8C:60'
        option ip '192.168.1.2'
        option name 'U6-LR'

config host
        option name 'TL-WPA8631P'
        option dns '1'
        option mac '54:AF:97:A8:F7:A8'
        option ip '192.168.1.4'

config host
        option dns '1'
        option mac '00:E4:21:44:1B:93'
        option ip '192.168.1.16'
        option name 'uknow'

config host
        option mac '64:B5:C6:B5:FC:04'
        option ip '192.168.1.13'
        option name 'uknow'
        option dns '1'

config host
        option name 'gbscontrol'
        option dns '1'
        option mac '3C:61:05:E3:63:39'
        option ip '192.168.1.5'

config host
        option name 'UAP-LR'
        option dns '1'
        option mac '04:18:D6:66:12:7D'
        option ip '192.168.1.3'

config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'

But still all tests fail

Let's check after reboot:
ifstatus lan
ifstatus wan6
ip -6 r

Okay I've rebooted.

ifstatus lan:

{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 1933,
        "l3_device": "br-lan",
        "proto": "static",
        "device": "br-lan",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [
                {
                        "address": "192.168.1.1",
                        "mask": 24
                }
        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "2603:6011:3b03:4bc5::",
                        "mask": 64,
                        "preferred": 591961,
                        "valid": 591961,
                        "local-address": {
                                "address": "2603:6011:3b03:4bc5::1",
                                "mask": 64
                        }
                },
                {
                        "address": "fddd::",
                        "mask": 64,
                        "local-address": {
                                "address": "fddd::1",
                                "mask": 64
                        }
                }
        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}

ifstatus wan6:

{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 1990,
        "l3_device": "eth1",
        "proto": "dhcpv6",
        "device": "eth1",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2605:a000:ffc0:e7:29f1:33a0:187:9d74",
                        "mask": 128,
                        "preferred": 591897,
                        "valid": 591897
                }
        ],
        "ipv6-prefix": [
                {
                        "address": "2603:6011:3b03:4bc5::",
                        "mask": 64,
                        "preferred": 591897,
                        "valid": 591897,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2603:6011:3b03:4bc5::",
                                        "mask": 64
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::201:5cff:fe8d:1246",
                        "metric": 512,
                        "valid": 1793,
                        "source": "2603:6011:3b03:4bc5::/64"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::201:5cff:fe8d:1246",
                        "metric": 512,
                        "valid": 1793,
                        "source": "2605:a000:ffc0:e7:29f1:33a0:187:9d74/128"
                }
        ],
        "dns-server": [
                "2001:1998:f00:1::1",
                "2001:1998:f00:2::1"
        ],
        "dns-search": [
                "search.charter.com"
        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "00170020200119980f0000010000000000000001200119980f00000200000000000000010018001406736561726368076368617274657203636f6d00"
        }
}

ip -6 r:

default from 2603:6011:3b03:4bc5::/64 via fe80::201:5cff:fe8d:1246 dev eth1 proto static metric 512 pref medium
default from 2605:a000:ffc0:e7:29f1:33a0:187:9d74 via fe80::201:5cff:fe8d:1246 dev eth1 proto static metric 512 pref medium
2603:6011:3b03:4bc5::/64 dev br-lan proto static metric 1024 pref medium
unreachable 2603:6011:3b03:4bc5::/64 dev lo proto static metric 2147483647 pref medium
fddd::/64 dev br-lan proto static metric 1024 pref medium
unreachable fddd::/48 dev lo proto static metric 2147483647 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
fe80::/64 dev eth1 proto kernel metric 256 pref medium
fe80::/64 dev ifb4eth1 proto kernel metric 256 pref medium

Is wan6 assigned to zone wan?
What happens when you ping -6 something from the router ?

Yes I checked and wan6 is automatically set to the 'wan' firewall zone.

I am able to ping -6 all of these ipv6 addresses assigned to my computer from the router. When I run ping commands even -4 on the router through ssh it never stops sending packets though is this normal behavior?

Try pinging something external.
Yes, you will need to stop it with ^C, otherwise add -c {number of pings} on the command line.

Okay thank you! Trying again to ping external sites but sadly still doesn't work, this time I tried ipv6-test.com

ping -6 ipv6-test.com -c 4

PING ipv6-test.com (2001:41d0:701:1100::29c8): 56 data bytes
ping: sendto: Network unreachable

Try the same from the LAN computer.
Your router's LAN IPv6 address is now reachable from the Internet, you may want to setup a firewall rule.

That also gives an error

ping -6 ipv6-test.com

Pinging ipv6-test.com [2001:41d0:701:1100::29c8] with 32 bytes of data:
Destination net unreachable.
Destination net unreachable.
Destination net unreachable.
Destination net unreachable.

Ping statistics for 2001:41d0:701:1100::29c8:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)
ping -6 google.com

Pinging google.com [2607:f8b0:4009:80a::200e] with 32 bytes of data:
Destination net unreachable.
Destination net unreachable.
Destination net unreachable.
Destination net unreachable.

Ping statistics for 2607:f8b0:4009:80a::200e:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)

At first glance everything looks right, see if using official image will make any difference.

So I won't be able to re flash the router for a little bit but while I have free time at work I am still messing with the router remotely and I find that I'm in a situation more like the thread you linked to in the beginning where my router is getting ipv6 and pings successfully, now it is just my LAN devices that don't have IPV6 detected on the test website and can't ping IPV6 sites.

My current config
Nework:

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option packet_steering '1'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option device 'br-lan'
        option ipaddr '192.168.1.1'
        option delegate '0'
        option ip6assign '64'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'
        option ipv6 'auto'

config interface 'wan6'
        option proto 'dhcpv6'
        option device '@wan'
        option reqaddress 'try'
        option reqprefix '64'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        option promisc '1'

config device
        option name 'eth1'

config device
        option name 'eth0'

config interface 'docker'
        option device 'docker0'
        option proto 'none'
        option auto '0'

config device
        option type 'bridge'
        option name 'docker0'

DHCP:

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '101'
        option limit '150'
        option leasetime '24h'
        option dhcpv4 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option dhcpv6 'server'
        option ra_default '2'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'Abwezi-PC'
        option dns '1'
        option mac '04:D9:F5:7E:18:54'
        option ip '192.168.1.140'

config host
        option dns '1'
        option mac '60:22:32:2E:8C:60'
        option ip '192.168.1.2'
        option name 'U6-LR'

config host
        option name 'TL-WPA8631P'
        option dns '1'
        option mac '54:AF:97:A8:F7:A8'
        option ip '192.168.1.4'

config host
        option dns '1'
        option mac '00:E4:21:44:1B:93'
        option ip '192.168.1.16'
        option name 'uknow'

config host
        option mac '64:B5:C6:B5:FC:04'
        option ip '192.168.1.13'
        option name 'uknow'
        option dns '1'

config host
        option name 'gbscontrol'
        option dns '1'
        option mac '3C:61:05:E3:63:39'
        option ip '192.168.1.5'

config host
        option name 'UAP-LR'
        option dns '1'
        option mac '04:18:D6:66:12:7D'
        option ip '192.168.1.3'

config dhcp 'wan6'
        option interface 'wan6'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'
        option master '1'

Got around to reflashing a new img today and it works right away I guess the prebuilt fw was causing the problem in some way after all. Thanks for the help!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.