Trouble Flashing openwrt to a Linksys EA6350 V4b

I'm having some trouble when trying to flash openwrt into a Linksys EA6350 V4b. I've started with it using the by logging into the router and using the Linksys GUI to flash
Step 1 Flash "openwrt-22.03.5-ramips-mt7621-linksys_ea6350-v4-squashfs-factory.bin" is successful.

Step 2 Flash "openwrt-22.03.5-ramips-mt7621-linksys_ea6350-v4-initramfs-kernel.bin" and I get a message from the router stating "This firmware file wont work on this router. If you downloaded it from linksys it may have become corrupted."

I have downloaded the file for a second time and still get the same message.. Any suggestions would be appreciated. I'm guessing I probably have downloaded an incorrect file based upon the error message.
Thanks in advance.

OOPS - Title has typo. Router is Linksys EA6350 V4B

You just need the factory image to install your device. The initramfs file is meant for recovery only.

1 Like

Thank you very much for your quick response. I've tried it again and with similar failure.

First, flashed via Linksys GUI the "openwrt-22.03.5-ramips-mt7621-linksys_ea6350-v4-squashfs-factory.bin" and that was successful - and it rebooted to standard Linksys gui.

Second, flashed via Linksys gui the "openwrt-22.03.5-ramips-mt7621-linksys_ea6350-v4-squashfs-sysupgrade.bin" file and got a similar result telling me that I have an invalid firmware file

So I'm guessing I still may be trying with an incorrect file.

Sysupgrade file can only be handled by the the sysupgrade command and Luci, while in OpenWrt. So this error message is normal, Linksys GUI doesn't know how to handle this file.
You only need to flash the factory file from Linksys GUI to install OpenWrt to your device.

  • initramfs file is for low-level recovery.
  • factory file is for flashing within the vendor GUI.
  • sysupgrade file is for upgrading within OpenWrt.

Have you read this? I have a device with such issue, it's tricky but easy to solve once you have understood.

1 Like

Again, Thank you for the quick response. I had read the item you referenced but I think some of it went over my head. I have read it again and know how I want to proceed but will defer that until tomorrow when I am fresh. Thanks for the coaching Will be back tomorrow - hopefully with a success story.

I can explain in a private mail if you want. It took me several hours to understand+ reading infos. You'll save some time.

I think I now understand so let me give it a try. I had previously downloaded the factory image from Linksys and had done the first step successfully. I'll get back to you

Remember that you must flash OpenWrt on partition A.

Flash OpenWrt. If it boots, than it's on partition A. Apply the code to /etc/rc.local. reboot several times (3+), it should be fine.

If you reboot to Linksys, than Linksys is on partition A and you tried to flash OpenWrt on partition B. Flash again Linksys. It will be on partition B. You can now flash Openwrt, it will be on partition A.

Success! I did the two flashes as prescribed and was able to log in as root and made the changes to prevent the fallback. Rebooted 5 or more times and still can log in as root. So that part is good. When I attempt to connect via http: to, I get a blue screen but nothing else is populated. But I can telnet to it and file structure so I know I have success thus far. Going to do some more reading.

And once more, thank you very much for the coaching.

1 Like

This is a cache issue from the browser. Delete it or use a private session. Nothing serious.
If it boots 5 times, than you have succeeded. Save the settings.
Do not try to install OpenWrt on the other partition. Do not sysupgrade, it will be on the other partition.
To upgrade: use the manual power button trick. It will switch partition and boot to Linksys. Flash the newer factory image. Yes, factory image, not sysupgrade image. Restore the settings. It's painfull way, but the only one.
Well done.

Have spent several hours reading and doing my configuration and things are working well - though a lot of it is over my head due to my lack of knowledge of many of the terms. So thank you again for all your help and coaching.

I do have a related question. In your last response to me, you stated "Do not sysupgrade. So just so I'm clear, I should never use the openwrt feature to perform the system upgrade to openwrt. I must always revert to Linksys image and do the linksys factory image update before applying the openwrt update. Is that correct?

1 Like

Exact. If you do so it will flash OpenWrt on B, and than your device will become instable. You must keep Linksys on B.

Not this.
Reverse to Linksys (on B), flash the new OpenWrt factory image: it will be flashed on A, over the actual one. Restore the settings. Nothing more.

You now have on A a newer OpenWrt than the previous. At the end, it seems like an upgrade, nevertheless you have not used a sysupgrade file.