Trouble finding images for tl-wa850re-v2


About a month ago I installed LEDE on a tl-wa850re-v2 and configured it as a wifi extender - everything working perfectly fine.

Now I'm looking to do the same thing again on another tl-wa850re-v2 - but I can't find the bin any more.

On the wiki page here
the link to
gives a 404

I also tried building the image myself by downloading the image builder and running
make image PROFILE=tl-wa850re-v2 PACKAGES="-ppp -ppp-mod-pppoe"
but while this builds, it produces no factory.bin file

During build, these error messages pop up:

os-image partition too big (more than 1376256 bytes): Success
cp: cannot stat '/lede-imagebuilder-ar71xx-generic.Linux-x86_64/build_dir/target-mips_24kc_musl/linux-ar71xx_generic/tmp/lede-ar71xx-generic-tl-wa850re-v2-squashfs-sysupgrade.bin': No such file or directory

cp: cannot stat '/lede-imagebuilder-ar71xx-generic.Linux-x86_64/build_dir/target-mips_24kc_musl/linux-ar71xx_generic/tmp/lede-ar71xx-generic-tl-wa850re-v2-squashfs-factory.bin': No such file or directory

So, in essence my question is: how can I get a tl-wa850re-v2 factory image?

There is no longer a way to officially support this device.
Available flash space is not enough for default LEDE image.

You can try to disable some packages, kernel options and reconfigure kernel/rootfs partitions layout.

Too bad :frowning:
Any hints on which kernel options & packages I could disable and how to reconfigure the partitions layout? I'm pretty new to lede.

I have the exact same problem. In fact, as i only need it as a "bridge AP", i tried removing everything else with:

make image PROFILE=tl-wa850re-v2 PACKAGES="wavemon uhttpd uhttpd-mod-ubus libiwinfo-lua luci-base luci-app-firewall luci-mod-admin-full luci-theme-bootstrap -opkg -libmedtls -ppp -kmod-nf-ipt -kmod-nf-conntrack -kmod-ipt-core -kmod-ipt-conntrack -kmod-nf-nat -dnsmasq -kmod-ipt-nat -firewall -odhcpd-ipv6only -kmod-ppp -kmod-pppoe -kmod-pppox -kmodusb-core -kmod-usb-ohci -kmod-usb2 -ppp-mod-pppoe -ip6tables -odhcp6c -kmod-ipv6 -kmod-ip6tables -odhcpd -iptables -luci-proto-ipv6 -kmod-nf-ipt6 -kmod-nf-conntrack6 -libip6tc"

Still got the messages saying that i had to make the images smaller than ~1.37mb, so i tried compiling without GPIO/Wireless, got it down to less than that (about 1.2mb), but still got the same error saying that 1.2mb > 1.37mb !?

 make image PROFILE=tl-wa850re-v2 PACKAGES="-wavemon -uhttpd -uhttpd-mod-ubus -libiwinfo-lua -luci-base -luci-app-firewall -luci-mod-admin-full -luci-theme-bootst
rap -opkg -libmedtls -ppp -kmod-nf-ipt -kmod-nf-conntrack -kmod-ipt-core -kmod-ipt-conntrack -kmod-nf-nat -dnsmasq -kmod-ipt-nat -firewall -odhcpd-ipv6only -kmod-ppp -kmod-pppoe -kmod-pppox -kmodusb-core -kmod-usb-ohci -kmo
d-usb2 -ppp-mod-pppoe -ip6tables -odhcp6c -kmod-ipv6 -kmod-ip6tables -odhcpd -iptables -luci-proto-ipv6 -kmod-nf-ipt6 -kmod-nf-conntrack6 -libip6tc -logd -kmod-ath -kmod-ath9k -libiwinfo -rssileds -kmod-gpio-button-hotplug"


Cleaning up

Activating init scripts

Building images...
22+1 records in
23+0 records out
1507328 bytes (1.5 MB) copied, 0.00115766 s, 1.3 GB/s
Image Name:   MIPS OpenWrt Linux-4.9.70
Created:      Sat Dec 23 19:43:06 2017
Image Type:   MIPS Linux Kernel Image (lzma compressed)
Data Size:    1499997 Bytes = 1464.84 kB = 1.43 MB
Load Address: 80060000
Entry Point:  80060000
Parallel mksquashfs: Using 1 processor
Creating 4.0 filesystem on /opt/LEDE_DEC_17/openwrt-imagebuilder-ar71xx-generic.Linux-x86_64/build_dir/target-mips_24kc_musl/linux-ar71xx_generic/root.squashfs, block size 262144.
Pseudo file "/dev" exists in source filesystem "/opt/LEDE_DEC_17/openwrt-imagebuilder-ar71xx-generic.Linux-x86_64/build_dir/target-mips_24kc_musl/root-ar71xx/dev".
Ignoring, exclude it (-e/-ef) to override.
[=================================================================================================================================================================================================================/] 278/278 100%
Exportable Squashfs 4.0 filesystem, xz compressed, data block size 262144
        compressed data, compressed metadata, compressed fragments, no xattrs
        duplicates are removed
Filesystem size 980.48 Kbytes (0.96 Mbytes)
        38.89% of uncompressed filesystem size (2520.92 Kbytes)
Inode table size 3472 bytes (3.39 Kbytes)
        21.36% of uncompressed inode table size (16253 bytes)
Directory table size 4888 bytes (4.77 Kbytes)
        54.29% of uncompressed directory table size (9004 bytes)
Number of duplicate files found 33
Number of inodes 485
Number of files 276
Number of fragments 5
Number of symbolic links  158
Number of device nodes 1
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 50
Number of ids (unique uids + gids) 1
Number of uids 1
        root (0)
Number of gids 1
        root (0)
1960+1 records in
1960+1 records out
1004012 bytes (1.0 MB) copied, 0.00258099 s, 389 MB/s
os-image partition too big (more than 1376256 bytes): Success
cp: cannot stat '/opt/LEDE_DEC_17/openwrt-imagebuilder-ar71xx-generic.Linux-x86_64/build_dir/target-mips_24kc_musl/linux-ar71xx_generic/tmp/openwrt-ar71xx-generic-tl-wa850re-v2-squashfs-sysupgrade.bin': No such file or directo
1960+1 records in
1960+1 records out
1004012 bytes (1.0 MB) copied, 0.00256269 s, 392 MB/s
os-image partition too big (more than 1376256 bytes): Success
cp: cannot stat '/opt/LEDE_DEC_17/openwrt-imagebuilder-ar71xx-generic.Linux-x86_64/build_dir/target-mips_24kc_musl/linux-ar71xx_generic/tmp/openwrt-ar71xx-generic-tl-wa850re-v2-squashfs-factory.bin': No such file or directory
padding image to 00100000
padding image to 000f6000
padding image to 000f8000
padding image to 00100000
8+1 records in
9+0 records out
1179648 bytes (1.2 MB) copied, 0.000938127 s, 1.3 GB/s

Calculating checksums...
[root@LEDE openwrt-imagebuilder-ar71xx-generic.Linux-x86_64]#

Also looking for this firmware. Are the older firmware versions archived anywhere?

+1 I want the "old" firmware. :disappointed_relieved:

Since TL-WA850RE v2 has only snapshot release, that doesn't help.
There is no "previous release" for easy downloading.

Didn't have time to check whether it uses snapshots or not, so posted the link just in case.

The older version :frowning:
any one can upload them please :slight_smile:

atm we have a some month old full snapshot imagebuilder-build, acessable via a brandnew libremesh-chef webui :-o -> Distribution: Freifunk Leipzig

its not configured yet for Freifunk Mesh usage, but 850-v2 gives you an image.. so test it (also in advanced mode), or modify needed packages..

1 Like

Thank you @freifunkufo
But i can't try this, because im not able to recover it if that will break them so i just need the old version of openwrt-wa850 V2

Do you still have the old router? Perhaps you could login and extract the image from mtd?

Alternatively, have you tried using imagebuilder from v18?

I managed to build and boot from a working image, includes luci and saves config:

make image PROFILE=tl-wa850re-v2 PACKAGES="luci -ppp -ppp-mod-pppoe -kmod-usb-core -kmod-usb-ohci -kmod-usb2 -kmod-usb-ledtrig-usbport -odhcpd-ipv6only -ip6tables -wpad-mini -luci-proto-ppp -odhcp6c -kmod-ip6tables -kmod-nf-ipt6 -kmod-nf-conntrack6 -libip6tc"

Once you have an image that boots and saves, you can then try adding some of the packages back.

I have uploaded an image that i built using openwrt imagebuilder.
Default settings, no luci so you ll need to edit the config files in /etc/config by hand.
No opkg either but you cant install anything with 4MB of flash anyway.
It will do basic AP functionality there is just enough remaining space for this.

Isn't "default settings" too big? What parameters did you give to "make image?"

I followed this:
Then the " Which packages can I safely remove to save space?" paragraph in the openwrt FAQ.
Ran make menuconfig in the buildroot folder, removed the stuff in the menu that is safe, then ran make to build.
I managed to build an image with luci that did not lose the few configs i did after a reboot.

they can be found here:

It has dhcpd, no firewall, no ipv6 no ppp/pppoe no opkg, only the bare minimum to run the wa850re v2 as an access point using luci. I tried this on mine and it works fine.

Filesystem usage after basic configs and a reboot:

# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2048      2048         0 100% /rom
tmpfs                    14080       428     13652   3% /tmp
/dev/mtdblock3             320       232        88  73% /overlay
overlayfs:/overlay         320       232        88  73% /
tmpfs                      512         0       512   0% /dev

still much better than the crappy original tplink firmware...

1 Like

please can you upload it? link is not working

1 Like

Could you please send me the functional picture? for my wa850 v2, thanks.

hey, could you please share this particular image. The link isn't working. Please help!
I want to use it as a repeater - that would entail 2 settings (Client-WDS) and AP. Will this modded firmware allow both of those to be stored?
I'm unaware how much space these settings take, please advice.