I have recently set up my router with the newest stable OpenWRT firmware and for the most part it works completely fine. The configuring I have done is setting timezone and enabling WiFi. There is however one specific website which I seem to be unable to connect to. The website in question is https://aftenbladet.no. IPv4 pings have 100% packet loss, and when I try to connect through a browser it is just stuck loading.
I am fully able to connect to the website through another router or through mobile data, so I know that the website isn't down. Using a VPN does nothing, so I am pretty sure
PING openwrt.org (64.226.122.113): 56 data bytes
64 bytes from 64.226.122.113: seq=0 ttl=52 time=33.452 ms
64 bytes from 64.226.122.113: seq=1 ttl=52 time=32.242 ms
64 bytes from 64.226.122.113: seq=2 ttl=52 time=32.205 ms
64 bytes from 64.226.122.113: seq=3 ttl=52 time=32.175 ms
64 bytes from 64.226.122.113: seq=4 ttl=52 time=32.183 ms
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
config defaults
option syn_flood 1
option input REJECT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1
config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT
# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option dest_port 546
option family ipv6
option target ACCEPT
config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT
# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT
config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT
Looks like an entirely default config (aside from wifi). There's no reason within OpenWrt that you would not have access to that site.
When you ran your tests earlier, were they from the router or a client behind the router?
What happens if you connect another router (or your computer directly) to your ISP instead of OpenWrt? Pro-tip: pay attention to the IP address you have on your OpenWrt router's WAN and compare that to whatever you use to test in lieu of the OpenWrt router... if different, that could be relevant.
These test were run directly from the router, but I have gotten the same results running them from my computer and phone.
Everything works without a hitch when using another router or connecting directly to my computer. I struggled to find the ip address of the other routers WAN interface, but in the end I wasn't able to find out where it was supposed to be
It is possible that there is a block on the ip address your openwrt router is using.
Try cloning the MAC address of the working router into the openwrt router (the wan port MAC address). Hopefully that will enable the openwrt router to get the same ip as your other router, and then you can try again.
The isp probably gives out the ip addresses based on the MAC address. Something was causing the specific ip address you had on your openwrt router to be unable to reach the server in question - possibly a block on the server side for security or dos protection (or other reasons, although I have no way to know why that might have happened).
By cloning the other router’s MAC address, the isp gave you the same ip as it gave to your old router. And that ip was’t blocked. So now it is working.