Trouble compiling arp-whisper on OpenWrt v23.05

Hello everyone, I'm packaging arp-whisper for OpenWrt, and I'm having some issues when I try to compile it.

I'm using v23.05 to build the package, I've added:

src-git arpw;feature/add-arp-whisper

to feeds.conf.default and then I run:

./scripts/feeds update -a

./scripts/feeds install -a

everything looks fine until this point.

The documentation says that I can run make feeds/arpw/utils/arp-whisper/download V=s to test the Makefile but it doesn't work and it's not descriptive of what the error is:

user@5673ea418fea:~/openwrt$ make feeds/arpw/utils/arp-whisper/download V=s

make[2]: Entering directory '/home/user/openwrt/scripts/config'

make[2]: 'conf' is up to date.

make[2]: Leaving directory '/home/user/openwrt/scripts/config'

time: target/linux/prereq#0.86#0.04#0.91

make[1]: Entering directory '/home/user/openwrt'

make[1]: *** No rule to make target 'feeds/arpw/utils/arp-whisper/download'. Stop.

make[1]: Leaving directory '/home/user/openwrt'

make: *** [/home/user/openwrt/include/ feeds/arpw/utils/arp-whisper/download] Error 2

The Makefile is Here

What am I doing wrong?

I really appreciate any help you can provide.

The documentation does not tell you to pass the actual path. It explicitly tells you to use package/$packagename/download.

Have you tried that?


Awesome, it was that, thank you very much.

1 Like