Tried latest on my RPi 3B+ & don't think it booted

I tried
openwrt-18.06.1-brcm2708-bcm2710-rpi-3-ext4-factory.img and the sysupgrade version following instructions to create the SD card.

I have a display plugged into the HDMI and when I power up the color swirl appears with a yellow lightning bold in upper right corner.

Almost immediately the red power LED goes out and the green LED next to it repeats 4 slow and 4 fast blinks.

I'm thinking I need to replace the contents of the boot partition with the contents of an SD card that boots. I'll try that.

I copied start.elf from an SD which boots to the openWRT SD I made and now I have the openWRT ASCI logo on my display.

1 Like

H'h. Well now I think this is a dead end and I'll just give up!

I signed onto the admin web page and attempted to set the root password and then waited. And waited. Went over to the RPi and it was unresponsive with stuff on the screen which I photographed.

Anyway I tried again with the same result (actually, it's the second attempt that I photographed).

My second attempt showed that my first attempt to set the root password was not successful.


Correction: It's not a B+, it's a B V1.2

I tried a couple more things:

  1. I tried rebuilding the image by hand in case something went wrong the first time. I set up the partitions by hand (gparted) and copied the files into the partitions (cpio) and provided a good start.elf. This SD booted so I tried the admin web page and changing the password. Got same result as before, i.e. the form of the output looks the same as in the above photo with different data except for identical "running task" numbers and "Call trace:" list. NB this is the RPi 3B v1.2 (which also has a Quectel EC25 installed on a SixFab shield).

  2. So I put the SD into a RPi 3B+ (bare board) and it booted and when I opened the admin web page I was able to set the root password and it's still running fine.

So I don't know why one works and the other does not. I hope it's not a malfunction in the RPi 3B v1.2. I feel that's unlikely and I have no idea yet how to diagnose it.

The RPi 3B v1.2 has the same behavior when setting the root password when the SixFab shield with the EC25 is not installed.

Also, when I tried to access the admin web page on the 3B v1.2 after the root password was set (using a 3B+) LuCI crashed before presenting a response.

Yet more noise.

I tried booting the 3B v1.2 with the start.elf supplied in the IMG file and it worked. but it does not work with either of my two 3B+.

So I think the start.elf supplied in the IMG files is out of date. From this page:

this quote: "8 flashes: SDRAM not recognised. You need newer bootcode.bin/start.elf firmware."