TRENDnet TEW-809UB (USB WiFi adapter) - USB2 High-Speed vs USB3 SuperSpeed

hey,

this is somewhat off-topic. i've got a couple of these devices. both of them have a micro-usb 3 port but connect to hosts as usb 2 devices (no superspeed).

i'd like to know if they are both defective or if this is "normal" behavior for this device. in the latter case, i'd have a theory: maybe trendet disabled usb3 support thought firmware because superspeed (5 Gbps) transfers caused too much RF interference because their circuit is crap and is not properly shielded.

what do you think?

thanks

I would actually suspect the USB cable being bad first. If the USB 3.0 cable pairs are broken but the USB 2.0 pair is intact, you would get exactly this behavior. Try with a known good quality USB 3.0 cable and see if it works at full USB 3.0 speeds. The cables that come in the box of most products are often trash-tier quality stuff.

Yes, USB 3.0 and Wifi 2.4 GHz can have interference problems but I have a hard time believing TRENDnet would not have noticed this during development and testing of the device.

thanks.

of course i tested thoroughly before posting: 2 different hosts, 2 different ports on each host, 2 different cables, and even 2 operating systems (linux and windoze). under all these combinations and with these same cables, another micro-usb3 device is recognized as usb3 and connects in superspeed while the two TRENDnet TEW-809UB connect as usb2.

(btw, the included cable seems quite sturdy and heavy.)

what i need is someone else testing the same device to really confirm that all of them come with usb3 factory disabled.

on linux:

[1043342.124954] usb 3-2: new high-speed USB device number 37 using xhci_hcd
[1043342.273757] usb 3-2: New USB device found, idVendor=20f4, idProduct=809a, bcdDevice= 0.00
[1043342.273768] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[1043342.273773] usb 3-2: Product: 802.11ac NIC
[1043342.273776] usb 3-2: Manufacturer: Realtek
[1043342.273778] usb 3-2: SerialNumber: 123456

on windows:

thanks!