TRENDnet AC2600 (TEW-827DRU v1.0R)


#41

I was thinking about this, and your statement that you had a difficult time makes me wonder if there isn't something else going on. Like maybe you are unintentionally performing the process to get into the Recovery Loader incorrectly.

Like I said in my previous post, I've had one or two weird instances where the image didn't write correctly. However, doing it again always cleared this up.

Maybe you are counting seconds a bit fast? Try holding the reset button down for six seconds instead of four -- there's no harm in holding it longer.

Also, I note that my instructions above say "the recovery system will not load if no ethernet cable is plugged in during boot". I need to correct that. Not only does a cable need to be plugged in, the other side needs to be active, so there needs to be an active ethernet signal on the port. This is a very subtle distinction but an important one. If you were plugging into your PC and the port wasn't actually set up/active yet, that would cause the Recovery Loader to not run.


#42

@jmomo

I just bought a 827 dru, but here in Brazil unfortunately sell only version 2.0.

Do you think that one day we will have openwrt for version 2.0?
I'm thinking of returning the store this router with version 2.0, and buy version 1.0 used. Is it worth it?

One of the points I most wanted to have on the router was openwrt support.
Another question, does the Streamboost feature of version 1.0 still work with openwrt?

Thank you for your help


#43

The Streamboost feature is not there in OpenWrt. But it isn't needed. The OpenWrt software works so good I don't miss Streamboost at all. If you can exchange your router for a version 1.0R then do it. With the OpenWrt software it's like having a new router. And everything works on it. All lights, IPV6, all work great. Connections including wifi never drop out. On the stock Trendnet software I could not keep an IPV6 connection longer than 20 minutes no matter what I did. Get the V1.0R if you can, install OpenWrt and don't look back. You will love it.


#44

The TEW-827DRU version 2 is a completely different model with completely different hardware. I consider the re-use of model numbers like this immoral and abusive.

I can't say if the v2 will ever be supported by OpenWRT. It would be safe for you to assume that it won't be until it is. I won't be working on it unless someone gifts me some hardware.

There are lots of good deals out there for used devices based on the ipq806x SoC, like the tew827dru. All of the routers based on ipq806x are pretty awesome, though almost all have little bugs or issues of some kind, including this one. Check out the Linksys EA8500, Netgear D7500v2, Netgear D7800, TP-Link C2600, and Zyxel NBG6817.

I was able to get a spare used TEW-827DRU v1 off ebay here in the USA for $30 a few months ago.

The TEW-827DRU's upsides are that it has a larger SLC NAND flash than most devices, so it has more room for packages and storage. However, the NBG6817 has a massive 4GB eMMC, so it's even bigger.

The EA8500 has an ESATA/USB2 port, which is pretty cool, but only has one USB3 port.

The Netgear models all have little issues but they are very well supported.

The C2600 is pretty boring but common and works. Beware that I think there are issues with different versions being supported and the serial ports on them are not available unless you solder in a level shifter and do a bunch of other work. Be sure to research.

If you can find a use TEW-827DRU v1, go for it! Otherwise look for one of the models mentioned above. Be sure to research the device a little before buying, not after.

As for StreamBoost, it's a completely proprietary QoS mechanism and will never be supported by OpenWRT. However, it isn't needed because there are open-source QoS mechanisms available that are comparable if not better. Google for "openwrt fq_codel cake sqm". Note that my builds are very basic and don't include these but you can install them easily since there is so much free space on this device.

Good luck!


#45

Thank you for your answer, tomorrow I'll give you a look at these suggested devices (I have to see if you have it here in Brazil).

but returning to 827dru 1.0: the bugs you said the device has, are only those that are mentioned in the beginning of the topic? (flash method and led button)? or does the 827dru have any additional bugs? Thank you.


#46

Correct. At this point there are no known bugs, just some unimplemented features like the LED on/off button and the redundant partition system.

The biggest downside of getting a used TEW-827DRU was that it was less popular than some of those other models, mostly because it was priced a bit higher, so it may be harder to find. If you can find one, go for it!


#47

hello dear classmates! first of all I want to thank your great work in making our router TEW-827DRU v1.0R manage to run openwrt. Jmomo thank you very much! .

1-wanted to ask if it really worth changing from factory to openwrt?

2-Is the firmware change dangerous? Is it possible to return to the factory state? with the tplink it is very simple and transmits tranquility.

I currently have it in the factory and I do not try to install openwrt (I have openwrt in other routers, very happy indeed ...) I mainly use the TEW-827DRU v1.0R as a torrent client and its small NAS configuration through the samba protocol, I guess What is the service that I activated, although I do not really notice it (maybe because it really works great?) haha ​​sarcasm ...) and I see files from the PC with kodi, the speed of file copy, I notice slow 50mbs ... its usb 3.0 is connected to a hdd unit segate of 2TB portable (all this configuration is lan through port 1000mb). To finish I can use the openvpn function to enter from anywhere to supply it. Through openwrt I can install packages for these specific functions and for what you mention your memory is quite large. I am a new user in this world of openwrt, thanks for your time and sorry my poor english I am from Argentina. For the other user who wants to buy a unit of this equipment that is from Brazil, I buy it at the freeshop of the rio de janeiro airport when flying to my country (beautiful country, in love with its beaches! Buzios). I hope this information is useful to you.


#48

I dunno. Depends on you. If it's not broke, don't fix?

Read my top post. This is one of the safest type of devices to play with because it has a loader/installer in the uboot image itself and relatively easy console access inside the chassis.

Going back to OEM is easy. Just be sure to back up your current configuration and download a copy of the OEM images prior to testing. See my post above regarding restoring the OEM image.

I don't have any info about USB3 disk or samba performance. It depends on what the limiting factor is. If it's CPU or disk then OpenWRT might not be any faster. Then again, OpenWRT has a much newer linux kernel compared to the OEM image and that might offer you some benefits.

Be sure to research the packages you will need to install to configure OpenVPN, Samba, and disk storage. Most of it can probably be done through the luci web interface, but some of it might need to be done over ssh. Hopefully that's something you are comfortable with.

Good luck.


#49

hi my friend jmomo! I wanted to tell you that I found a fault in the original firmware, when I finished downloading a torrent file and wanted to transfer it or read it for the network the speed drops to 0mb when restarting the router to work optimally ... then the carnival weekend , take courage and install openwrt in tew-827dru with the http method of recovery the first time I failed, because I had not connected another cable in an ethernet port as I mentioned in a coemntario. everything went fine, but when I did a speed test on speedtest.net it gave me that I needed 10mb of speed, then I continued to configure and install some packages to create usb support and then samba and a problem with a package (kmod-usb- storage) that does not allow to install for a cinflicto with the kernel and another package (kmod-fs-ntfs) look for information in google and I did not understand very well and decided not to touch more :(. I went back to the firmaware as mentioned in his tutorial and made another time the speed test and gave me the velocity more than 10mb of the missing.I do not know what can be done to improve, on the other hand the page of start of luci google takes it as a unsafe page.Thank you for your work I hope my experience is useful.


#50

I will try to reproduce this problem myself when I have some free time.

This is because the page doesn't have a proper TLS/SSL certificate, or you were accessing the unencrypted http version of the page. There are ways to fix this but it's probably easiest and safe to simply ignore.


#51

One more data! I do not know if I explain myself well or Google translator complicates the translation. . . The speed of my ISP (Internet service provider) is 30Mbps. Running openwrt I get 16 / 18Mbps. Running the trendnet stock firmware 30 / 32Mbps ... Running openwrt something happens. Thanks for you time and dedication.


#52

ipq8065 is good for (at least) 350-400 MBit/s routing speed, including PPPoE overhead, while ipq8064 is slightly slower, that is still far beyond your observed limits. Given that the TEW-827DRU doesn't include a modem, there really shouldn't be a limiting factor.


#53

I think I know what caused this error and it should be fixed now.

There was a problem with the package list on my package server, which is why the kmod- packages failed to install.

Sorry about that. It's probably been broken for a few days now.


#54

Well I now have an issue after weeks of the router working flawlessly. I am on the latest release with the LED's and everything working. Except that today I tried to log into my router and I am locked out. I get all the usual certificate warnings when logging in. All browsers. But it seems my user name and password have been changed. Root is now automatically in my user name box. If I change that to my correct user name and use my password I am locked out. What happened? How do I get back into my router? Do I need to reflash the latest build in order to get back in? I haven't changed anything nor have I tried to log into the router in weeks. Not since my last post here. Help please.

Edit
I got into the router. But I have to use "root" as my user name. I have no idea how my user name was changed. Any ideas?


#55

That would be an issue with your browser and its way of caching user credentials. The only valid username for OpenWrt (by default) is "root".