TRENDnet AC2600 (TEW-827DRU v1.0R)

I think I know what caused this error and it should be fixed now.

There was a problem with the package list on my package server, which is why the kmod- packages failed to install.

Sorry about that. It's probably been broken for a few days now.

1 Like

Well I now have an issue after weeks of the router working flawlessly. I am on the latest release with the LED's and everything working. Except that today I tried to log into my router and I am locked out. I get all the usual certificate warnings when logging in. All browsers. But it seems my user name and password have been changed. Root is now automatically in my user name box. If I change that to my correct user name and use my password I am locked out. What happened? How do I get back into my router? Do I need to reflash the latest build in order to get back in? I haven't changed anything nor have I tried to log into the router in weeks. Not since my last post here. Help please.

I got into the router. But I have to use "root" as my user name. I have no idea how my user name was changed. Any ideas?

That would be an issue with your browser and its way of caching user credentials. The only valid username for OpenWrt (by default) is "root".

Hey everyone

There has not been an official update release in awhile. I check in on the mailing list and forums every couple of months but there hasn't been too much lately.

Most OpenWRT devices don't have the overlay space to do in-place upgrades, but ours has plenty. You can always update your packages in place on this device, though you should never use wireless when doing so (it will disconnect you), and you may need to run the upgrade commands several times, but it will work. It might also be a good idea to run such upgrades under a screen or tmux session in case you do get disconnected. Unfortunately OpenWRT doesn't do upgrades very well, unlike normal Linux distributions.

I may do a build with current upgrades built in soon here, but given the Netflix-discovered linux TCP SACK issues disclosed yesterday I think we might actually get a new 18.0.3 release.

There's some circle-jerk discussion here if interested:

If I don't see a new release upstream I'll do a new update build here in the next few weeks.

A new release of 18.06.3 and 17.01.7 is supposed to be released any day now. When that happens I'll go build and upload. It might be a week or two though as I am pretty busy right now.

Changelogs are here. It's just security stuff:

@jmomo would you be interested to use the NSS cores for routing tasks? It will definitely improve the performance of the 827DRU v1.0R.

I managed (I think) to identify the issue causing the NSS drivers to randomly reboot my R7800. Do refer to my IPQ806x NSS Drivers post.

It should be simple to change the DTS files of the 827DRU to make it work. Just follow my commit logs and apply the same changes. It should work.

Hey Quarky. Sadly I'm super busy these days and don't have a ton of time to play around with my devices. I've seen your thread and work on the NSS code for hardware acceleration before. You've definitely got my interest and I'd encourage you to keep at it.

Thanks for checking in.

I have built and uploaded new images based on OpenWRT v18.06.4. The patch set for this build is v14.

Minimal image files are here:

Minimal+luci image files are here:

There are no changes from me on this one and nothing specific for this device. It's the same patch set as the previous v18.06 builds. All of the changes for us are security patches and bugfixes.

UPDATE: I pulled the images due to a problem with the luci build's web interface not working. I will re-publish soon with verified working images.

I just flashed my router with this latest firmware, but now I get the message:

You don't have permission to access / on this server

Any ideas ?



Did some googling:

chmod -R +rX /www && chmod +x /www/cgi-bin/luci

fixed it.

regards, Louis

Thanks for letting me know. I will publish new fixed builds as soon as I figure out what the package maintainer fucked up.

Yep, it's fucked new right out of the box:

root@OpenWrt:~# ls /www/
drwxr-xr-x    4 root     root          79 Jun 27 12:18 .
drwxr-xr-x    1 root     root         288 Jan  1  1970 ..
drwxr-----    2 root     root          27 Jun 27 12:18 cgi-bin
-rw-r-----    1 root     root         495 Jun 27 12:18 index.html
drwxr-----    4 root     root          61 Jun 27 12:18 luci-static

ls $(opkg files luci-base | sort | egrep -v "^Package ")

Almost all, but not exactly all, of the files in the luci-base package have broken permissions. This strongly implies a problem with the upstream package source, but I need to make sure it's not something specific to my build process.

I don't see any bugs reported on this yet. However, I noticed that this bug isn't showing up in my personal build.

This is my fault... sort of. I updated feeds outside of my build script, which has umask 0022 set (See commit 5f80315634c66a647aed9673e10582acd8462d69). The file permission should be explicitly set during the build process, but that would be smart.

This is a bug, but it's a bug in the feeds script instead of luci.

I have built and uploaded a new images based on OpenWRT v18.06.4. The patch set for this build is v14.

This corrects a build problem with feed packages which caused incorrect file permissions. Notably, the web interface would greet you with a "Forbidden" error message on the luci build.

Anyone who installed the previous v18.06.4 images should upgrade. The problems in the last build will be automatically fixed and no further action is needed.

Minimal image files are here:

Minimal+luci image files are here:


Hi jmomo,

Thanks for the latest 18.06 build!

Just a question about whether you think you will be able to include support for the latest luci-app-openvpn snapshot package? It looks to have an option to load config from ovpn file to ease the setup of VPN through Luci.

Otherwise, I'd really appreciate any help to correctly configure interface and routing for my setup... OpenVPN starts up fine to connect to remote servers with connection confirmed in the system log:

"daemon.notice openvpn(ExpressVPN)[2872]: Initialization Sequence Completed".

But for the life of me I can't figure out why my tun0 interface and firewall VPN zone config simply doesn't want to connect to the Internet thereafter...

I would really appreciate any help.


That's just a package like any other, and this device has tons of free flash space. Update your package list and install it.

The images I publish can download and install packages from the official OpenWRT repositories just like an officially-supported device.

As for the OpenVPN stuff, I have no idea! make a post in the main support forum area for help on that.

1 Like

Hi, thanks a ton for doing this. My router seems to be crapping the bed lately. Total newb here, just going to follow your instructions and hope for the best, appreciate your work!

So I installed the firmware ...and it worked great until I started playing a game. The game in this instance was World of Warcraft. Every 5 to 10 minutes I would be disconnected from the game using ethernet ...could immediately log back in, but obviously this was untenable. Tried to figure it out, but couldn't ...forwarded ports etc. Ended up having to reflash old trendnet firmware. :frowning:

I did manage to get the snapshot packages installed, but the loading of openVPN config files then did not work. It simply never created a openVPN instance that I could later edit. I eventually reverted to your build and manualy configured all the parameters to get the VPN connection established.
Overall though, I'm just not winning with my connection to the Internet ... and getting super frustrated that I can't find a guide that clearly sets out how the routing tables, routing rules, dns settings need to match-up...

That would be an issue for another support thread since it's not specific to this hardware. You are artificially limiting your audience to a tiny number of people who almost certainly are not experts in the area you want help in.

Go post in the "Installing and Using" category and hopefully someone with OpenVPN experience can help.