TRENDnet AC2600 (TEW-827DRU v1.0R)

hello dear classmates! first of all I want to thank your great work in making our router TEW-827DRU v1.0R manage to run openwrt. Jmomo thank you very much! .

1-wanted to ask if it really worth changing from factory to openwrt?

2-Is the firmware change dangerous? Is it possible to return to the factory state? with the tplink it is very simple and transmits tranquility.

I currently have it in the factory and I do not try to install openwrt (I have openwrt in other routers, very happy indeed ...) I mainly use the TEW-827DRU v1.0R as a torrent client and its small NAS configuration through the samba protocol, I guess What is the service that I activated, although I do not really notice it (maybe because it really works great?) haha ​​sarcasm ...) and I see files from the PC with kodi, the speed of file copy, I notice slow 50mbs ... its usb 3.0 is connected to a hdd unit segate of 2TB portable (all this configuration is lan through port 1000mb). To finish I can use the openvpn function to enter from anywhere to supply it. Through openwrt I can install packages for these specific functions and for what you mention your memory is quite large. I am a new user in this world of openwrt, thanks for your time and sorry my poor english I am from Argentina. For the other user who wants to buy a unit of this equipment that is from Brazil, I buy it at the freeshop of the rio de janeiro airport when flying to my country (beautiful country, in love with its beaches! Buzios). I hope this information is useful to you.

1 Like

I dunno. Depends on you. If it's not broke, don't fix?

Read my top post. This is one of the safest type of devices to play with because it has a loader/installer in the uboot image itself and relatively easy console access inside the chassis.

Going back to OEM is easy. Just be sure to back up your current configuration and download a copy of the OEM images prior to testing. See my post above regarding restoring the OEM image.

I don't have any info about USB3 disk or samba performance. It depends on what the limiting factor is. If it's CPU or disk then OpenWRT might not be any faster. Then again, OpenWRT has a much newer linux kernel compared to the OEM image and that might offer you some benefits.

Be sure to research the packages you will need to install to configure OpenVPN, Samba, and disk storage. Most of it can probably be done through the luci web interface, but some of it might need to be done over ssh. Hopefully that's something you are comfortable with.

Good luck.

hi my friend jmomo! I wanted to tell you that I found a fault in the original firmware, when I finished downloading a torrent file and wanted to transfer it or read it for the network the speed drops to 0mb when restarting the router to work optimally ... then the carnival weekend , take courage and install openwrt in tew-827dru with the http method of recovery the first time I failed, because I had not connected another cable in an ethernet port as I mentioned in a coemntario. everything went fine, but when I did a speed test on speedtest.net it gave me that I needed 10mb of speed, then I continued to configure and install some packages to create usb support and then samba and a problem with a package (kmod-usb- storage) that does not allow to install for a cinflicto with the kernel and another package (kmod-fs-ntfs) look for information in google and I did not understand very well and decided not to touch more :(. I went back to the firmaware as mentioned in his tutorial and made another time the speed test and gave me the velocity more than 10mb of the missing.I do not know what can be done to improve, on the other hand the page of start of luci google takes it as a unsafe page.Thank you for your work I hope my experience is useful.

I will try to reproduce this problem myself when I have some free time.

This is because the page doesn't have a proper TLS/SSL certificate, or you were accessing the unencrypted http version of the page. There are ways to fix this but it's probably easiest and safe to simply ignore.

2 Likes

One more data! I do not know if I explain myself well or Google translator complicates the translation. . . The speed of my ISP (Internet service provider) is 30Mbps. Running openwrt I get 16 / 18Mbps. Running the trendnet stock firmware 30 / 32Mbps ... Running openwrt something happens. Thanks for you time and dedication.

ipq8065 is good for (at least) 350-400 MBit/s routing speed, including PPPoE overhead, while ipq8064 is slightly slower, that is still far beyond your observed limits. Given that the TEW-827DRU doesn't include a modem, there really shouldn't be a limiting factor.

I think I know what caused this error and it should be fixed now.

There was a problem with the package list on my package server, which is why the kmod- packages failed to install.

Sorry about that. It's probably been broken for a few days now.

1 Like

Well I now have an issue after weeks of the router working flawlessly. I am on the latest release with the LED's and everything working. Except that today I tried to log into my router and I am locked out. I get all the usual certificate warnings when logging in. All browsers. But it seems my user name and password have been changed. Root is now automatically in my user name box. If I change that to my correct user name and use my password I am locked out. What happened? How do I get back into my router? Do I need to reflash the latest build in order to get back in? I haven't changed anything nor have I tried to log into the router in weeks. Not since my last post here. Help please.

Edit
I got into the router. But I have to use "root" as my user name. I have no idea how my user name was changed. Any ideas?

That would be an issue with your browser and its way of caching user credentials. The only valid username for OpenWrt (by default) is "root".

Hey everyone

There has not been an official update release in awhile. I check in on the mailing list and forums every couple of months but there hasn't been too much lately.

Most OpenWRT devices don't have the overlay space to do in-place upgrades, but ours has plenty. You can always update your packages in place on this device, though you should never use wireless when doing so (it will disconnect you), and you may need to run the upgrade commands several times, but it will work. It might also be a good idea to run such upgrades under a screen or tmux session in case you do get disconnected. Unfortunately OpenWRT doesn't do upgrades very well, unlike normal Linux distributions.

I may do a build with current upgrades built in soon here, but given the Netflix-discovered linux TCP SACK issues disclosed yesterday I think we might actually get a new 18.0.3 release.

There's some circle-jerk discussion here if interested:

If I don't see a new release upstream I'll do a new update build here in the next few weeks.

A new release of 18.06.3 and 17.01.7 is supposed to be released any day now. When that happens I'll go build and upload. It might be a week or two though as I am pretty busy right now.

Changelogs are here. It's just security stuff:

https://openwrt.org/releases/18.06/changelog-18.06.3
https://openwrt.org/releases/17.01/changelog-17.01.7

@jmomo would you be interested to use the NSS cores for routing tasks? It will definitely improve the performance of the 827DRU v1.0R.

I managed (I think) to identify the issue causing the NSS drivers to randomly reboot my R7800. Do refer to my IPQ806x NSS Drivers post.

It should be simple to change the DTS files of the 827DRU to make it work. Just follow my commit logs and apply the same changes. It should work.

Hey Quarky. Sadly I'm super busy these days and don't have a ton of time to play around with my devices. I've seen your thread and work on the NSS code for hardware acceleration before. You've definitely got my interest and I'd encourage you to keep at it.

Thanks for checking in.

I have built and uploaded new images based on OpenWRT v18.06.4. The patch set for this build is v14.

Minimal image files are here:

http://jmomo.net/files/lede/TRENDnet_TEW-827DRU_20190704233207_OpenWRT_v18.06.4_minimal/bin/

Minimal+luci image files are here:

http://jmomo.net/files/lede/TRENDnet_TEW-827DRU_20190704235745_OpenWRT_v18.06.4_luci/bin/

There are no changes from me on this one and nothing specific for this device. It's the same patch set as the previous v18.06 builds. All of the changes for us are security patches and bugfixes.

UPDATE: I pulled the images due to a problem with the luci build's web interface not working. I will re-publish soon with verified working images.

I just flashed my router with this latest firmware, but now I get the message:

Forbidden
You don't have permission to access / on this server

Any ideas ?

regards,

Louis

Did some googling:

chmod -R +rX /www && chmod +x /www/cgi-bin/luci

fixed it.

regards, Louis

Thanks for letting me know. I will publish new fixed builds as soon as I figure out what the package maintainer fucked up.

Yep, it's fucked new right out of the box:

root@OpenWrt:~# ls /www/
drwxr-xr-x    4 root     root          79 Jun 27 12:18 .
drwxr-xr-x    1 root     root         288 Jan  1  1970 ..
drwxr-----    2 root     root          27 Jun 27 12:18 cgi-bin
-rw-r-----    1 root     root         495 Jun 27 12:18 index.html
drwxr-----    4 root     root          61 Jun 27 12:18 luci-static

ls $(opkg files luci-base | sort | egrep -v "^Package ")

Almost all, but not exactly all, of the files in the luci-base package have broken permissions. This strongly implies a problem with the upstream package source, but I need to make sure it's not something specific to my build process.

I don't see any bugs reported on this yet. However, I noticed that this bug isn't showing up in my personal build.

This is my fault... sort of. I updated feeds outside of my build script, which has umask 0022 set (See commit 5f80315634c66a647aed9673e10582acd8462d69). The file permission should be explicitly set during the build process, but that would be smart.

This is a bug, but it's a bug in the feeds script instead of luci.

I have built and uploaded a new images based on OpenWRT v18.06.4. The patch set for this build is v14.

This corrects a build problem with feed packages which caused incorrect file permissions. Notably, the web interface would greet you with a "Forbidden" error message on the luci build.

Anyone who installed the previous v18.06.4 images should upgrade. The problems in the last build will be automatically fixed and no further action is needed.

Minimal image files are here:

http://jmomo.net/files/lede/TRENDnet_TEW-827DRU_20190705200801_OpenWRT_v18.06.4_minimal/bin/

Minimal+luci image files are here:

http://jmomo.net/files/lede/TRENDnet_TEW-827DRU_20190705205610_OpenWRT_v18.06.4_luci/bin/