Travelmate support thread

Sorry, I did not see this reply and I cannot remember where my snark came from.

It could be that because I suppose I never see a hard wire option in the US and I presume they are as rare as hen's teeth everywhere else too.

But, Travelmate it focused on bridging wireless to wireless. Which is why you are supposed to already be associated with an AP and have it working before you hit the "use wizard configuration button once" just once. So it can see what is configured and use those settings going forward.

Adding things after leaves you with Travelmate trying to get a good 'known to it' config working with things it does not expect nor have any reference to make it work.

It is a travel router.
You turn it on, you associate with an AP with its interface, when you leave you turn it off 'poweroff' or unplug it and then repeat it at the next hotspot..

You don't try switching it around after it is already working on an AP because that would not be a real-world-usage.

Figure out what works without involving Travelmate use the Wizard and expect trouble if you try to 'improve' on it.

Best to decide what you want, get it all working, never move a USB device from the first port OpenWRT assigned it a USB address, connect to an AP in wireless and then use the wizard only once, just like it says to.

Sorry, I missed the significance of this gem:

Of course not. That would just be a router in its most basic setup.

Is this a single radio device? If so, disable the proactive scanning (trm_proactive) ... and set the AP channel to "auto".

@ vochong, I am not an expert at reading the detailed logs, but there seem to be two things going on. Assuming radio0 is 5GHz, "no enabled station on radio 'radio0'" is the error I ran into where neither Travelmate nor OpenWRT was able to scan the 5GHz band for uplinks if the AP was enabled. The second error "can't connect to uplink 'radio1/myssid-2.4ghz/-'" suggests that it was able to find a 2.4GHz uplink but the connection attempt failed for reasons that are not obvious from the log. I have seen this but it usually was an error in my configuration of the uplink or a problem with the uplink access point. Why disabling your downlink helped is unclear, unless there was a conflict between the AP and STA definitions.

@nh905

I think I have found how to reproduce the problem consistently (with or without travelmate). Just use any recent master build (I've tried on several different device models) and you will see that the STA/client interface can never get any IP address from the uplink if an AP is configured and enabled on the same radio. The AP needs to be temporarily disabled in order for the STA/Client to acquire an IP address from the uplink, and then the AP can be enabled after that. You can restart the radio (when both STA/Client and AP on that same radio are enabled) to cause the problem to show up. When the problem shows up, the only way for the STA/Client to get an IP address from the uplink is to temporarily disable the AP (on the same radio).

Such problem is not seen with images from the 23.05.x branch.

@vochong On what version of OpenWRT are you seeing this issue? I am running 23.5.0 on a RAVPower RP-WD009 and have not seen the issue you describe. What does the system log show around the time of the failure?

I just did the following tests using Travelmate:

  • disabled the 5GHz STA/client. Travelmate switched to the 2.4GHz STA/client
  • connected to the RP-WD009 using the 2.4GHz AP/master
  • restarted the 2.4GHz radio using Network/Wireless
  • Travelmate successfully reconnected to the 2.4GHz STA/client without any interruption to my 2.4GHz AP/master connection.

I then enabled the 5GHz STA/client, disabled the 2.4GHz STA/client, let Travelmate switch to the 5GHz STA/client, and connected to the 5GHz AP/master from my laptop. When I restarted the 5GHz radio, Travelmate initially complained that the scan of the radio did not return anything, similar to what I experienced early in my OpenWRT testing on the RP-WD009. However, Travelmate tried again and was successfully able to connect. Without Travelmate, OpenWRT re-established the connection to the 5GHz STA/client on the first attempt..

I mentioned that "Such problem is not seen with images from the 23.05.x branch.".

You need to use the snapshot images from the Master branch to see the problem.

Yes it's a single radio device. I disabled proactive scanning and it did improve the initial uplink connection speed, but the connection is still unstable (compared to using the basic connection method instead of Travelmate), even when the AP is disabled.

I am encountering a problem on Travelmate 2.1.2-6. I am trying to set up VPN, but sometimes I do not want to use a VPN. In the Travelmate service/status it always shows Ext. Hooks with an x in front of the VPN.

I have to physically turn off the VPN (wireguard with ProtonVPN) interface in order to avoid using the VPN. I have tried setting the VPN to "not bring up on boot" and to turn off the VPN under the travelmate wireless stations (editing so the station should not be managed by Travelmate).

I have tried putting the VPN interface in the same firewall zone as the trm_wwan, and to put the VPN in its own firewall zone with forward to the trm_wwan zone, as well as from the lan zone.

Is this a bug in Travelmate? If so, I will submit a support to the travelmate github, but I wanted to ask if anyone had any advice about this.

Just to add to my previous post:

When I am using travelmate, my wifi to wifi (using two radios, one on 2.4 GHz and one on 5GHz) seems to significantly reduce the network speeds to 1/4 the speeds when I use a wired connection to the Travelmate router.

For instance, when I use a wired connection, I am able to reach over 60 Mbps, but when I use wifi to connect to the router, my data rate is capped to 15 Mbps.

anyone else have this problem? I have seen this with two different routers (to verify the issue and to see if it was a processing issue). One router was a Netgear EX6120 repeater with openwrt 23.05.3 flashed, and the other was a Linksys WRT3200ACM (much greater processing power). Both devices exhibited this behavior.

Thanks for all the work, I've started building a TravelRouter , with 3 VPN (IPSEC/OpenVPN/Wireguard) ... but travelmate solve the problem of wifi connection... Just remains Ethernet and USB tethering to do manually (too sad I cannot add usb0 ou lan0 as a wifi station connecting to it if it's up, with priority)...

However, in the log tab I encounter this error ? Is it a well known problem ? or a problem on my installation ?

NetworkError

HTTP error 404 while loading class file "/luci-static/resources/tools/views.js?v=git-24.073.29889-cd7e519"
  at compileClass (http://r4mt3000.lan/luci-static/resources/luci.js?v=git-24.073.29889-cd7e519:168:16)

What should I do ? is it a missing package ?

EDIT: SOLVED, I updated luci-base from the 23.05.3 release (git-24.086.45142-09d5a38)

So, it's not a question, just a hint... update luci-base

1 Like

Hi,
It works fine today, but I'm using an IPSEC VPN (swanctl/StrongSwan) as VPN (to my home). Is there a way to code the VPN hook...
I have programmed an init.d service with start and stop command... is it difficult ? If it work I can send back what works for me...

@AlainCo I had a similar problem trying to configure Travelmate VPN Hook for OpenVPN (https://forum.openwrt.org/t/travelmate-support-thread/5155/795?u=nh905. I am not sure what the config interface name should be for your setup . Until I configured /etc/config/network and /etc/config/firewall, there was no obvious OpenVPN option in the Travelmate pulldown, so perhaps Travelmate allows you to specify a name.

1 Like

@BostonDanPhD see if https://forum.openwrt.org/t/travelmate-support-thread/5155/843?u=nh905 applies to you as well.

In terms of network speed, I recall I got better throughput when my clients were on 5GHz and my uplink was on 2.4GHz. I expected the opposite would be true (use 5GHz for the uplink and 2.4GHz for the clients) but the relatively weak radios in my travel router and the distances between clients, the travel router, and my Internet router might be the cause.

1 Like

ON 2GHZ vs 5GHz, I've observed the same... I use 5GHz for AP and 2GHZ for station connect.
For VPN, it seems dedicated to each VPN.
The problem is that swanctl/strongswan/ipsec is not well integrated (the UCI support is outdated and insufficient, ipsec service should not be started).
The worst problem I suspect is that for Internet Wide VPN (0.0.0.0/0,::0/0) the client install a VIP on the device of the WAN where the server was contacted ... I don't really understand what happen when the WAN device changes. Hopefully travelmate seems to work at the WIFI level, not caring of ping.
I also use MWAN3 for Ethernet and tethering, and I see it is lost when IPSEC is on as soon as WAN changes...
It seems few people use IPSEC, but it's a good protocol, it supports IPV6 on my freebox router (provider's box) VPN...

Sorry guys, I'm a little bit confused about the scripts for a login here on a camping site.
The infrastructure seems to be a Mikrotik Hotspot Login.
But the generic login script is not working. Is anybody here who can assist me with a working script?
The Login Screen looks like this:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
   "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<head>
<title>internet hotspot > login</title>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="pragma" content="no-cache" />
<meta http-equiv="expires" content="-1" />
<meta name="viewport" content="width=device-width; initial-scale=1.0; maximum-scale=1.0;"/>
<style type="text/css">
body {color: #737373; font-size: 10px; font-family: verdana;}

textarea,input,select {
background-color: #FDFBFB;
border: 1px solid #BBBBBB;
padding: 2px;
margin: 1px;
font-size: 14px;
color: #808080;
}

a, a:link, a:visited, a:active { color: #AAAAAA; text-decoration: none; font-size: 10px; }
a:hover { border-bottom: 1px dotted #c1c1c1; color: #AAAAAA; }
img {border: none;}
td { font-size: 14px; color: #7A7A7A; }
</style>

</head>

<body>
	<form name="sendin" action="http://10.0.0.1/login" method="post">
		<input type="hidden" name="username" />
		<input type="hidden" name="password" />
		<input type="hidden" name="dst" value="http://www.msftconnecttest.com/redirect" />
		<input type="hidden" name="popup" value="true" />
	</form>
	
	<script type="text/javascript" src="/md5.js"></script>
	<script type="text/javascript">
	<!--
	    function doLogin() {
		document.sendin.username.value = document.login.username.value;
		document.sendin.password.value = hexMD5('\040' + document.login.password.value + '\361\350\056\376\157\046\212\141\371\366\223\234\146\014\010\346');
		document.sendin.submit();
		return false;
	    }
	//-->
	</script>

<div align="center">
<a href="http://10.0.0.1/login?target=lv&amp;dst=http%3A%2F%2Fwww.msftconnecttest.com%2Fredirect">Latviski</a>
</div>

<table width="100%" style="margin-top: 10%;">
	<tr>
	<td align="center" valign="middle">
		<div class="notice" style="color: #c1c1c1; font-size: 9px">Please log on to use the internet hotspot service<br /></div><br />
		<table width="280" height="280" style="border: 1px solid #cccccc; padding: 0px;" cellpadding="0" cellspacing="0">
			<tr>
				<td align="center" valign="bottom" height="175" colspan="2">
					<form name="login" action="http://10.0.0.1/login" method="post"
					     onSubmit="return doLogin()" >
						<input type="hidden" name="dst" value="http://www.msftconnecttest.com/redirect" />
						<input type="hidden" name="popup" value="true" />
						
							<table width="100" style="background-color: #ffffff">
								<tr><td align="right">login</td>
										<td><input style="width: 80px" name="username" type="text" value=""/></td>
								</tr>
								<tr><td align="right">password</td>
										<td><input style="width: 80px" name="password" type="password"/></td>
								</tr>
								<tr><td>&nbsp;</td>
										<td><input type="submit" value="OK" /></td>
								</tr>
							</table>
					</form>
				</td>
			</tr>
			<tr><td align="center"><a href="http://www.mikrotik.com" target="_blank" style="border: none;"><img src="/img/logobottom.png" alt="mikrotik" /></a></td></tr>
		</table>
	
	<br /><div style="color: #c1c1c1; font-size: 9px">Powered by MikroTik RouterOS</div>
		</td>
	</tr>
</table>

<script type="text/javascript">
<!--
  document.login.username.focus();
//-->
</script>
</body>
</html>

Thanks in advance
Alex