Travelmate support thread

Works for me - e.g. a mullvad client config:

/etc/config/openvpn:

config openvpn mullvad
	option enabled '1'
	option config '/etc/openvpn/mullvad_se.ovpn'

/etc/config/network:

config interface 'ovpn'
	option proto 'none'
	option device 'tun0'
	option auto '0'

/etc/config/firewall:

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'
	list network 'wan6'
	list network 'trm_wwan'
	list network 'trm_wwan6'
	list network 'ovpn'

/etc/config/travelmate:

config uplink
	option enabled '1'
	option device 'radio0'
	option ssid '404 Not found'
	option bssid 'xx:xx:xx:xx:xx:xx'
	option con_start_expiry '0'
	option con_end_expiry '0'
	option con_start '2024.02.02-15:49:07'
	option vpn '1'
	option vpnservice 'openvpn'
	option vpniface 'ovpn'

travelmate connection log:

Fri Feb  2 22:27:36 2024 user.info trm-2.1.2-2[5288]: travelmate instance started ::: action: start, pid: 5288
Fri Feb  2 22:27:37 2024 user.info trm-ntp  [5714]: get ntp time sync
Fri Feb  2 22:28:45 2024 user.info trm-vpn  [6621]: openvpn client connection enabled 'ovpn/mullvad_se'

It's important that use a usual client setup and that you untick "Bring up on boot" for the openvpn interface (both mentioned in the online readme).

@dibdot , thanks for the fast response. I noticed yesterday that the command line instructions for configuring OpenVPN were different from the LuCI instructions which I used, but I think they end up at the same place. I backed out the the connection of tun0 to the wan interface, uninstalled/reinstalled openvpn-openssl, and followed the instructions at https://openwrt.org/docs/guide-user/services/vpn/openvpn/client. It appears that OpenVPN is not automatically enabled by the install - there is no option enabled '1' in /etc/config/openvpn. I enabled OpenVPN via LuCI, I had to disable autostart of OpenVPN via LuCI System/Startup.

There is no interface 'opvn' in /etc/config/network nor any reference to tun0/tun+. /etc/config/firewall is close to what you listed except there are no references to wan/wan6/openvpn. The file does include list network 'tun+ Instead of opvmwhich I believe the LuCI instructions added as well except specifically for tun0.

If I try to enable VPN for one of the uplinks via TravelMate, I am still stuck on the VPN interface. I am presented with

. The only way I can get vpniface in /etc/config/travelmate is by adding it manually, and that does not appear to do anything.

Is it possible that the OpenVPN installation has changed in 2.5.8-4 and is no longer created an 'opvn' interface in /etc/network?

Nope, should work ... as you can see in my former post - it works for me with latest 23.05 release. I think your base openvpn setup is borked, maybe it's better you follow the client instructions here (they seem to be more complete on the first look): https://openwrt.org/docs/guide-user/services/vpn/openvpn/client-luci

I had originally followed the client-luci instructions without success.

I did a reset of my travel router today, set the correct timezone and did a minimal WiFi configuration: set country code to CA (Canada), scanned and joined my home 2.4GHz WiFi channel, and set up a 2.4GHz Master for testing purposes. I installed the latest OpenVPN, uploaded and enabled a working OpenVPN configuration, configured the firewall using the uci commands, and verified client access. I disabled autostart of OpenVPN.

I installed curl, downloaded the latest TravelMate/LuCI packages, and ran the Interface Wizard accepting all defaults. I deleted the existing 2.4 GHz client so that I could add an uplink to it via TravelMate. I could not complete the VPN Settings: the only options were unspecified, lan, trm_wwan, trm_wwan6, and wwan. Reboots did not help.

Based on your early response, I manually updated /etc/config/network, adding

config interface 'ovpn'					
                 option proto 'none'
                 option device 'tun0'
                 option auto '0'

In the config zone 'wan' section of /etc/config/firewall, I appended

          list network 'ovpn'

After a reboot, I was successfully able to set up the TravelMate VPN interface and verified that TravelMate was starting OpenVPN when the 2.4GHz client as activated.

I found https://forum.openwrt.org/t/how-to-setup-travelmate-rigth/33269/ which mentions editing the above files but with no details. Were the instructions included in an earlier version of the README.md file? Could the Interface Wizard make the required changes?

If I scan for new networks and add one it's working perfectly fine. Only annoying thing is I have to go to Network / Wireless and press on "Save & Apply" before the new connection is working. Is there any option to automate this? Especially if you say the OpenWRT shall connect to any open wireless network.

Thanks in advance! :slight_smile:

A quick update in my RP-WD009/OpenWRT/TravelMate/OpenVPN experiences. TravelMate works well switching between access points (AP) based on the priorities I specified in TravelMate. It handles channel changes within the same AP (a full test will have to wait until I am travelling). OpenVPN works fine although I had to tweak the configuration since the latest OpenSSL complains that my CA MD is too weak, and I currently do not have time to regenerate the certificates.

I decided to prefer the 5GHz radio for uplinks and the 2.4GHz radio for connected clients. During early testing, I had configured the 5GHz master for client access but had issues where OpenWRT would not be able to scan for uplink channels if the 5GHz master was enabled. Based on other forum posts, this appears to be an OpenWRT issue.

I also found that OpenWRT will not recognize channels in the 36-64 range even though they are valid in my country and are used by my smartphone's hotspot feature. My home router does not allow me to use channels 100 to 144 since they are DFS channels. That leaves me with channels 147 and 159 at 40MHz channel width. Next time I am travelling, I will need to figure out what country settings lets OpenWRT access all available channels.

I have to Save & Apply in Services -> TravelMate / Wireless Stations but have not needed to use Network -> Wireless. Depending on the order of clients and also the Radio selection setting in TravelMate, it can take a while before a connection comes up. Turning on TravelMate Verbose Debug Logging helps show me what TravelMate is doing 'behind the scenes'.

I guess this was my mistake. :sweat_smile: I never saved it in the travelmate service.

Thank you!

First of all, I want to thank you guys for this very nice project.

I have been using it for like 6 months now. I recently updated my ASUS RT-AC85P to OpenWrt 23.05.2. Since then, i have one very annoying issue with travelmate.

After successfully connecting to a Vodafone Hotspot, travelmate used to establish a wireguard VPN tunnel.
Since the update, this function doesn't work. I have to "restart" the wg0 (wireguard) interface manually. After that, everything works fine. It even shows VPN checked and Ext. hooks on the travelmate status page.

Do you have any hints on how to solve this? I have waited like 10 minutes and rebooted plenty of times.

The shown status in your screenshot states "net cp", that means you're currently behind a captive portal. Travelmate only tries to connect to a vpn if the status is "net ok".

Hi everyone,
I could really use some help with setting up Travelmate please!

My device is a DWR-921, hardware version is C3. I have a primary router downstairs and its SSID is DHB#. I installed Travelmate and initially it did connect to DHB#, but after one or two hours the connection dropped. Since then, Travelmate no longer connects to the main wi-fi network. The logs say,

can't connect to uplink 'radio0/DHB#/-' (1/3)
can't connect to uplink 'radio0/DHB#/-' (2/3)
uplink has been disabled 'radio0/DHB#/-' (3/3)

After that, the logs keep saying that there is no enabled station on radio0.

In the full syslogs, I notice it saying, Interface 0 setup failed: BRIDGE_NOT_ALLOWED, and my radio0 keeps going up and down.

My LAN interface and Travelmate interface are set to the device "br-lan", should I change this?

Next, regarding my access point SSID. In the Interface Configuration, should it be set to the travelmate wwan network, or simply to the wwan network, in order to benefit from Travelmate's connection management?

One thing that's worth mentioning, is that to get the connection working the first time (to my primary wi-fi network), I had to remove the connection to that network from the Wireless Overview page in LuCi, and create the connection within Travelmate by doing a radio scan. It took me a while to figure this out because it isn't mentioned in the Travelmate page on GitHub.

Thanks in advance!

Your setup sounds a bit weirdy... :wink:
Please (re-)start from scratch and read the travelmate online readme before. Thanks.

It says "connected (net ok/65) / 2.1.2-2". The screenshot was just to give you some informations about the installed travelmate version.
In my request i have mentiones that everything is working after manually restarting the WG0 VPN interface.
But the automatic initiation of the VPN doesnt work.

Any idea how to solve this?

Please update to the latest travelmate version (2.1.2-5), check the online readme regarding vpn setup and if it still doesn't work, provide at least the consistent output of:

  • /etc/init.d/travelmate status
  • cat /etc/config/travelmate
  • logread -e "trm-" while travelmate is running in debug mode and connected to this uplink

Hi Dirk,
I reset my router and tried again. Travelmate is still unable to maintain a connection to my main router.

I can successfully connect to the main router by using the normal wireless client option instead of Travelmate.

I enabled debug logs, here are the logs:

Thu Mar 14 14:14:58 2024 user.info trm-2.1.2-5[23633]: travelmate instance started ::: action: start, pid: 23633
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_setdev  ::: radio: radio0, radio_list(cnf/cur): -/radio0, disabled: -
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: loopback, proto: static, device: lo, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: lan, proto: static, device: br-lan, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: wan, proto: dhcp, device: eth0.2, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: wan6, proto: dhcpv6, device: eth0.2, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: trm_wwan, proto: dhcp, device: -, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: trm_wwan6, proto: dhcpv6, device: @trm_wwan, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_env     ::: auto_sta: -, wpa_flags: sae: ✔, owe: ✔, eap: ✘, suiteb192: ✘, sys_ver: D-Link DWR-921 C1, OpenWrt 23.05.0 r23497-6637af95aa
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: false, section: , uplink_config: -
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_jsnup   ::: section: -, status: running (not connected), sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, ntp: 1, vpn: 0/0, mail: 0/0
Thu Mar 14 14:14:58 2024 user.debug trm-2.1.2-5[23633]: f_check   ::: mode: initial, name: -, status: false, enabled: 1, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 0
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_main-1  ::: status: false, proactive: 1
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: , section: default_radio0, uplink_config: -
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: enabled, result: -, uplink_config: -
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start, result: -, uplink_config: -
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end, result: -, uplink_config: -
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start_expiry, result: -, uplink_config: -
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end_expiry, result: -, uplink_config: -
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_setif   ::: enabled: , section: default_radio0, active_sta: -, uplink_config: -
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: , section: trm_uplink2, uplink_config: @uplink[0]
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: enabled, result: 1, uplink_config: @uplink[0]
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start, result: -, uplink_config: @uplink[0]
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end, result: 2024.03.13-22:43:54, uplink_config: @uplink[0]
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start_expiry, result: 0, uplink_config: @uplink[0]
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end_expiry, result: 0, uplink_config: @uplink[0]
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_setif   ::: enabled: 1, section: trm_uplink2, active_sta: -, uplink_config: @uplink[0]
Thu Mar 14 14:14:59 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: false, section: , uplink_config: @uplink[0]
Thu Mar 14 14:15:04 2024 user.debug trm-2.1.2-5[23633]: f_wifi    ::: radio_list: radio0, radio: radio0, timeout: 5
Thu Mar 14 14:15:10 2024 user.debug trm-2.1.2-5[23633]: f_check   ::: mode: dev, name: -, status: false, enabled: 1, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 0
Thu Mar 14 14:15:10 2024 user.debug trm-2.1.2-5[23633]: f_main-3  ::: radio_list: radio0, sta_list: trm_uplink2-radio0
Thu Mar 14 14:15:10 2024 user.debug trm-2.1.2-5[23633]: f_mac     ::: action: get, section: trm_uplink2, macaddr: -, result: -
Thu Mar 14 14:15:11 2024 user.debug trm-2.1.2-5[23633]: f_main-5  ::: sta_radio: radio0, sta_essid: "DHB#", sta_bssid: -
Thu Mar 14 14:15:17 2024 user.debug trm-2.1.2-5[23633]: f_main-6  ::: radio: radio0, scan_device: , scan_cnt: 1
Thu Mar 14 14:15:17 2024 user.debug trm-2.1.2-5[23633]: f_main-7  ::: radio(sta/scan): radio0/radio0, essid(sta/scan): "DHB#"/"TP-LINK_8472CF", bssid(sta/scan): /34:E8:94:84:72:CF, quality(min/scan): 35/31, open: -
Thu Mar 14 14:16:17 2024 user.debug trm-2.1.2-5[23633]: f_setdev  ::: radio: radio0, radio_list(cnf/cur): -/radio0, disabled: -
Thu Mar 14 14:16:17 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: loopback, proto: static, device: lo, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: lan, proto: static, device: br-lan, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: wan, proto: dhcp, device: eth0.2, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: wan6, proto: dhcpv6, device: eth0.2, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: trm_wwan, proto: dhcp, device: -, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: trm_wwan6, proto: dhcpv6, device: @trm_wwan, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_env     ::: auto_sta: -, wpa_flags: sae: ✔, owe: ✔, eap: ✘, suiteb192: ✘, sys_ver: D-Link DWR-921 C1, OpenWrt 23.05.0 r23497-6637af95aa
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: false, section: , uplink_config: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_jsnup   ::: section: -, status: running (not connected), sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, ntp: 1, vpn: 0/0, mail: 0/0
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_check   ::: mode: initial, name: -, status: false, enabled: 1, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 0
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_main-1  ::: status: false, proactive: 1
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: , section: default_radio0, uplink_config: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: enabled, result: -, uplink_config: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start, result: -, uplink_config: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end, result: -, uplink_config: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start_expiry, result: -, uplink_config: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end_expiry, result: -, uplink_config: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_setif   ::: enabled: , section: default_radio0, active_sta: -, uplink_config: -
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: , section: trm_uplink2, uplink_config: @uplink[0]
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: enabled, result: 1, uplink_config: @uplink[0]
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start, result: -, uplink_config: @uplink[0]
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end, result: 2024.03.13-22:43:54, uplink_config: @uplink[0]
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start_expiry, result: 0, uplink_config: @uplink[0]
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end_expiry, result: 0, uplink_config: @uplink[0]
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_setif   ::: enabled: 1, section: trm_uplink2, active_sta: -, uplink_config: @uplink[0]
Thu Mar 14 14:16:18 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: false, section: , uplink_config: @uplink[0]
Thu Mar 14 14:16:24 2024 user.debug trm-2.1.2-5[23633]: f_wifi    ::: radio_list: radio0, radio: radio0, timeout: 5
Thu Mar 14 14:16:30 2024 user.debug trm-2.1.2-5[23633]: f_check   ::: mode: dev, name: -, status: false, enabled: 1, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 0
Thu Mar 14 14:16:30 2024 user.debug trm-2.1.2-5[23633]: f_main-3  ::: radio_list: radio0, sta_list: trm_uplink2-radio0
Thu Mar 14 14:16:30 2024 user.debug trm-2.1.2-5[23633]: f_mac     ::: action: get, section: trm_uplink2, macaddr: -, result: -
Thu Mar 14 14:16:30 2024 user.debug trm-2.1.2-5[23633]: f_main-5  ::: sta_radio: radio0, sta_essid: "DHB#", sta_bssid: -
Thu Mar 14 14:16:36 2024 user.debug trm-2.1.2-5[23633]: f_main-6  ::: radio: radio0, scan_device: , scan_cnt: 1
Thu Mar 14 14:16:37 2024 user.debug trm-2.1.2-5[23633]: f_main-7  ::: radio(sta/scan): radio0/radio0, essid(sta/scan): "DHB#"/"TP-LINK_8472CF", bssid(sta/scan): /34:E8:94:84:72:CF, quality(min/scan): 35/34, open: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_setdev  ::: radio: radio0, radio_list(cnf/cur): -/radio0, disabled: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: loopback, proto: static, device: lo, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: lan, proto: static, device: br-lan, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: wan, proto: dhcp, device: eth0.2, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: wan6, proto: dhcpv6, device: eth0.2, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: trm_wwan, proto: dhcp, device: -, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getvpn  ::: iface: trm_wwan6, proto: dhcpv6, device: @trm_wwan, vpn_ifacelist: -, vpn_infolist: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_env     ::: auto_sta: -, wpa_flags: sae: ✔, owe: ✔, eap: ✘, suiteb192: ✘, sys_ver: D-Link DWR-921 C1, OpenWrt 23.05.0 r23497-6637af95aa
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: false, section: , uplink_config: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_jsnup   ::: section: -, status: running (not connected), sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, ntp: 1, vpn: 0/0, mail: 0/0
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_check   ::: mode: initial, name: -, status: false, enabled: 1, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 0
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_main-1  ::: status: false, proactive: 1
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: , section: default_radio0, uplink_config: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: enabled, result: -, uplink_config: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start, result: -, uplink_config: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end, result: -, uplink_config: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start_expiry, result: -, uplink_config: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end_expiry, result: -, uplink_config: -
Thu Mar 14 14:17:37 2024 user.debug trm-2.1.2-5[23633]: f_setif   ::: enabled: , section: default_radio0, active_sta: -, uplink_config: -
Thu Mar 14 14:17:38 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: , section: trm_uplink2, uplink_config: @uplink[0]
Thu Mar 14 14:17:38 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: enabled, result: 1, uplink_config: @uplink[0]
Thu Mar 14 14:17:38 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start, result: -, uplink_config: @uplink[0]
Thu Mar 14 14:17:38 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end, result: 2024.03.13-22:43:54, uplink_config: @uplink[0]
Thu Mar 14 14:17:38 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_start_expiry, result: 0, uplink_config: @uplink[0]
Thu Mar 14 14:17:38 2024 user.debug trm-2.1.2-5[23633]: f_getval  ::: option: con_end_expiry, result: 0, uplink_config: @uplink[0]
Thu Mar 14 14:17:38 2024 user.debug trm-2.1.2-5[23633]: f_setif   ::: enabled: 1, section: trm_uplink2, active_sta: -, uplink_config: @uplink[0]
Thu Mar 14 14:17:38 2024 user.debug trm-2.1.2-5[23633]: f_getcfg  ::: status: false, section: , uplink_config: @uplink[0]
Thu Mar 14 14:17:43 2024 user.debug trm-2.1.2-5[23633]: f_wifi    ::: radio_list: radio0, radio: radio0, timeout: 5
Thu Mar 14 14:17:49 2024 user.debug trm-2.1.2-5[23633]: f_check   ::: mode: dev, name: -, status: false, enabled: 1, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 0
Thu Mar 14 14:17:49 2024 user.debug trm-2.1.2-5[23633]: f_main-3  ::: radio_list: radio0, sta_list: trm_uplink2-radio0
Thu Mar 14 14:17:49 2024 user.debug trm-2.1.2-5[23633]: f_mac     ::: action: get, section: trm_uplink2, macaddr: -, result: -
Thu Mar 14 14:17:49 2024 user.debug trm-2.1.2-5[23633]: f_main-5  ::: sta_radio: radio0, sta_essid: "DHB#", sta_bssid: -
Thu Mar 14 14:17:56 2024 user.debug trm-2.1.2-5[23633]: f_main-6  ::: radio: radio0, scan_device: , scan_cnt: 1
Thu Mar 14 14:17:56 2024 user.debug trm-2.1.2-5[23633]: f_main-7  ::: radio(sta/scan): radio0/radio0, essid(sta/scan): "DHB#"/"TP-LINK_8472CF", bssid(sta/scan): /34:E8:94:84:72:CF, quality(min/scan): 35/37, open: -

Please advise.

I don't think travelmate cares. Try it.

I edited my previous post and included the logs.

Is use of an Ethernet port instead of WiFi supported?

I'm using up-to-date 23.05 and when I plug my travelmate router's wan port into an Ethernet Internet connection (i.e. Internet cable modem for example) it still seems to want to connect to a WiFi AP.

Is there some specific configuration item I am missing to tell travelmate that if it gets a usable network on it's wan interface, not to try to bring up a WiFi interface and to use the wan interface for it's WWAN instead?

Additionally, if the Ethernet port is unplugged travelmate should fall-back to it's usual WiFi operational model.

What's your problem/issue actually? The travelmate interface will be generated with a lower interface/routing metric (100). As soon as your routers wan interface (by default with "higher" metric 0) has a wired connection, this connection will be preferred, e.g.:

root@2go:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.168.1.1      0.0.0.0         UG    0      0        0 eth0
default         10.168.20.1     0.0.0.0         UG    100    0        0 phy0-sta0
10.168.1.0      *               255.255.255.0   U     0      0        0 eth0
10.168.20.0     *               255.255.255.0   U     100    0        0 phy0-sta0
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan

Hi @dibdot, do you have any advice on this please?