Travelmate support thread

Hi
Sounds like you might be looking for Guest network. Look at https://openwrt.org/docs/guide-user/network/wifi/guestwifi/guest-wlan-webinterface

I had to use a mix of the Luci and ssh instructions to get it working. You can isolate the guest from the rest of the lan.

Sorry, maybe I wasn’t clear. I’m not looking for a guest network; I am looking for a way for family members already authorized on the network to look up new APs and connect to them.

This is for a travel trailer with family members.

Basically I want Luci | Services | Travelmate | Wireless Stations accessible directly without root password, and without giving anyone access to the rest of Luci.

My best bet would be "luci-app-commands", maybe you can script something and provide static links to your family ... that's only a rough assumption from my side, I haven't tested this yet.

Anyone want to take that on for beer money? I don’t have the knowledge to do it.

Basically something like:

192.168.1.1://wifiAPsetup

That will take you directly to
Luci | Services | Travelmate | Wireless Stations
And allow you to pick a network, provide a passphrase, and save and apply. (Just one button - I don’t want to have to explain the difference between “Save and Apply” and “Save” and “Apply”. Just a “Connect” button.)

Please take a look at this, and let us know if it works for you: SOLVED: LUCI add support user (in addition to root)

Hi, I have a router to do some testing around, which are the steps that I need to do to test latest packages or latest code of travelmate on that router ? should I install build tools and git, or what? thanks.

Unfortunately not. That will create a second user with full access to all of Luci, right? I just want to allow access to just that one page.

Is there a way to have the second user limited in scope?

no, luci does not have integrated accounts/permissions control, and you cant assign themes for users (I that this last will be ideal to have.) ... so will be need to rewrite some luci or add a new page to the system...

it seems that some years ago there was some steps on this matter but I think that are too basic and probably useless https://github.com/openwrt/luci/issues/623

so... you need a web page that runs on the openwrt router, shows the list of scan for wireless networks, able to pick one and enter its key to be able to connect to it ?
let me know I could try to do that.

Exactly. Something a non-techie can use to connect to a new wifi network, without needing root access.

Wanted to let you know that I've installed travelmate and it's running successfully on a Netgear R6120. I'm not sure where the full device list is located or if my device is already included.

Thanks a million for this package. I'm a complete newbie and would've probably never figured it out without this. It would've taken me forever if I had.

1 Like

just wanted to say travelmate works awesome! thank you so much. I did have 1 feature request if possible. could there be checkboxes added to the travelmate wireless stations section to enable and disable access points. deleting or moving them up or down sometimes can be cumbersome when there are a few you temporarily do not want to connect to, but also dont want to delete to have to re-enter the wifi password.

Before I know about travelmate, I was struggled netifd and user defined single(merged) wpa_supplicant
netifd always engaged every network event/commands, that was nightmare for me.
I really appreciate travelmate. :heart_eyes:

Installed travelmate last night, it was nicely accepts existing my AP+STA configurations.
But, I found bug(I think) in luci-app-travelmate

  • Network -> Wireless -> Scan phy0 : No impact of AP side disconnection while scanning.
  • Services -> Travelmate -> Wireless Stations -> Scan phy0 : AP side permanently disconnected until manullay restart the network( even travelmate not running status )

Here is my environments

OpenWrt 19.07.2 r10947-65030d81f3 running on MIPS 24KEc(MT7688)
completely disabled IPv6 support
 system.@system[0].conloglevel='8'
 system.@system[0].cronloglevel='0'
 system.@system[0].klogconloglevel='8'

 + dnsmasq - 2.80-16
 + hostapd-common - 2019-08-08-ca8c2bd2-2
 + iw - 5.0.1-1
 + iwinfo - 2019-10-16-07315b6f-1
 + jshn - 2020-02-27-7da66430-1
 + jsonfilter - 2018-02-04-c7e938d6-1
 + libc - 1.1.24-2
 + libiwinfo-lua - 2019-10-16-07315b6f-1
 + libiwinfo20181126 - 2019-10-16-07315b6f-1
 + rpcd-mod-iwinfo - 2019-12-10-aaa08366-2
 + uclient-fetch - 2019-05-30-3b3e368d-1
 + wpa-cli - 2019-08-08-ca8c2bd2-2
 + wpad - 2019-08-08-ca8c2bd2-2

 + travelmate - 1.5.3-1
 + luci-app-travelmate - git-20.105.64099-eeba108-1

Follwings is my configurations.

root@OpenWrt:/# uci export network
package network

config interface 'loopback'
	option ifname 'lo'
	option ipv6 '0'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.255.255.0'
	option delegate '0'
	option force_link '1'

config interface 'ra0lan'
	option macaddr '1a:aa:aa:aa:aa:aa'
	option ipv6 '0'
	option proto 'static'
	option ipaddr '192.168.168.1'
	option netmask '255.255.255.0'
	option delegate '0'
	option force_link '1'
	option ifname 'wl0ap'

config interface 'ra0wan'
	option macaddr '1b:bb:bb:bb:bb:bb'
	option ipv6 '0'
	option proto 'dhcp'
	option broadcast '1'
	option hostname 'radiowan'
	option delegate '0'
	option force_link '1'
	option ifname 'wl0sta'

config interface 'ra0mon'
	option ipv6 '0'
	option proto 'none'
	option delegate '0'
	option force_link '1'
	option ifname 'wl0mon'

config interface 'eth0lan'
	option ifname 'eth0'
	option ipv6 '0'
	option proto 'static'
	option netmask '255.255.255.0'
	option delegate '0'
	option ipaddr '192.168.169.1'
	option macaddr '12:34:56:78:90:AB'

config interface 'eth0wan'
	option ifname '@eth0lan'
	option ipv6 '0'
	option proto 'dhcp'
	option broadcast '1'
	option hostname 'cablewan'
	option delegate '0'
	option force_link '1'
	option macaddr 'BA:09:87:65:43:21'

config interface 'dummy1'
	option proto 'dhcp'

config interface 'dummy2'
	option proto 'dhcp'

config interface 'relay0'
	option proto 'relay'
	option ipv6 '0'
	option force_link '1'
	option delegate '0'
	option network 'dummy1 dummy2'

root@OpenWrt:/# uci export wireless
package wireless

config wifi-device 'phy0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT40'
	option channel 'auto'
	option txpower '5'
	option log_level '0'

config wifi-iface 'ap01'
	option macaddr '00:00:00:00:00:01'
	option device 'phy0'
	option mode 'ap'
	option ifname 'wl0ap'
	option network 'ra0lan'
	option name 'thisisAP'
	option ssid 'XHOTSPOTX'
	option encryption 'psk2'
	option key '#_REDACTED_#'
	option disabled '0'

config wifi-iface 'mon01'
	option device 'phy0'
	option mode 'monitor'
	option ifname 'wl0mon'
	option network 'ra0mon'
	option ssid 'bastion'
	option disabled '0'

config wifi-iface 'sta01'
	option device 'phy0'
	option mode 'sta'
	option ifname 'wl0sta'
	option network 'ra0wan'
	option name 'thisisSTA'
	option ssid '#_REDACTED_#'
	option encryption 'psk2'
	option key '#_REDACTED_#'
	option macaddr '0c:cc:cc:cc:cc:cc'
	option disabled '1'

config wifi-iface 'sta02'
	option device 'phy0'
	option mode 'sta'
	option ifname 'wl0sta'
	option network 'ra0wan'
	option ssid '#_REDACTED_#'
	option bssid '#_REDACTED_#'
	option encryption 'psk2'
	option key '#_REDACTED_#'
	option disabled '1'

config wifi-iface 'sta99'
	option device 'phy0'
	option mode 'sta'
	option ifname 'wl0sta'
	option network 'ra0wan'
	option ssid '#_REDACTED-UPLINK_SSID-REDACTED_#'
	option encryption 'wpa2'
	option eap_type 'peap'
	option auth 'EAP-MSCHAPV2'
	option identity '#_REDACTED_#'
	option password '#_REDACTED_#'

root@OpenWrt:/# uci export travelmate
package travelmate

config travelmate 'global'
	option trm_captive '1'
	option trm_proactive '1'
	option trm_autoadd '0'
	option trm_triggerdelay '2'
	option trm_maxretry '5'
	option trm_listexpiry '0'
	option trm_minquality '35'
	option trm_maxwait '30'
	option trm_timeout '60'
	option trm_rtfile '/tmp/trm_runtime.json'
	option trm_enabled '1'
	option trm_netcheck '1'
	option trm_iface 'ra0wan'
	option trm_radio 'phy0'
	option trm_debug '1'

Followings is issued after /etc/init.d/travelmate stop && /etc/init.d/network restart && logread -f logs.

Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'eth0lan' is enabled
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'eth0lan' is setting up now
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'eth0wan' is enabled
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'eth0wan' is setting up now
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'eth0lan' is now up
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'loopback' is enabled
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'loopback' is setting up now
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'loopback' is now up
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Network device 'eth0' link is up
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Network alias 'eth0' link is up
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'eth0wan' has link connectivity
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'eth0lan' has link connectivity
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Network device 'lo' link is up
Mon Apr 20 04:40:41 2020 daemon.notice netifd: Interface 'loopback' has link connectivity
Mon Apr 20 04:40:41 2020 daemon.notice netifd: eth0wan (19802): udhcpc: started, v1.30.1
Mon Apr 20 04:40:41 2020 user.notice firewall: Reloading firewall due to ifup of eth0lan (eth0)
Mon Apr 20 04:40:42 2020 daemon.notice netifd: eth0wan (19802): udhcpc: sending discover
Mon Apr 20 04:40:42 2020 user.notice mac80211: Failed command: iw phy phy0 set antenna 0xffffffff 0xffffffff
Mon Apr 20 04:40:42 2020 daemon.notice netifd: phy0 (19781): sh: acs_survey: out of range
Mon Apr 20 04:40:42 2020 daemon.notice netifd: phy0 (19781): sh: acs_survey: out of range
Mon Apr 20 04:40:43 2020 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Mon Apr 20 04:40:43 2020 daemon.notice hostapd: wl0ap: interface state UNINITIALIZED->COUNTRY_UPDATE
Mon Apr 20 04:40:43 2020 daemon.notice hostapd: ACS: Automatic channel selection started, this may take a bit
Mon Apr 20 04:40:43 2020 daemon.notice hostapd: wl0ap: interface state COUNTRY_UPDATE->ACS
Mon Apr 20 04:40:43 2020 daemon.notice hostapd: wl0ap: ACS-STARTED
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[19517]: exiting on receipt of SIGTERM
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: started, version 2.80 cachesize 150
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: DNS service limited to local subnets
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq-dhcp[20010]: DHCP, IP range 192.168.169.100 -- 192.168.169.249, lease time 12h
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: using local addresses only for domain test
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: using local addresses only for domain onion
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: using local addresses only for domain localhost
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: using local addresses only for domain local
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: using local addresses only for domain invalid
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: using local addresses only for domain bind
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: using local addresses only for domain lan
Mon Apr 20 04:40:44 2020 daemon.warn dnsmasq[20010]: no servers found in /tmp/resolv.conf.auto, will retry
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: read /etc/hosts - 4 addresses
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq-dhcp[20010]: read /etc/ethers - 0 addresses
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: read /etc/hosts - 4 addresses
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq[20010]: read /tmp/hosts/dhcp.cfg01411c - 1 addresses
Mon Apr 20 04:40:44 2020 daemon.info dnsmasq-dhcp[20010]: read /etc/ethers - 0 addresses
Mon Apr 20 04:40:45 2020 daemon.notice netifd: eth0wan (19802): udhcpc: sending discover
Mon Apr 20 04:40:47 2020 daemon.notice hostapd: handle_probe_req: send failed
Mon Apr 20 04:40:48 2020 daemon.notice netifd: eth0wan (19802): udhcpc: sending discover
Mon Apr 20 04:40:48 2020 daemon.notice hostapd: handle_probe_req: send failed
Mon Apr 20 04:40:48 2020 daemon.notice hostapd: handle_probe_req: send failed
Mon Apr 20 04:40:48 2020 daemon.notice hostapd: handle_probe_req: send failed
...(snip:duplicatemessages)...
Mon Apr 20 04:40:51 2020 daemon.notice hostapd: handle_probe_req: send failed
Mon Apr 20 04:40:51 2020 daemon.notice hostapd: handle_probe_req: send failed
Mon Apr 20 04:40:51 2020 daemon.notice hostapd: handle_probe_req: send failed
Mon Apr 20 04:40:52 2020 daemon.notice hostapd: ACS: Survey is missing noise floor
Mon Apr 20 04:40:52 2020 daemon.notice hostapd: ACS: Survey is missing noise floor
Mon Apr 20 04:40:52 2020 daemon.notice hostapd: ACS: Survey is missing noise floor
...(snip:duplicatemessages)...
Mon Apr 20 04:40:52 2020 daemon.notice hostapd: ACS: Survey is missing noise floor
Mon Apr 20 04:40:52 2020 daemon.notice hostapd: ACS: Survey is missing noise floor
Mon Apr 20 04:40:52 2020 daemon.notice hostapd: ACS: Survey is missing noise floor
Mon Apr 20 04:40:52 2020 daemon.notice hostapd: wl0ap: ACS-COMPLETED freq=2412 channel=1
Mon Apr 20 04:40:52 2020 daemon.err hostapd: Using interface wl0ap with hwaddr 00:00:00:00:00:01 and ssid "XHOTSPOTX"
Mon Apr 20 04:40:53 2020 daemon.notice hostapd: wl0ap: interface state ACS->ENABLED
Mon Apr 20 04:40:53 2020 daemon.notice hostapd: wl0ap: AP-ENABLED
Mon Apr 20 04:40:53 2020 daemon.notice netifd: Network device 'wl0mon' link is up
Mon Apr 20 04:40:53 2020 daemon.notice netifd: Interface 'ra0mon' has link connectivity
Mon Apr 20 04:40:53 2020 daemon.notice netifd: phy0 (19781): command failed: Not supported (-122)
Mon Apr 20 04:40:53 2020 user.notice mac80211: Failed command: iw dev wl0mon set txpower fixed 500
Mon Apr 20 04:40:53 2020 daemon.notice wpa_supplicant[20105]: Successfully initialized wpa_supplicant
Mon Apr 20 04:40:53 2020 daemon.notice netifd: Interface 'ra0lan' is enabled
Mon Apr 20 04:40:53 2020 daemon.notice netifd: Interface 'ra0lan' is setting up now
Mon Apr 20 04:40:53 2020 daemon.notice netifd: Interface 'ra0lan' is now up
Mon Apr 20 04:40:53 2020 daemon.notice netifd: Interface 'ra0mon' is enabled
Mon Apr 20 04:40:53 2020 daemon.notice netifd: Interface 'ra0mon' is setting up now
Mon Apr 20 04:40:53 2020 daemon.notice netifd: Interface 'ra0mon' is now up
Mon Apr 20 04:40:53 2020 daemon.notice netifd: Interface 'ra0wan' is enabled
Mon Apr 20 04:40:53 2020 daemon.notice netifd: Interface 'ra0wan' is setting up now
Mon Apr 20 04:40:53 2020 daemon.notice netifd: ra0wan (20139): udhcpc: started, v1.30.1
Mon Apr 20 04:40:53 2020 user.notice firewall: Reloading firewall due to ifup of ra0lan (wl0ap)
Mon Apr 20 04:40:54 2020 daemon.notice netifd: ra0wan (20139): udhcpc: sending discover
Mon Apr 20 04:40:54 2020 daemon.notice wpa_supplicant[20106]: wl0sta: SME: Trying to authenticat[ 4341.744749] wl0sta: authenticate with #_REDACTED-UPLINK_BSSID-REDACTED_#
e with #_REDACTED-UPLINK_BSSID-REDACTED_# (SSID='#_REDACTED-UPLINK_SSID-REDACTED_#' freq=2437 MHz)
Mon Apr 20 04:40:54 2020 kern.info kernel: [ 4341.744749] wl0sta: authenticate with #_REDACTED-UPLINK_BSSID-REDACTED_#
[ 4341.773927] wl0sta: send auth to #_REDACTED-UPLINK_BSSID-REDACTED_# (try 1/3)
Mon Apr 20 04:40[ 4341.782007] wl0sta: authenticated
:54 2020 kern.info kernel: [ 4341.773927] wl0sta: send auth to #_REDACTED-UPLINK_BSSID-REDACTED_# (try 1/3)
Mon Apr 20 04:40:54 2020 kern.info kernel: [ 4341.782007] wl0sta: authenticated
Mon[ 4341.799836] wl0sta: associate with #_REDACTED-UPLINK_BSSID-REDACTED_# (try 1/3)
 Apr 20 04:40:54 2020 daemon.notice wpa_supplicant[20106]: wl0sta: Trying to ass[ 4341.813264] wl0sta: RX AssocResp from #_REDACTED-UPLINK_BSSID-REDACTED_# (capab=0x431 status=0 aid=1)
ociate with 00:4[ 4341.822336] wl0sta: associated
e:35:1c:7b:42 (SSID='#_REDACTED-UPLINK_SSID-REDACTED_#' freq=2437 MHz)
Mon Apr 20 04:40:54 2020 kern.info kernel: [ 4341.799836] wl0sta: associate with #_REDACTED-UPLINK_BSSID-REDACTED_# (try 1/3)
Mon Apr 20 04:40:54 2020 daemon.notice netifd: Network device 'wl0sta' link is up
Mon Apr 20 04:40:54 2020 daemon.notice netifd: Interface 'ra0wan' has link connectivity
Mon Apr 20 04:40:54 2020 kern.info kernel: [ 4341.813264] wl0sta: RX AssocResp from #_REDACTED-UPLINK_BSSID-REDACTED_# (capab=0x431 status=0 aid=1)
Mon Apr 20 04:40:54 2020 kern.info kernel: [ 4341.822336] wl0sta: associated
Mon Apr 20 04:40:54 2020 daemon.notice wpa_supplicant[20106]: wl0sta: Associated with #_REDACTED-UPLINK_BSSID-REDACTED_#
Mon Apr 20 04:40:54 2020 daemon.notice wpa_supplicant[20106]: wl0sta: CTRL-EVENT-EAP-STARTED EAP authentication started
Mon Apr 20 04:40:54 2020 daemon.notice wpa_supplicant[20106]: wl0sta: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Mon Apr 20 04:40:54 2020 daemon.notice wpa_supplicant[20106]: wl0sta: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25
Mon Apr 20 04:40:54 2020 daemon.notice wpa_supplicant[20106]: wl0sta: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
...(snip:EAP certification information)...
Mon Apr 20 04:40:56 2020 daemon.notice wpa_supplicant[20106]: EAP-MSCHAPV2: Authentication succeeded
Mon Apr 20 04:40:56 2020 daemon.notice wpa_supplicant[20106]: EAP-TLV: TLV Result - Success - EAP-TLV/Phase2 Completed
Mon Apr 20 04:40:56 2020 daemon.notice wpa_supplicant[20106]: wl0sta: CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully
Mon Apr 20 04:40:56 2020 daemon.notice wpa_supplicant[20106]: wl0sta: PMKSA-CACHE-ADDED #_REDACTED-UPLINK_BSSID-REDACTED_# 0
Mon Apr 20 04:40:56 2020 daemon.notice wpa_supplicant[20106]: wl0sta: WPA: Key negotiation completed with #_REDACTED-UPLINK_BSSID-REDACTED_# [PTK=CCMP GTK=CCMP]
Mon Apr 20 04:40:56 2020 daemon.notice wpa_supplicant[20106]: wl0sta: CTRL-EVENT-CONNECTED - Connection to #_REDACTED-UPLINK_BSSID-REDACTED_# completed [id=0 id_str=]
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20010]: exiting on receipt of SIGTERM
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: started, version 2.80 cachesize 150
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: DNS service limited to local subnets
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq-dhcp[20256]: DHCP, IP range 192.168.169.100 -- 192.168.169.249, lease time 12h
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq-dhcp[20256]: DHCP, IP range 192.168.168.100 -- 192.168.168.249, lease time 12h
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: using local addresses only for domain test
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: using local addresses only for domain onion
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: using local addresses only for domain localhost
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: using local addresses only for domain local
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: using local addresses only for domain invalid
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: using local addresses only for domain bind
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: using local addresses only for domain lan
Mon Apr 20 04:40:56 2020 daemon.warn dnsmasq[20256]: no servers found in /tmp/resolv.conf.auto, will retry
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: read /etc/hosts - 4 addresses
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq-dhcp[20256]: read /etc/ethers - 0 addresses
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: read /etc/hosts - 4 addresses
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq[20256]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Mon Apr 20 04:40:56 2020 daemon.info dnsmasq-dhcp[20256]: read /etc/ethers - 0 addresses
Mon Apr 20 04:40:57 2020 daemon.notice netifd: ra0wan (20139): udhcpc: sending discover
Mon Apr 20 04:40:57 2020 daemon.notice netifd: Network device 'wl0ap' link is up
Mon Apr 20 04:40:57 2020 daemon.notice netifd: Interface 'ra0lan' has link connectivity
Mon Apr 20 04:40:58 2020 daemon.notice netifd: ra0wan (20139): udhcpc: sending select for #_REDACTED-UPLINK_IP-REDACTED_#
Mon Apr 20 04:40:58 2020 daemon.notice netifd: ra0wan (20139): udhcpc: lease of #_REDACTED-UPLINK_IP-REDACTED_# obtained, lease time 3600
Mon Apr 20 04:40:58 2020 daemon.notice netifd: Interface 'ra0wan' is now up
Mon Apr 20 04:40:58 2020 daemon.info dnsmasq[20256]: reading /tmp/resolv.conf.auto
Mon Apr 20 04:40:58 2020 daemon.info dnsmasq[20256]: using local addresses only for domain test
Mon Apr 20 04:40:58 2020 daemon.info dnsmasq[20256]: using local addresses only for domain onion
Mon Apr 20 04:40:58 2020 daemon.info dnsmasq[20256]: using local addresses only for domain localhost
Mon Apr 20 04:40:58 2020 daemon.info dnsmasq[20256]: using local addresses only for domain local
Mon Apr 20 04:40:58 2020 daemon.info dnsmasq[20256]: using local addresses only for domain invalid
Mon Apr 20 04:40:58 2020 daemon.info dnsmasq[20256]: using local addresses only for domain bind
Mon Apr 20 04:40:58 2020 daemon.info dnsmasq[20256]: using local addresses only for domain lan
Mon Apr 20 04:40:58 2020 daemon.info dnsmasq[20256]: using nameserver #_REDACTED-UPLINK_DNS-REDACTED_##53
Mon Apr 20 04:40:58 2020 daemon.info dnsmasq[20256]: using nameserver #_REDACTED-UPLINK_DNS-REDACTED_##53
Mon Apr 20 04:40:58 2020 user.notice firewall: Reloading firewall due to ifup of ra0wan (wl0sta)
Mon Apr 20 04:41:00 2020 daemon.info dnsmasq[20256]: read /etc/hosts - 4 addresses
Mon Apr 20 04:41:00 2020 daemon.info dnsmasq[20256]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Mon Apr 20 04:41:00 2020 daemon.info dnsmasq-dhcp[20256]: read /etc/ethers - 0 addresses
############################################################################################################################
#####Try to connect wl0ap
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: authentication OK (open system)
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-AUTHENTICATE.indication(cc:20:e8:--:--:--:--, OPEN_SYSTEM)
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-DELETEKEYS.request(cc:20:e8:--:--:--:--)
Mon Apr 20 04:41:29 2020 daemon.info hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: authenticated
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: association OK (aid 1)
Mon Apr 20 04:41:29 2020 daemon.info hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: associated (aid 1)
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-ASSOCIATE.indication(cc:20:e8:--:--:--:--)
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-DELETEKEYS.request(cc:20:e8:--:--:--:--)
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: binding station to interface 'wl0ap'
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: event 1 notification
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: start authentication
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.1X: unauthorizing port
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: sending 1/4 msg of 4-Way Handshake
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: received EAPOL-Key frame (2/4 Pairwise)
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: sending 3/4 msg of 4-Way Handshake
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: received EAPOL-Key frame (4/4 Pairwise)
Mon Apr 20 04:41:29 2020 daemon.notice hostapd: wl0ap: AP-STA-CONNECTED cc:20:e8:--:--:--:--
Mon Apr 20 04:41:29 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.1X: authorizing port
Mon Apr 20 04:41:29 2020 daemon.info hostapd: wl0ap: STA cc:20:e8:--:--:--:-- RADIUS: starting accounting session 9D1BAB232C9A7356
Mon Apr 20 04:41:29 2020 daemon.info hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: pairwise key handshake completed (RSN)
Mon Apr 20 04:41:29 2020 daemon.info dnsmasq-dhcp[20256]: DHCPREQUEST(wl0ap) 192.168.168.207 cc:20:e8:--:--:--:--
Mon Apr 20 04:41:29 2020 daemon.info dnsmasq-dhcp[20256]: DHCPACK(wl0ap) 192.168.168.207 cc:20:e8:--:--:--:-- client4apside
############################################################################################################################
#####Successfully connected wl0ap & IP optained
#####Do Network -> Wireless -> Scan phy0
[ 4489.192758] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:43:22 2020 kern.in[ 4489.210016] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
fo kernel: [ 4489.192758] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:43:22 2020 kern.info kernel: [ 4489.210016] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
[ 4499.190900] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:43:32 2020 kern.info kernel: [ 4499.190900] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: l[ 4499.206537] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
ink is not ready
Mon Apr 20 04:43:32 2020 kern.info kernel: [ 4499.206537] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
[ 4509.187550] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
[ 4509.194965] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:43:42 2020 kern.info kernel: [ 4509.187550] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:43:42 2020 kern.info kernel: [ 4509.194965] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
[ 4519.209544] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:43:52 2020 kern.info kernel: [ 4519.209544] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready[ 4519.227749] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:43:52 2020 kern.info kernel: [ 4519.227749] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
[ 4534.302864] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:44:07 2020 kern.in[ 4534.319448] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
fo kernel: [ 4534.302864] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:44:07 2020 kern.info kernel: [ 4534.319448] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
[ 4544.328031] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:44:17 2020 kern.info kernel: [ 4544.328031] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready[ 4544.347492] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:44:17 2020 kern.info kernel: [ 4544.347492] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
#####wl0ap connected client connection does not break during several scans(Even wl0sta connected to the uplink)
############################################################################################################################
#####Try to Services -> Travelmate -> Wireless Stations -> Scan phy0 (Travelmate stopped, but make sure about disconnect wl0ap issue caused from luci frontend or travelmate core)
[ 4808.401976] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:48[ 4808.417060] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
:41 2020 kern.info kernel: [ 4808.401976] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 04:48:41 2020 kern.info kernel: [ 4808.417060] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
############################################################################################################################
#####Broken wl0ap connection until restart network services(Travelmate status:Not running!, phy0 scan via luci-app-travelmate)
Mon Apr 20 04:49:26 2020 daemon.notice hostapd: wl0ap: AP-STA-DISCONNECTED cc:20:e8:--:--:--:--
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: authentication OK (open system)
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: event 0 notification
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-AUTHENTICATE.indication(cc:20:e8:--:--:--:--, OPEN_SYSTEM)
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-DELETEKEYS.request(cc:20:e8:--:--:--:--)
Mon Apr 20 04:49:26 2020 daemon.info hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: authenticated
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: association OK (aid 1)
Mon Apr 20 04:49:26 2020 daemon.info hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: associated (aid 1)
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-ASSOCIATE.indication(cc:20:e8:--:--:--:--)
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-DELETEKEYS.request(cc:20:e8:--:--:--:--)
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: binding station to interface 'wl0ap'
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: event 1 notification
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: sending 1/4 msg of 4-Way Handshake
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: received EAPOL-Key frame (2/4 Pairwise)
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: sending 3/4 msg of 4-Way Handshake
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: received EAPOL-Key frame (4/4 Pairwise)
Mon Apr 20 04:49:26 2020 daemon.notice hostapd: wl0ap: AP-STA-CONNECTED cc:20:e8:--:--:--:--
Mon Apr 20 04:49:26 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.1X: authorizing port
Mon Apr 20 04:49:26 2020 daemon.info hostapd: wl0ap: STA cc:20:e8:--:--:--:-- RADIUS: starting accounting session 9D1BAB232C9A7356
Mon Apr 20 04:49:26 2020 daemon.info hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: pairwise key handshake completed (RSN)
Mon Apr 20 04:49:26 2020 daemon.info dnsmasq-dhcp[20256]: DHCPREQUEST(wl0ap) 192.168.168.207 cc:20:e8:--:--:--:--
Mon Apr 20 04:49:26 2020 daemon.info dnsmasq-dhcp[20256]: DHCPACK(wl0ap) 192.168.168.207 cc:20:e8:--:--:--:-- client4apside
Mon Apr 20 04:49:30 2020 daemon.notice hostapd: wl0ap: AP-STA-DISCONNECTED cc:20:e8:--:--:--:--
Mon Apr 20 04:49:30 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- WPA: event 2 notification
Mon Apr 20 04:49:30 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.1X: unauthorizing port
Mon Apr 20 04:49:30 2020 daemon.info hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: disassociated
Mon Apr 20 04:49:30 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-DISASSOCIATE.indication(cc:20:e8:--:--:--:--, 8)
Mon Apr 20 04:49:30 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-DELETEKEYS.request(cc:20:e8:--:--:--:--)
Mon Apr 20 04:49:31 2020 daemon.info hostapd: wl0ap: STA cc:20:e8:--:--:--:-- IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Mon Apr 20 04:49:31 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-DEAUTHENTICATE.indication(cc:20:e8:--:--:--:--, 2)
Mon Apr 20 04:49:31 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:--:-- MLME: MLME-DELETEKEYS.request(cc:20:e8:--:--:--:--)
#####Broken wl0ap connection, can not connect wl0ap anymore ( sometimes asking password again, or just disconnect )

Also it is odd, when I issue /etc/init.d/travelmate status or service travelmate status
Even status_service section defined( does not enter this section; ), also /tmp/trm_runtime.json existed

root@OpenWrt:/# /etc/init.d/travelmate status
Syntax: /etc/init.d/travelmate [command]

Available commands:
        start   Start the service
        stop    Stop the service
        restart Restart the service
        reload  Reload configuration files (or restart if service does not implement reload)
        enable  Enable service autostart
        disable Disable service autostart


root@OpenWrt:/# json_load_file /tmp/trm_runtime.json  && json_dump
{ "data": { "travelmate_status": "running \/ not connected", "travelmate_version": "1.5.3", "station_id": "-\/-\/-", "station_interface": "-", "faulty_stations": "", "wpa_capabilities": "EAP\/-\/-", "last_rundate": "2020.04.20-06:22:38", "system": "Widora-NEO (16M), OpenWrt 19.07.2 r10947-65030d81f3" } }

After reboot & factory reset(following exact same zone/if name offered, macchange or other option field removed), uplink switching does not works, all wifi showed disabled(even uplink wlan manually enabled&connected). It just same as before(when I did not know about travel mate, just manually enable only single wwlan uplink)
I can not sure this is HW issue or OpenWRT or travelmate issue...
But, manual AP+STA(merged user defined single wpa_supplicant.conf) without issues. :roll_eyes:

Hi, thanks for the terse logs. Please remove this option (option trm_radio 'phy0') from your travelmate config, hit /etc/init.d/travelmate restart and send back the travelmate related logs (logread -e "travelmate". Thanks!

After removed trm_radio section : Automatic uplink selection seems work(all disabled -> pick available single uplink enabled)

But, still using phy0 scan through luci-app-travelmate, it disconnects my AP clients permanently( even travelmate service running or not )
Network -> Wireless -> phy0 Scan :: OK(during scan, AP side link alive)

Built in Network -> Wireless -> phy0 Scan
Mon Apr 20 10:07:23 2020 daemon.notice procd: Ping
Mon Apr 20 10:07:28 2020 daemon.notice procd: Ping
Mon Apr 20 10:07:33 2020 daemon.notice procd: Ping
Mon Apr 20 10:07:38 2020 daemon.notice procd: Ping
Mon Apr 20 10:07:39 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devic[ 4289.293673] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
es/platform/10300000.wmac/net/tmp.phy0","SUBSYSTEM":"net","DEVTYPE":"wlan","INTERFACE":"tmp.phy0","IFINDEX":"28","SEQNUM":"680"}}
Mon Apr 20 10:07:39 2020 daemon.notice procd: Command: exec
Mon Apr 20 10:07:39 2020 daemon.notice procd:  /[ 4289.321493] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
sbin/hotplug-call
Mon Apr 20 10:07:39 2020 daemon.notice procd:  net
Mon Apr 20 10:07:39 2020 daemon.notice procd: Message:
Mon Apr 20 10:07:39 2020 daemon.notice procd:  ACTION=add
Mon Apr 20 10:07:39 2020 daemon.notice procd:  DEVPATH=/devices/platform/10300000.wmac/net/tmp.phy0
Mon Apr 20 10:07:39 2020 daemon.notice procd:  SUBSYSTEM=net
Mon Apr 20 10:07:39 2020 daemon.notice procd:  DEVTYPE=wlan
Mon Apr 20 10:07:39 2020 daemon.notice procd:  INTERFACE=tmp.phy0
Mon Apr 20 10:07:39 2020 daemon.notice procd:  IFINDEX=28
Mon Apr 20 10:07:39 2020 daemon.notice procd:  SEQNUM=680
Mon Apr 20 10:07:39 2020 daemon.notice procd: Launched hotplug exec instance, pid=18491
Mon Apr 20 10:07:39 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-0","SUBSYSTEM":"queues","SEQNUM":"681"}}
Mon Apr 20 10:07:39 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-1","SUBSYSTEM":"queues","SEQNUM":"682"}}
Mon Apr 20 10:07:39 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-2","SUBSYSTEM":"queues","SEQNUM":"683"}}
Mon Apr 20 10:07:39 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-3","SUBSYSTEM":"queues","SEQNUM":"684"}}
Mon Apr 20 10:07:39 2020 kern.info kernel: [ 4289.293673] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 10:07:39 2020 kern.info kernel: [ 4289.321493] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 10:07:39 2020 daemon.notice procd: Finished hotplug exec instance, pid=18491
Mon Apr 20 10:07:43 2020 daemon.notice procd: Ping
Mon Apr 20 10:07:43 2020 daemon.notice procd: {{"ACTION":"remove","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-3","SUBSYSTEM":"queues","SEQNUM":"685"}}
Mon Apr 20 10:07:43 2020 daemon.notice procd: {{"ACTION":"remove","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-2","SUBSYSTEM":"queues","SEQNUM":"686"}}
Mon Apr 20 10:07:43 2020 daemon.notice procd: {{"ACTION":"remove","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-1","SUBSYSTEM":"queues","SEQNUM":"687"}}
Mon Apr 20 10:07:43 2020 daemon.notice procd: {{"ACTION":"remove","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-0","SUBSYSTEM":"queues","SEQNUM":"688"}}
Mon Apr 20 10:07:43 2020 daemon.notice procd: {{"ACTION":"remove","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0","SUBSYSTEM":"net","DEVTYPE":"wlan","INTERFACE":"tmp.phy0","IFINDEX":"28","SEQNUM":"689"}}
Mon Apr 20 10:07:43 2020 daemon.notice procd: Command: exec
Mon Apr 20 10:07:43 2020 daemon.notice procd:  /sbin/hotplug-call
Mon Apr 20 10:07:43 2020 daemon.notice procd:  net
Mon Apr 20 10:07:43 2020 daemon.notice procd: Message:
Mon Apr 20 10:07:43 2020 daemon.notice procd:  ACTION=remove
Mon Apr 20 10:07:43 2020 daemon.notice procd:  DEVPATH=/devices/platform/10300000.wmac/net/tmp.phy0
Mon Apr 20 10:07:43 2020 daemon.notice procd:  SUBSYSTEM=net
Mon Apr 20 10:07:43 2020 daemon.notice procd:  DEVTYPE=wlan
Mon Apr 20 10:07:43 2020 daemon.notice procd:  INTERFACE=tmp.phy0
Mon Apr 20 10:07:43 2020 daemon.notice procd:  IFINDEX=28
Mon Apr 20 10:07:43 2020 daemon.notice procd:  SEQNUM=689
Mon Apr 20 10:07:43 2020 daemon.notice procd: Launched hotplug exec instance, pid=18512
Mon Apr 20 10:07:43 2020 daemon.notice procd: Finished hotplug exec instance, pid=18512
Mon Apr 20 10:07:48 2020 daemon.notice procd: Ping
Mon Apr 20 10:07:49 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devices/platform/10300000.wmac/net/tm[ 4299.314509] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
p.phy0","SUBSYSTEM":"net","DEVTYPE":"wlan","INTERFACE":"tmp.phy0","IFINDEX":"29","SEQNUM":"690"}}
Mon Apr 20 10:07:49 2020 daemon.notice procd: Command: exec
Mon Apr 20 10:07:49 2020 daemon.notice procd:  /sbin/hotplug-cal[ 4299.340779] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
l
Mon Apr 20 10:07:49 2020 daemon.notice procd:  net
Mon Apr 20 10:07:49 2020 daemon.notice procd: Message:

Services -> Travelmate -> Wireless Stations -> Scan phy0 :: Breaks AP side connections until restart network

Mon Apr 20 09:32:26 2020 daemon.notice procd: Ping
Mon Apr 20 09:32:28 2020 user.debug travelmate-1.5.3[9752]: f_prepdev ::: config: phy0, disabled: -
Mon Apr 20 09:32:28 2020 user.debug travelmate-1.5.3[9752]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
Mon Apr 20 09:32:28 2020 user.info travelmate-1.5.3[9752]: travelmate instance stopped ::: action: stop, pid:
Mon Apr 20 09:32:28 2020 daemon.notice procd: Create service travelmate
Mon Apr 20 09:32:28 2020 daemon.notice procd: running /etc/init.d/travelmate running
Mon Apr 20 09:32:28 2020 daemon.notice procd: start /etc/init.d/travelmate running
Mon Apr 20 09:32:28 2020 daemon.notice procd: Create service travelmate
Mon Apr 20 09:32:28 2020 daemon.notice procd: Start instance travelmate::travelmate
Mon Apr 20 09:32:28 2020 daemon.notice procd: Started instance travelmate::travelmate[9813]
Mon Apr 20 09:32:28 2020 daemon.notice procd: running /etc/init.d/travelmate running
Mon Apr 20 09:32:28 2020 daemon.notice procd: start /etc/init.d/travelmate running
Mon Apr 20 09:32:28 2020 daemon.notice procd: stop /etc/init.d/travelmate running - took 0.394142497s
Mon Apr 20 09:32:29 2020 daemon.notice procd: stop /etc/init.d/travelmate running - took 0.209669814s
Mon Apr 20 09:32:29 2020 user.debug travelmate-1.5.3[9813]: f_prepdev ::: config: phy0, disabled: -
Mon Apr 20 09:32:29 2020 user.debug travelmate-1.5.3[9813]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
Mon Apr 20 09:32:29 2020 user.info travelmate-1.5.3[9813]: travelmate instance started ::: action: start, pid: 9813
Mon Apr 20 09:32:29 2020 user.debug travelmate-1.5.3[9813]: f_prepdev ::: config: phy0, disabled: -
Mon Apr 20 09:32:29 2020 user.debug travelmate-1.5.3[9813]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
Mon Apr 20 09:32:29 2020 user.debug travelmate-1.5.3[9813]: f_jsnup   ::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -, list_expiry: 0
Mon Apr 20 09:32:29 2020 user.debug travelmate-1.5.3[9813]: f_check   ::: mode: initial, name: -, status: , connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
Mon Apr 20 09:32:29 2020 user.debug travelmate-1.5.3[9813]: f_main    ::: status: , proactive: 1
Mon Apr 20 09:32:29 2020 user.debug travelmate-1.5.3[9813]: f_prepif  ::: config: ap01, mode: ap, network: ra0lan, radio: phy0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 0
Mon Apr 20 09:32:29 2020 user.debug travelmate-1.5.3[9813]: f_prepif  ::: config: mon01, mode: monitor, network: ra0mon, radio: phy0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 0
Mon Apr 20 09:32:30 2020 user.debug travelmate-1.5.3[9813]: f_prepif  ::: config: sta01, mode: sta, network: trmwan, radio: phy0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
Mon Apr 20 09:32:30 2020 user.debug travelmate-1.5.3[9813]: f_prepif  ::: config: sta02, mode: sta, network: trmwan, radio: phy0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
Mon Apr 20 09:32:30 2020 user.debug travelmate-1.5.3[9813]: f_prepif  ::: config: sta99, mode: sta, network: trmwan, radio: phy0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
Mon Apr 20 09:32:30 2020 user.debug travelmate-1.5.3[9813]: f_jsnup   ::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -, list_expiry: 0
Mon Apr 20 09:32:30 2020 user.debug travelmate-1.5.3[9813]: f_check   ::: mode: dev, name: phy0, status: false, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
Mon Apr 20 09:32:30 2020 user.debug travelmate-1.5.3[9813]: f_main    ::: iwinfo: /usr/bin/iwinfo, dev_list: phy0, sta_list: sta01-phy0 sta02-phy0 sta99-phy0, faulty_list: -
Mon Apr 20 09:32:30 2020 user.debug travelmate-1.5.3[9813]: f_main    ::: sta_radio: phy0, sta_essid: "#UPLINKsta01_BSSID#", sta_bssid: -
Mon Apr 20 09:32:30 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devices/platform/10300000.wmac/net/tm[ 2180.725051] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
p.phy0","SUBSYSTEM":"net","DEVTYPE":"wlan","INTERFACE":"tmp.phy0","IFINDEX":"20","SEQNUM":"605"}}
Mon Apr 20 09:32:30 2020 daemon.notice procd:[ 2180.745199] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
 Command: exec
Mon Apr 20 09:32:30 2020 daemon.notice procd:  /sbin/hotplug-call
Mon Apr 20 09:32:30 2020 daemon.notice procd:  net
Mon Apr 20 09:32:30 2020 daemon.notice procd: Message:
Mon Apr 20 09:32:30 2020 daemon.notice procd:  ACTION=add
Mon Apr 20 09:32:30 2020 daemon.notice procd:  DEVPATH=/devices/platform/10300000.wmac/net/tmp.phy0
Mon Apr 20 09:32:30 2020 daemon.notice procd:  SUBSYSTEM=net
Mon Apr 20 09:32:30 2020 daemon.notice procd:  DEVTYPE=wlan
Mon Apr 20 09:32:30 2020 daemon.notice procd:  INTERFACE=tmp.phy0
Mon Apr 20 09:32:30 2020 daemon.notice procd:  IFINDEX=20
Mon Apr 20 09:32:30 2020 daemon.notice procd:  SEQNUM=605
Mon Apr 20 09:32:30 2020 daemon.notice procd: Launched hotplug exec instance, pid=10008
Mon Apr 20 09:32:30 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-0","SUBSYSTEM":"queues","SEQNUM":"606"}}
Mon Apr 20 09:32:30 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-1","SUBSYSTEM":"queues","SEQNUM":"607"}}
Mon Apr 20 09:32:30 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-2","SUBSYSTEM":"queues","SEQNUM":"608"}}
Mon Apr 20 09:32:30 2020 daemon.notice procd: {{"ACTION":"add","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-3","SUBSYSTEM":"queues","SEQNUM":"609"}}
Mon Apr 20 09:32:30 2020 kern.info kernel: [ 2180.725051] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 09:32:30 2020 kern.info kernel: [ 2180.745199] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Mon Apr 20 09:32:30 2020 daemon.notice procd: Finished hotplug exec instance, pid=10008
Mon Apr 20 09:32:31 2020 daemon.notice procd: Ping
Mon Apr 20 09:32:32 2020 daemon.notice procd: {{"ACTION":"remove","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-3","SUBSYSTEM":"queues","SEQNUM":"610"}}
Mon Apr 20 09:32:32 2020 daemon.notice procd: {{"ACTION":"remove","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-2","SUBSYSTEM":"queues","SEQNUM":"611"}}
Mon Apr 20 09:32:32 2020 daemon.notice procd: {{"ACTION":"remove","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-1","SUBSYSTEM":"queues","SEQNUM":"612"}}
Mon Apr 20 09:32:32 2020 daemon.notice procd: {{"ACTION":"remove","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0/queues/tx-0","SUBSYSTEM":"queues","SEQNUM":"613"}}
Mon Apr 20 09:32:32 2020 daemon.notice procd: {{"ACTION":"remove","DEVPATH":"/devices/platform/10300000.wmac/net/tmp.phy0","SUBSYSTEM":"net","DEVTYPE":"wlan","INTERFACE":"tmp.phy0","IFINDEX":"20","SEQNUM":"614"}}
Mon Apr 20 09:32:32 2020 daemon.notice procd: Command: exec
Mon Apr 20 09:32:32 2020 daemon.notice procd:  /sbin/hotplug-call
Mon Apr 20 09:32:32 2020 daemon.notice procd:  net
Mon Apr 20 09:32:32 2020 daemon.notice procd: Message:
Mon Apr 20 09:32:32 2020 daemon.notice procd:  ACTION=remove
Mon Apr 20 09:32:32 2020 daemon.notice procd:  DEVPATH=/devices/platform/10300000.wmac/net/tmp.phy0
Mon Apr 20 09:32:32 2020 daemon.notice procd:  SUBSYSTEM=net
Mon Apr 20 09:32:32 2020 daemon.notice procd:  DEVTYPE=wlan
Mon Apr 20 09:32:32 2020 daemon.notice procd:  INTERFACE=tmp.phy0
Mon Apr 20 09:32:32 2020 daemon.notice procd:  IFINDEX=20
Mon Apr 20 09:32:32 2020 daemon.notice procd:  SEQNUM=614
Mon Apr 20 09:32:32 2020 daemon.notice procd: Launched hotplug exec instance, pid=10027
Mon Apr 20 09:32:32 2020 user.debug travelmate-1.5.3[9813]: f_main    ::: scan_radio: phy0, scan_buffer: 1024, scan_list: #LOTS_OF_SCANNED_SSIDes_AND_BSSIDes_PAIRS(JSON)#
Mon Apr 20 09:32:32 2020 daemon.notice procd: Finished hotplug exec instance, pid=10027
Mon Apr 20 09:32:32 2020 user.debug travelmate-1.5.3[9813]: f_main    ::: sta_radio: phy0, sta_essid: "#UPLINKsta02_SSID(NOT_IN_RANGE)#", sta_bssid: #UPLINKsta02_BSSID_MANUALLY_SPECIFIED#
Mon Apr 20 09:32:32 2020 user.debug travelmate-1.5.3[9813]: f_main    ::: sta_radio: phy0, sta_essid: "#UPLINKsta99_SSID(WITHIN_RANGE)#", sta_bssid: -
Mon Apr 20 09:32:32 2020 user.debug travelmate-1.5.3[9813]: f_main    ::: scan_quality: 82, scan_essid: "#UPLINKsta99_SSID(WITHIN_RANGE)#", scan_bssid: #UPLINKsta99_BSSID#, scan_open: -
Mon Apr 20 09:32:33 2020 daemon.notice hostapd: wl0ap: interface state ENABLED->DISABLED
Mon Apr 20 09:32:33 2020 daemon.debug hostapd: wl0ap: STA cc:20:e8:--:--:-- MLME: MLME-DEAUTHENTICATE.indication(cc:20:e8:--:--:--, 1)
Mon Apr 20 09:32:33 2020 daemon.notice hostapd: wl0ap: AP-STA-DISCONNECTED cc:20:e8:--:--:--
Mon Apr 20 09:32:33 2020 daemon.notice hostapd: wl0ap: AP-DISABLED
Mon Apr 20 09:32:33 2020 daemon.notice hostapd: wl0ap: CTRL-EVENT-TERMINATING
Mon Apr 20 09:32:33 2020 daemon.notice hostapd: nl80211: deinit ifname=wl0ap disabled_11b_rates=0
Mon Apr 20 09:32:33 2020 daemon.notice netifd: Network device 'wl0ap' link is down
Mon Apr 20 09:32:33 2020 daemon.notice netifd: Interface 'ra0lan' has link connectivity loss
#After phy0 scan through `luci-app-travelmate`, Client can not connect to AP until manually interface restart
root@OpenWrt:/# ifdown ra0lan
#Nothing happens on uplink(sta99)
...(snip)...
root@OpenWrt:/# ifup ra0lan
#Influenced to uplink(sta99) immediately
[ 3795.280209] wl0sta: deauthenticating from #UPLINKsta99_BSSID# by local choice (Reason: 3=DEAUTH_LEAVING)
[ 3807.985465] wl0sta: authenticate with #UPLINKsta99_BSSID#
[ 3808.014463] wl0sta: send auth to #UPLINKsta99_BSSID# (try 1/3)
[ 3808.021528] wl0sta: authenticated
[ 3808.046749] wl0sta: associate with #UPLINKsta99_BSSID# (try 1/3)
[ 3808.056285] wl0sta: RX AssocResp from #UPLINKsta99_BSSID# (capab=0x431 status=0 aid=1)
[ 3808.064508] wl0sta: associated

My mitigation: Disabling 'force_link' for wireless interface. This resolved ap link lost issues

Both wiresles scan called through hotplug-call, but travelmate's scan action breaks wireless links if force_link checked :thinking:

Still having casual(?) issues

  • Sometimes all station(even uplink connected) disabled status showed on Network -> Wireless : This happens, travelmate do nothing even one of uplink within range.
  • init script status option not working : 19.07.02's rc.common can not handle status ALL_COMMANDS :see_no_evil:

Anyway, Using travelmate is better idea than fighting with netifd vs custom wpa_supplicant.
Really appreciate your contribution + fast&kind support :smiling_face_with_three_hearts:

+This is small share, I had problems when interface names or aliases or zones (whatever) including '.' or '-' in 19.07.02. Some configuration troubles with '.', some others troubles with '-'. Please consider if you have troubles with network, wireless, firewall configurations.

Ah, at least I found/understand one of your problems: your radio is named "phy0" and all references as well ... travelmate (the author :smile:) is currently quite dumb and has hardcoded "radio[0-9]" as valid namespace. As a workaround rename "phy0" to "radio0" in your wireless config and test again ...

Regarding "status", that's a known limitation in 19.07.x. As a workaround add the following line to /etc/init.d/travelmate:

[...]
START=25
USE_PROCD=1

EXTRA_COMMANDS="status_service" # that's new, you can call it via /etc/init.d/travelmate status_service

[...]

Good luck!

However, I tested device name 'radio0', link breaks permanently scan through travelmate UI.
The only one way( as for now ), wireless interface 'force_link' option should disabled.
Just curious why Network -> Wireless -> Scan has no issues with 'force_link' enabled or not :roll_eyes:

Yeah, this mitigation enables status command

START=25
USE_PROCD=1
EXTRA_COMMANDS="${EXTRA_COMMANDS} status"
status(){
        status_service "$@"
}

trm_init="/etc/init.d/travelmate"
trm_script="/usr/bin/travelmate.sh"

Nope, that breaks current master - please use the "status_service" syntax.

Debug logs please (travelmate related) - thanks.

Services->Travelmate->Scan behavior(disconnects AP permanent) not influenced that travelmate running or not. Also, travelmate debug log does not including hotplug messages.

Anyway, here is my console logs(that only showing travelmate logs, therefore you don't know why stop switching/enabling uplink or disconnects AP while ondemand scan)

Line0 == Since U-boot started

Named as 'radio0' / AP interface 'force_link'(1)

  • Until uptime 34mins: Clients can not connect to AP(unseen) == can not test manual scan behavior
  • Even within ranges, does not try to enabling uplink.
  • Manually enable one of uplink -> then restart network -> testing scan( AP disconnected permanent ) <== already posted.
	Line 1135: Mon Apr 20 12:55:24 2020 daemon.notice hostapd: wl0ap: ACS-COMPLETED freq=2484 channel=14
	Line 1136: Mon Apr 20 12:55:24 2020 daemon.err hostapd: Using interface wl0ap with hwaddr 00:00:00:00:00:01 and ssid "SSIDOFAP"
	Line 1138: Mon Apr 20 12:55:24 2020 daemon.notice netifd: Network device 'wl0ap' link is up
	Line 1141: Mon Apr 20 12:55:24 2020 daemon.notice procd: ubus path hostapd.wl0ap
	Line 1142: Mon Apr 20 12:55:24 2020 daemon.notice hostapd: wl0ap: interface state ACS->ENABLED
	Line 1143: Mon Apr 20 12:55:24 2020 daemon.notice hostapd: wl0ap: AP-ENABLED
	Line 1150: Mon Apr 20 12:55:25 2020 daemon.notice procd: Received ubus notify 'interface.update': {"interface":"ra0lan","up":true,"pending":false,"available":true,"autostart":true,"dynamic":false,"uptime":0,"l3_device":"wl0ap","proto":"static","device":"wl0ap","updated":["addresses"],"metric":0,"dns_metric":0,"delegation":false,"ipv4-address":[{"address":"192.168.168.1","mask":24}],"ipv6-address":[],"ipv6-prefix":[],"ipv6-prefix-assignment":[],"route":[],"dns-server":[],"dns-search":[],"neighbors":[],"inactive":{"ipv4-address":[],"ipv6-address":[],"route":[],"dns-server":[],"dns-search":[],"neighbors":[]},"data":{}}
	Line 1150: Mon Apr 20 12:55:25 2020 daemon.notice procd: Received ubus notify 'interface.update': {"interface":"ra0lan","up":true,"pending":false,"available":true,"autostart":true,"dynamic":false,"uptime":0,"l3_device":"wl0ap","proto":"static","device":"wl0ap","updated":["addresses"],"metric":0,"dns_metric":0,"delegation":false,"ipv4-address":[{"address":"192.168.168.1","mask":24}],"ipv6-address":[],"ipv6-prefix":[],"ipv6-prefix-assignment":[],"route":[],"dns-server":[],"dns-search":[],"neighbors":[],"inactive":{"ipv4-address":[],"ipv6-address":[],"route":[],"dns-server":[],"dns-search":[],"neighbors":[]},"data":{}}
	Line 1156: Mon Apr 20 12:55:25 2020 user.notice firewall: Reloading firewall due to ifup of ra0lan (wl0ap)
	Line 1157: Mon Apr 20 12:55:25 2020 user.debug travelmate-1.5.3[940]: f_check   ::: mode: dev, name: radio0, status: false, connection: -, wait: 11, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 1158: Mon Apr 20 12:55:25 2020 user.debug travelmate-1.5.3[940]: f_main    ::: iwinfo: /usr/bin/iwinfo, dev_list: radio0, sta_list: sta01-radio0 sta02-radio0 sta99-radio0, faulty_list: -
	Line 1159: Mon Apr 20 12:55:26 2020 user.debug travelmate-1.5.3[940]: f_main    ::: sta_radio: radio0, sta_essid: "...(REDACT:SSID_OF_sta01)...", sta_bssid: -
	Line 1160: Mon Apr 20 12:55:26 2020 user.debug travelmate-1.5.3[940]: f_main    ::: scan_radio: radio0, scan_buffer: 1024, scan_list:
	Line 1161: Mon Apr 20 12:55:26 2020 user.debug travelmate-1.5.3[940]: f_main    ::: no scan results on 'radio0' - continue
	Line 1162: Mon Apr 20 12:55:26 2020 user.debug travelmate-1.5.3[940]: f_jsnup   ::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 1163: Mon Apr 20 12:55:26 2020 user.debug travelmate-1.5.3[940]: f_check   ::: mode: initial, name: -, status: false, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 1217: Mon Apr 20 12:56:26 2020 user.debug travelmate-1.5.3[940]: f_prepdev ::: config: radio0, disabled: -
	Line 1218: Mon Apr 20 12:56:26 2020 user.debug travelmate-1.5.3[940]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
	Line 1219: Mon Apr 20 12:56:26 2020 user.debug travelmate-1.5.3[940]: f_jsnup   ::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 1220: Mon Apr 20 12:56:26 2020 user.debug travelmate-1.5.3[940]: f_check   ::: mode: initial, name: -, status: false, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 1221: Mon Apr 20 12:56:26 2020 user.debug travelmate-1.5.3[940]: f_main    ::: status: false, proactive: 1
	Line 1222: Mon Apr 20 12:56:26 2020 user.debug travelmate-1.5.3[940]: f_prepif  ::: config: ap01, mode: ap, network: ra0lan, radio: radio0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 0
	Line 1223: Mon Apr 20 12:56:26 2020 user.debug travelmate-1.5.3[940]: f_prepif  ::: config: mon01, mode: monitor, network: ra0mon, radio: radio0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 0
	Line 1224: Mon Apr 20 12:56:26 2020 user.debug travelmate-1.5.3[940]: f_prepif  ::: config: sta01, mode: sta, network: trmwan, radio: radio0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
	Line 1225: Mon Apr 20 12:56:26 2020 user.debug travelmate-1.5.3[940]: f_prepif  ::: config: sta02, mode: sta, network: trmwan, radio: radio0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
	Line 1226: Mon Apr 20 12:56:27 2020 user.debug travelmate-1.5.3[940]: f_prepif  ::: config: sta99, mode: sta, network: trmwan, radio: radio0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
	Line 1227: Mon Apr 20 12:56:27 2020 user.debug travelmate-1.5.3[940]: f_check   ::: mode: dev, name: radio0, status: false, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 1228: Mon Apr 20 12:56:27 2020 user.debug travelmate-1.5.3[940]: f_main    ::: iwinfo: /usr/bin/iwinfo, dev_list: radio0, sta_list: sta01-radio0 sta02-radio0 sta99-radio0, faulty_list: -
	Line 1229: Mon Apr 20 12:56:27 2020 user.debug travelmate-1.5.3[940]: f_main    ::: sta_radio: radio0, sta_essid: "...REDACT:SSID_OF_sta01...", sta_bssid: -
	Line 1230: Mon Apr 20 12:56:27 2020 user.debug travelmate-1.5.3[940]: f_main    ::: scan_radio: radio0, scan_buffer: 1024, scan_list:
	Line 1231: Mon Apr 20 12:56:27 2020 user.debug travelmate-1.5.3[940]: f_main    ::: no scan results on 'radio0' - continue
	Line 1232: Mon Apr 20 12:56:27 2020 user.debug travelmate-1.5.3[940]: f_jsnup   ::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 1233: Mon Apr 20 12:56:27 2020 user.debug travelmate-1.5.3[940]: f_check   ::: mode: initial, name: -, status: false, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 1246: Mon Apr 20 12:57:27 2020 user.debug travelmate-1.5.3[940]: f_prepdev ::: config: radio0, disabled: -
	Line 1247: Mon Apr 20 12:57:27 2020 user.debug travelmate-1.5.3[940]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
	Line 1248: Mon Apr 20 12:57:27 2020 user.debug travelmate-1.5.3[940]: f_jsnup   ::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 1249: Mon Apr 20 12:57:27 2020 user.debug travelmate-1.5.3[940]: f_check   ::: mode: initial, name: -, status: false, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 1250: Mon Apr 20 12:57:27 2020 user.debug travelmate-1.5.3[940]: f_main    ::: status: false, proactive: 1
	Line 1251: Mon Apr 20 12:57:27 2020 user.debug travelmate-1.5.3[940]: f_prepif  ::: config: ap01, mode: ap, network: ra0lan, radio: radio0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 0
	Line 1252: Mon Apr 20 12:57:27 2020 user.debug travelmate-1.5.3[940]: f_prepif  ::: config: mon01, mode: monitor, network: ra0mon, radio: radio0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 0
	Line 1253: Mon Apr 20 12:57:27 2020 user.debug travelmate-1.5.3[940]: f_prepif  ::: config: sta01, mode: sta, network: trmwan, radio: radio0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
	Line 1254: Mon Apr 20 12:57:28 2020 user.debug travelmate-1.5.3[940]: f_prepif  ::: config: sta02, mode: sta, network: trmwan, radio: radio0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
	Line 1255: Mon Apr 20 12:57:28 2020 user.debug travelmate-1.5.3[940]: f_prepif  ::: config: sta99, mode: sta, network: trmwan, radio: radio0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
	Line 1256: Mon Apr 20 12:57:28 2020 user.debug travelmate-1.5.3[940]: f_check   ::: mode: dev, name: radio0, status: false, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 1257: Mon Apr 20 12:57:28 2020 user.debug travelmate-1.5.3[940]: f_main    ::: iwinfo: /usr/bin/iwinfo, dev_list: radio0, sta_list: sta01-radio0 sta02-radio0 sta99-radio0, faulty_list: -
	Line 1258: Mon Apr 20 12:57:28 2020 user.debug travelmate-1.5.3[940]: f_main    ::: sta_radio: radio0, sta_essid: "...REDACT:SSID_OF_sta01...", sta_bssid: -
	Line 1259: Mon Apr 20 12:57:28 2020 user.debug travelmate-1.5.3[940]: f_main    ::: scan_radio: radio0, scan_buffer: 1024, scan_list:
	Line 1260: Mon Apr 20 12:57:28 2020 user.debug travelmate-1.5.3[940]: f_main    ::: no scan results on 'radio0' - continue
	Line 1261: Mon Apr 20 12:57:28 2020 user.debug travelmate-1.5.3[940]: f_jsnup   ::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 1262: Mon Apr 20 12:57:28 2020 user.debug travelmate-1.5.3[940]: f_check   ::: mode: initial, name: -, status: false, connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
#loop every 1 mins, no other hotplug messages seen on full console logs

Named as 'phy0' / all wireless interface 'force_link'(0)
Mon Apr 20 12:38:20 connected one of available uplink.
Mon Apr 20 12:46:36 ~ 47:11 multiple scan(Network->Wireless->Scan) : FINE
Mon Apr 20 12:48:46 ~ 50:00 multiple scan(Services->Travelmate->Scan) : FINE

	Line 1008: Mon Apr 20 12:37:44 2020 user.debug travelmate-1.5.3[945]: f_prepdev ::: config: phy0, disabled: -
	Line 1009: Mon Apr 20 12:37:44 2020 user.debug travelmate-1.5.3[945]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
	Line 1010: Mon Apr 20 12:37:44 2020 user.info travelmate-1.5.3[945]: travelmate instance started ::: action: start, pid: 945
	Line 1013: Mon Apr 20 12:37:45 2020 user.debug travelmate-1.5.3[945]: f_prepdev ::: config: phy0, disabled: -
	Line 1031: Mon Apr 20 12:37:45 2020 user.debug travelmate-1.5.3[945]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
	Line 1040: Mon Apr 20 12:37:45 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 1042: Mon Apr 20 12:37:46 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: initial, name: -, status: , connection: -, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 1043: Mon Apr 20 12:37:46 2020 user.debug travelmate-1.5.3[945]: f_main    ::: status: , proactive: 1
	Line 1064: Mon Apr 20 12:37:46 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: ap01, mode: ap, network: ra0lan, radio: phy0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 0
	Line 1071: Mon Apr 20 12:37:46 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: mon01, mode: monitor, network: ra0mon, radio: phy0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 0
	Line 1076: Mon Apr 20 12:37:47 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta01, mode: sta, network: trmwan, radio: phy0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
	Line 1079: Mon Apr 20 12:37:47 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta02, mode: sta, network: trmwan, radio: phy0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
	Line 1081: Mon Apr 20 12:37:47 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta99, mode: sta, network: trmwan, radio: phy0, trm_radio: -, trm_active_sta: -, proactive: 1, disabled: 1
	Line 1083: Mon Apr 20 12:37:47 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: -, status: running / not connected, sta_iface: -, sta_radio: -, sta_essid: -, sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 1336: Mon Apr 20 12:37:57 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: dev, name: phy0, status: false, connection: -, wait: 10, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 1337: Mon Apr 20 12:37:57 2020 user.debug travelmate-1.5.3[945]: f_main    ::: iwinfo: /usr/bin/iwinfo, dev_list: phy0, sta_list: sta01-phy0 sta02-phy0 sta99-phy0, faulty_list: -
	Line 1338: Mon Apr 20 12:37:57 2020 user.debug travelmate-1.5.3[945]: f_main    ::: sta_radio: phy0, sta_essid: "...(REDACT:SSID_OF_sta01)...", sta_bssid: -
	Line 1381: Mon Apr 20 12:37:59 2020 user.debug travelmate-1.5.3[945]: f_main    ::: scan_radio: phy0, scan_buffer: 1024, scan_list: ...(REDACT)...
	Line 1382: Mon Apr 20 12:37:59 2020 user.debug travelmate-1.5.3[945]: f_main    ::: sta_radio: phy0, sta_essid: "...(REDACT:SSID_OF_sta02)...", sta_bssid: ...(REDACT:BSSID_OF_sta02)...
	Line 1383: Mon Apr 20 12:37:59 2020 user.debug travelmate-1.5.3[945]: f_main    ::: sta_radio: phy0, sta_essid: "...(REDACT:SSID_OF_sta99)...", sta_bssid: -
	Line 1384: Mon Apr 20 12:37:59 2020 user.debug travelmate-1.5.3[945]: f_main    ::: scan_quality: 74, scan_essid: "...(REDACT:SSID_OF_sta99)...", scan_bssid: ...(REDACT:sta99_OneofBSSIDes)..., scan_open: -
	Line 1892: Mon Apr 20 12:38:20 2020 user.debug travelmate-1.5.3[945]: f_net     ::: fetch: /bin/uclient-fetch, timeout: 5, url: http://captive.apple.com, result: net ok
	Line 1896: Mon Apr 20 12:38:20 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: sta99, status: connected (net ok/74), sta_iface: trmwan, sta_radio: phy0, sta_essid: ...(REDACT:SSID_OF_sta99)..., sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 1897: Mon Apr 20 12:38:20 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: sta, name: wl0sta, status: true, connection: net ok/74, wait: 12, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 1898: Mon Apr 20 12:38:20 2020 user.info travelmate-1.5.3[945]: connected to uplink 'phy0/...(REDACT:SSID_OF_sta99).../-' (1/5, Widora-NEO (16M), OpenWrt 19.07.2 r10947-65030d81f3)
	Line 1900: Mon Apr 20 12:38:21 2020 user.debug travelmate-1.5.3[945]: f_net     ::: fetch: /bin/uclient-fetch, timeout: 5, url: http://captive.apple.com, result: net ok
	Line 1901: Mon Apr 20 12:38:21 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: sta99, status: connected (net ok/74), sta_iface: trmwan, sta_radio: phy0, sta_essid: ...(REDACT:SSID_OF_sta99)..., sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 1902: Mon Apr 20 12:38:21 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: initial, name: wl0sta, status: true, connection: net ok/74, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	-------------------uplink available(NTP), therefore huge time jumped-------------------
	Line 2001: Mon Apr 20 12:46:56 2020 user.debug travelmate-1.5.3[945]: f_prepdev ::: config: phy0, disabled: -
	Line 2020: Mon Apr 20 12:46:56 2020 user.debug travelmate-1.5.3[945]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
	Line 2021: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_net     ::: fetch: /bin/uclient-fetch, timeout: 5, url: http://captive.apple.com, result: net ok
	Line 2022: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: sta99, status: connected (net ok/74), sta_iface: trmwan, sta_radio: phy0, sta_essid: ...(REDACT:SSID_OF_sta99)..., sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 2023: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: initial, name: wl0sta, status: true, connection: net ok/74, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2024: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_main    ::: status: true, proactive: 1
	Line 2025: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: ap01, mode: ap, network: ra0lan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 0
	Line 2026: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: mon01, mode: monitor, network: ra0mon, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 0
	Line 2027: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta01, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 1
	Line 2028: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta02, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 1
	Line 2029: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta99, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: sta99, proactive: 1, disabled: 0
	Line 2030: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: dev, name: -, status: true, connection: net ok/74, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2031: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_main    ::: active_radio: phy0, active_essid: "...(REDACT:SSID_OF_sta99)...", active_bssid: -
	Line 2032: Mon Apr 20 12:46:57 2020 user.debug travelmate-1.5.3[945]: f_main    ::: iwinfo: /usr/bin/iwinfo, dev_list: -, sta_list: sta01-phy0 sta02-phy0 sta99-phy0, faulty_list: -
	Line 2033: Mon Apr 20 12:46:58 2020 user.debug travelmate-1.5.3[945]: f_net     ::: fetch: /bin/uclient-fetch, timeout: 5, url: http://captive.apple.com, result: net ok
	Line 2034: Mon Apr 20 12:46:58 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: sta99, status: connected (net ok/72), sta_iface: trmwan, sta_radio: phy0, sta_essid: ...(REDACT:SSID_OF_sta99)..., sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 2035: Mon Apr 20 12:46:58 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: initial, name: wl0sta, status: true, connection: net ok/72, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2208: Mon Apr 20 12:47:58 2020 user.debug travelmate-1.5.3[945]: f_prepdev ::: config: phy0, disabled: -
	Line 2209: Mon Apr 20 12:47:58 2020 user.debug travelmate-1.5.3[945]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
	Line 2210: Mon Apr 20 12:47:59 2020 user.debug travelmate-1.5.3[945]: f_net     ::: fetch: /bin/uclient-fetch, timeout: 5, url: http://captive.apple.com, result: net ok
	Line 2211: Mon Apr 20 12:47:59 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: sta99, status: connected (net ok/74), sta_iface: trmwan, sta_radio: phy0, sta_essid: ...(REDACT:SSID_OF_sta99)..., sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 2212: Mon Apr 20 12:47:59 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: initial, name: wl0sta, status: true, connection: net ok/74, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2213: Mon Apr 20 12:47:59 2020 user.debug travelmate-1.5.3[945]: f_main    ::: status: true, proactive: 1
	Line 2214: Mon Apr 20 12:47:59 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: ap01, mode: ap, network: ra0lan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 0
	Line 2215: Mon Apr 20 12:47:59 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: mon01, mode: monitor, network: ra0mon, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 0
	Line 2216: Mon Apr 20 12:47:59 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta01, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 1
	Line 2217: Mon Apr 20 12:47:59 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta02, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 1
	Line 2218: Mon Apr 20 12:47:59 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta99, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: sta99, proactive: 1, disabled: 0
	Line 2219: Mon Apr 20 12:47:59 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: dev, name: -, status: true, connection: net ok/74, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2220: Mon Apr 20 12:48:00 2020 user.debug travelmate-1.5.3[945]: f_main    ::: active_radio: phy0, active_essid: "...(REDACT:SSID_OF_sta99)...", active_bssid: -
	Line 2221: Mon Apr 20 12:48:00 2020 user.debug travelmate-1.5.3[945]: f_main    ::: iwinfo: /usr/bin/iwinfo, dev_list: -, sta_list: sta01-phy0 sta02-phy0 sta99-phy0, faulty_list: -
	Line 2222: Mon Apr 20 12:48:00 2020 user.debug travelmate-1.5.3[945]: f_net     ::: fetch: /bin/uclient-fetch, timeout: 5, url: http://captive.apple.com, result: net ok
	Line 2223: Mon Apr 20 12:48:01 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: sta99, status: connected (net ok/74), sta_iface: trmwan, sta_radio: phy0, sta_essid: ...(REDACT:SSID_OF_sta99)..., sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 2224: Mon Apr 20 12:48:01 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: initial, name: wl0sta, status: true, connection: net ok/74, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2277: Mon Apr 20 12:49:01 2020 user.debug travelmate-1.5.3[945]: f_prepdev ::: config: phy0, disabled: -
	Line 2278: Mon Apr 20 12:49:01 2020 user.debug travelmate-1.5.3[945]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
	Line 2280: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_net     ::: fetch: /bin/uclient-fetch, timeout: 5, url: http://captive.apple.com, result: net ok
	Line 2281: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: sta99, status: connected (net ok/72), sta_iface: trmwan, sta_radio: phy0, sta_essid: ...(REDACT:SSID_OF_sta99)..., sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 2282: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: initial, name: wl0sta, status: true, connection: net ok/72, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2283: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_main    ::: status: true, proactive: 1
	Line 2284: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: ap01, mode: ap, network: ra0lan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 0
	Line 2285: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: mon01, mode: monitor, network: ra0mon, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 0
	Line 2286: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta01, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 1
	Line 2287: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta02, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 1
	Line 2288: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta99, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: sta99, proactive: 1, disabled: 0
	Line 2289: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: dev, name: -, status: true, connection: net ok/72, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2290: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_main    ::: active_radio: phy0, active_essid: "...(REDACT:SSID_OF_sta99)...", active_bssid: -
	Line 2291: Mon Apr 20 12:49:02 2020 user.debug travelmate-1.5.3[945]: f_main    ::: iwinfo: /usr/bin/iwinfo, dev_list: -, sta_list: sta01-phy0 sta02-phy0 sta99-phy0, faulty_list: -
	Line 2292: Mon Apr 20 12:49:03 2020 user.debug travelmate-1.5.3[945]: f_net     ::: fetch: /bin/uclient-fetch, timeout: 5, url: http://captive.apple.com, result: net ok
	Line 2293: Mon Apr 20 12:49:03 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: sta99, status: connected (net ok/72), sta_iface: trmwan, sta_radio: phy0, sta_essid: ...(REDACT:SSID_OF_sta99)..., sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 2294: Mon Apr 20 12:49:03 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: initial, name: wl0sta, status: true, connection: net ok/72, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2387: Mon Apr 20 12:50:03 2020 user.debug travelmate-1.5.3[945]: f_prepdev ::: config: phy0, disabled: -
	Line 2388: Mon Apr 20 12:50:03 2020 user.debug travelmate-1.5.3[945]: f_env     ::: trm_eapcheck: 0, trm_saecheck: 1, trm_owecheck: 1, trm_wificmd: reload
	Line 2389: Mon Apr 20 12:50:04 2020 user.debug travelmate-1.5.3[945]: f_net     ::: fetch: /bin/uclient-fetch, timeout: 5, url: http://captive.apple.com, result: net ok
	Line 2390: Mon Apr 20 12:50:04 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: sta99, status: connected (net ok/72), sta_iface: trmwan, sta_radio: phy0, sta_essid: ...(REDACT:SSID_OF_sta99)..., sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 2391: Mon Apr 20 12:50:04 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: initial, name: wl0sta, status: true, connection: net ok/72, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2392: Mon Apr 20 12:50:04 2020 user.debug travelmate-1.5.3[945]: f_main    ::: status: true, proactive: 1
	Line 2393: Mon Apr 20 12:50:04 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: ap01, mode: ap, network: ra0lan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 0
	Line 2394: Mon Apr 20 12:50:04 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: mon01, mode: monitor, network: ra0mon, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 0
	Line 2395: Mon Apr 20 12:50:04 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta01, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 1
	Line 2396: Mon Apr 20 12:50:05 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta02, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: -, proactive: 1, disabled: 1
	Line 2397: Mon Apr 20 12:50:05 2020 user.debug travelmate-1.5.3[945]: f_prepif  ::: config: sta99, mode: sta, network: trmwan, radio: phy0, trm_radio: phy0, trm_active_sta: sta99, proactive: 1, disabled: 0
	Line 2398: Mon Apr 20 12:50:05 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: dev, name: -, status: true, connection: net ok/72, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1
	Line 2399: Mon Apr 20 12:50:05 2020 user.debug travelmate-1.5.3[945]: f_main    ::: active_radio: phy0, active_essid: "...(REDACT:SSID_OF_sta99)...", active_bssid: -
	Line 2400: Mon Apr 20 12:50:05 2020 user.debug travelmate-1.5.3[945]: f_main    ::: iwinfo: /usr/bin/iwinfo, dev_list: -, sta_list: sta01-phy0 sta02-phy0 sta99-phy0, faulty_list: -
	Line 2401: Mon Apr 20 12:50:05 2020 user.debug travelmate-1.5.3[945]: f_net     ::: fetch: /bin/uclient-fetch, timeout: 5, url: http://captive.apple.com, result: net ok
	Line 2402: Mon Apr 20 12:50:05 2020 user.debug travelmate-1.5.3[945]: f_jsnup   ::: config: sta99, status: connected (net ok/72), sta_iface: trmwan, sta_radio: phy0, sta_essid: ...(REDACT:SSID_OF_sta99)..., sta_bssid: -, faulty_list: -, list_expiry: 0
	Line 2403: Mon Apr 20 12:50:05 2020 user.debug travelmate-1.5.3[945]: f_check   ::: mode: initial, name: wl0sta, status: true, connection: net ok/72, wait: 1, max_wait: 30, min_quality: 35, captive: 1, netcheck: 1

Oops, still having AP side connection reset issue even 'force_link(0)'
There was no issues with disabling travelmate then specify uplink manually.
But, Now I suspect hostapd or probably MT7688 wifi driver on 19.07.2... but no idea how to tracing this problems( AP activated only one of STA established )

Will check removing 'macaddr' & 'bssid' options, and removing 'ifname' assignment on AP interface.

@didbot
Even though my MT7688's internal phy0 capability is followings

        valid interface combinations:
                 * #{ IBSS } <= 1, #{ managed, AP, mesh point } <= 4,
                   total <= 4, #channels <= 1, STA/AP BI must match

If current uplink gone, does not change another available uplink or mark as gone stations.
Maybe problems on 19.07.02's wpad or hostapd...(unsure)

No luck with...

  • factory reset
  • channel 'auto'/fixed
  • removing 'macaddress' and 'ifname' assignments to both /etc/conf/wireless, /etc/conf/network
  • default travelmate configurations

Followings is factory radio configurations.

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10300000.wmac'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

Will check adding bit old RTL8192CU adapter for AP, then 'radio0' for STA only mode.
*19.07.02 seems unstable when I soft reset, older name/directives popups when kernel loading( changing 'radio0' to 'phy0' or vice versa). Now if I cange some configurations, then always hard reset for make sure :expressionless:

'netifd' and 'ubus' is hurdle for me.
my poor workaround(before I did not know about travelmate) was like below

  • enable all uplink(STA) - yes, this will assoc/disassoc massively when starting more two uplink available with different channel;
  • after all sta up, immediately cat all wpa_supplicant* then make single wpa_supplicant
  • disables all STA interface manually - still netifd engaging
  • make vif for merged single wpa_supplicant, then up - also this manual enabled vif too...

One suggestions for travelmate( If you have spare time ),
Like debian('pre-up', 'post-up') hostpad & wpa_client cooperations...
if AP+STA configured on same physical interface -> check channel capability -> if 1 == 'uci set wireless.${INTERFACE_OF_AP}.channel="$CONNECTED_STA_CHANNEL"' for hostapd channel refresh smoothly.
-But I don't know how to dynamically reload hostapd configurations correctly through 'ubus' or 'netifd';

root@OpenWrt:/# find /etc/hotplug* -type f
/etc/hotplug-preinit.json
/etc/hotplug.d/firmware/10-rt2x00-eeprom
/etc/hotplug.d/ieee80211/10-wifi-detect
/etc/hotplug.d/iface/00-netstate
/etc/hotplug.d/iface/20-firewall
/etc/hotplug.d/net/00-sysctl
/etc/hotplug.d/net/20-smp-tune
/etc/hotplug.d/ntp/25-dnsmasqsec
/etc/hotplug.d/usb/10-motion
/etc/hotplug.json

Sorry for messing official support threads for my personal issues; and thanks again your best support.