I am doing attempt to get Raspberry Pi 2W with OpenWrt and Travelmate setup
I think I get an issue with the Travelmate setup or wizard.
So
- My model and versions are as follows:
Model : Raspberry Pi Zero 2 W Rev 1.0
Architecture : ARMv8 Processor rev 4
Target Platform : bcm27xx/bcm2710
Firmware Version : OpenWrt 23.05.0-rc3 r23389-5deed175a5 / LuCI openwrt-23.05 branch git-23.219.80063-bece581
Kernel Version : 5.15.127
I flash openwrt-23.05.0-rc3-bcm27xx-bcm2710-rpi-3-ext4-factory.img
which includes drivers for the WiFi
-
On Wireless I have
radio0 - Cypress CYW43455 802.11b/g/n -
Also on the sdcard I put all the required packages for Travelmate, to install offline, because there is no other interface to connect to internet:
curl_8.2.1-1_aarch64_cortex-a53.ipk
kmod-tun_5.15.127-1_aarch64_cortex-a53.ipk
libatomic1_12.3.0-4_aarch64_cortex-a53.ipk
libcurl4_8.2.1-1_aarch64_cortex-a53.ipk
libgmp10_6.2.1-1_aarch64_cortex-a53.ipk
libgnutls_3.8.0-3_aarch64_cortex-a53.ipk
libnettle8_3.9.1-1_aarch64_cortex-a53.ipk
libnghttp2-14_1.51.0-1_aarch64_cortex-a53.ipk
libqrencode_4.1.1-1_aarch64_cortex-a53.ipk
luci-app-travelmate_git-23.189.73029-ac423e9_all.ipk
msmtp_1.8.19-1_aarch64_cortex-a53.ipk
openvpn-mbedtls_2.5.8-3_aarch64_cortex-a53.ipk
qrencode_4.1.1-1_aarch64_cortex-a53.ipk
travelmate_2.1.0-1_all.ipk
-
Insert the sdcard and power on the Raspberry
-
Enable the wifi interface (either using keyboard or startup script)
uci set wireless.@wifi-device[0].disabled="0"
uci commit wireless
wifi
- Install all the packages above
opkg install /root/*
-
Connect to the default SSID
OpenWrt
, no password
root@OpenWrt:~# iw list
Wiphy phy0
wiphy index: 0
max # scan SSIDs: 10
max scan IEs length: 2048 bytes
max # sched scan SSIDs: 0
max # match sets: 0
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Available Antennas: TX 0 RX 0
Supported interface modes:
* IBSS
* managed
* AP
* P2P-client
* P2P-GO
* P2P-device
Band 1:
Capabilities: 0x1020
HT20
Static SM Power Save
RX HT20 SGI
No RX STBC
Max AMSDU length: 3839 bytes
DSSS/CCK HT40
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 16 usec (0x07)
HT TX/RX MCS rate indexes supported: 0-7
Frequencies:
* 2412 MHz [1] (20.0 dBm)
* 2417 MHz [2] (20.0 dBm)
* 2422 MHz [3] (20.0 dBm)
* 2427 MHz [4] (20.0 dBm)
* 2432 MHz [5] (20.0 dBm)
* 2437 MHz [6] (20.0 dBm)
* 2442 MHz [7] (20.0 dBm)
* 2447 MHz [8] (20.0 dBm)
* 2452 MHz [9] (20.0 dBm)
* 2457 MHz [10] (20.0 dBm)
* 2462 MHz [11] (20.0 dBm)
* 2467 MHz [12] (disabled)
* 2472 MHz [13] (disabled)
* 2484 MHz [14] (disabled)
valid interface combinations:
* #{ managed } <= 1, #{ P2P-device } <= 1, #{ P2P-client, P2P-GO } <= 1,
total <= 3, #channels <= 2
* #{ managed } <= 1, #{ AP } <= 1, #{ P2P-client } <= 1, #{ P2P-device } <= 1,
total <= 4, #channels <= 1
max # scan plans: 1
max scan plan interval: -1
max scan plan iterations: 0
Supported extended features:
* [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
root@OpenWrt:~# uci export network
package network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdc5:9d5f:e6e4::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
root@OpenWrt:~# ifconfig
br-lan Link encap:Ethernet HWaddr E4:5F:01:8B:28:55
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::e65f:1ff:fe8b:7655/64 Scope:Link
inet6 addr: fdc5:9d5f:e6e4::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8791 errors:0 dropped:0 overruns:0 frame:0
TX packets:8432 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:970056 (947.3 KiB) TX bytes:1444101 (1.3 MiB)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:1104 errors:0 dropped:0 overruns:0 frame:0
TX packets:1104 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:85932 (83.9 KiB) TX bytes:85932 (83.9 KiB)
phy0-ap0 Link encap:Ethernet HWaddr E4:5F:01:8B:28:55
inet6 addr: fe80::e65f:1ff:fe8b:7655/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8791 errors:0 dropped:0 overruns:0 frame:0
TX packets:8724 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:970056 (947.3 KiB) TX bytes:1495126 (1.4 MiB)
-
I run the Travelmate Interface Wizard, but not sure exactly what values I should put, so I wrote the suggested from the placeholders
trm_wwan
wan
100 -
Now I "Enable the travelmate service." and try to connect to my home WiFi
-
And when I save the configuration together with my home WiFi, OpenWrt ssid disappears and I can not connect back
-
Using the keyboard I can see the current configuration:
There is new interface phy0-sta0
that has gottne IP from my home network but Luci is not accessible
and uci export network
returns two new interfaces trm_wwan
and trm_wwan6
-
Travelmate status is connected to my home wifi.
-
I was expecting that default network will stay and have internet, but no
Any suggestions, or what else I can check?
Edit:
I set the firewall to lan and I am able to access Luci using the home wifi IP.
And one error that I can seen in the terminal is:
ieee80211 phy0: brcmf_cfg80211_get_channel: chanspec failed (-52)