Transmission not working when using openwrt on same network as workgroup peer

I am using openwrt as secondary router. here i am have provided it a static local ip and dhcp disable. I am able to browse it on local and using its attached network drive too but transmission is not working.

Please do the needful, your help is appreaciated.


This is a forum of volunteers. How about you do the needful and provide some information which can help your audience to help you?

You can start with your router's configuration as well as details of your network topology.

Can you please elaborate

Certainly. You have come into this forum and demanded - "do the needful" - that complete strangers, all of whom are volunteers, help you. But you have not provided any detail about your configuration which will help the members of this forum to help you.

No-one here is telepathic. If you can provide details of your router's configuration, as well as your network topology, along with details of all the troubleshooting steps you have attempted so far with their results, it will improve the chances of someone here being able to help you.

1 Like

Actually, i am using wifi from ISP router, i have another router with openwrt. If i connect it with lan from ISP router through internet port,it will create a separate network. I don't want to create two network I want only single network so I can use transmission and attached storage.

For example, my ISP router on and openwrt through internet, here transmission is working perfectly but not able to access attached drive on ISP network.

For now i configured openwrt, provide it a static IP and DHCP configuration off. Now both are on same network, i am able to access openwrt attached storage and luci web, but transmission is not working.

I want to make working both, transmission and attached storage on a single network.

That's a big improvement, thank you.

From your description, it sounds as if you are connecting the two routers with a cable ("internet port").

If so, then it also sounds like you're almost there.

When you gave OpenWRT a static IP address, did you also assign a gateway/default route? By default, the LAN interface does not need a gateway, because in normal use as a router it is the gateway. However, the way you're using it, OpenWRT is simply one more device on your ISP router's network ( And, in that case, OpenWRT needs to know how to get to the Internet; i.e. a gateway or a default route.

What are the contents of /etc/config/network from OpenWRT?

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fa2a:d333:8t69::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask ''
	option ip6assign '60'
	option gateway ''
	option ipaddr ''

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

Static IP requires manual input of DNS IPs as well.

Or you could set the lan side as DHCP client, just like wan, in the config you've posted.

1 Like

Thanks @frollic ,
Could you please share modified config? I am not able to find option on luci.

Which one of them ?

Any, which can make transmission working.

that can't be guaranteed, you might not have done what's needful ...

change lan in /etc/config/network to

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

then reboot.
note, the IP of your openwrt device might now change.

Applied, now IP has been changed but issue not resolved yet. still transmission not working.

Connect the cable from a lan port on the isp router to a lan port on the openwrt router

it was the first step, already did, currently both connected through Lan

Check if the DNS is working with a nslookup. Als try a ping. Maybe that will give some more clues.

Are you using ipv6 on the isp router?

that's kind of vague thought ...

1 Like

Apologies :pray:
Please suggest if anything can help.

Start by answering the questions you've been asked.

1 Like

Okay, now IP has been changed, i am able to access luci interface with new DHCP IP.
Transmission is still showing retrieving metadata.. any idea?