Transmission file permission

I have a USB drive attached to my OpenWRT router which I have mapped under Windows (Samba installed on the router)...

I have Transmission installed on my router and the download folder is on the same NAS drive.

I can read/write any file on the NAS drive from Windows except everything file/folder inside the Transmission download folder. I havent tried any workarounds so far as I'm not an experienced user and don't wanna screw something up.

How can I delete files downloaded by Transmission (deleting them from the Transmission web interface is out of the question as whenever the router restarts the download list disappears)

check the permissions on the transmission dir(s), and the umask for transmission files and folders ?

1 Like

Not sure how to do that. Are there any terminal commands? I'm a basic user but wont mind some fiddling...

from ssh ls -ld <the transmission folder>

1 Like

I did this but still no luck. Is a reboot needed or something?

The transmission folder will only allow reading in the folder for non-root users.

A chmod 777 /mmt/sdc/transmission will get you write permission in the folder, but we don't know anything about the subfolders.
Do they have the same drwxr-xr-xr ?

1 Like

fixed it already with the following

root@OpenWrt:/mnt/sdc/transmission/done# chmod 777 */
root@OpenWrt:/mnt/sdc/transmission/done# find . -type d -exec chmod 777 {} +

This might only work for already existing folders, not new ones.

I don't know what to do in this case?

This is how permissions look like

root@OpenWrt:/mnt/sdc/transmission# drwxrwxrwx 22 transmis transmis

do the chmod again, or change the umask parameter in the transmission config, it's probably 022, but you want it to be 000.

1 Like

umask parameter is 18

I will change it to 000

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.