Transmission config location is always empty

I am using OpenWrt 21.02.1 on Linksys EA8300. I've configured transmission to download torrents to my USB-HDD at "/mnt/sda1/transmission/downloads". Also I've changed config directory to "/mnt/sda1/transmission/config". But that config directory is always empty and I lose all my torrents (not an actual data downloaded) after router restart.
How can i fix this?

Here is content of /etc/config/transmission file

config transmission
        option config_overwrite '1'
        option mem_percentage '50'
        option nice '10'
        option alt_speed_enabled 'false'
        option alt_speed_time_enabled 'false'
        option bind_address_ipv4 '0.0.0.0'
        option bind_address_ipv6 '::'
        option blocklist_enabled 'false'
        option cache_size_mb '2'
        option dht_enabled 'true'
        option download_queue_enabled 'true'
        option encryption '1'
        option idle_seeding_limit_enabled 'false'
        option incomplete_dir_enabled 'false'
        option lazy_bitfield_enabled 'true'
        option lpd_enabled 'false'
        option message_level '1'
        option peer_limit_global '240'
        option peer_limit_per_torrent '60'
        option peer_port '51413'
        option peer_port_random_on_start 'false'
        option peer_socket_tos 'default'
        option pex_enabled 'true'
        option port_forwarding_enabled 'true'
        option preallocation '1'
        option queue_stalled_enabled 'true'
        option ratio_limit_enabled 'false'
        option rename_partial_files 'true'
        option rpc_enabled 'true'
        option scrape_paused_torrents_enabled 'true'
        option script_torrent_done_enabled 'false'
        option seed_queue_enabled 'false'
        option speed_limit_down_enabled 'false'
        option speed_limit_up_enabled 'false'
        option start_added_torrents 'true'
        option trash_original_torrent_files 'false'
        option umask '18'
        option upload_slots_per_torrent '14'
        option utp_enabled 'true'
        option scrape_paused_torrents 'true'
        option watch_dir_enabled 'false'
        option download_dir '/mnt/sda1/transmission/downloads'
        option user 'transmission'
        option group 'transmission'
        option config_dir '/mnt/sda1/transmission/config'
        option rpc_bind_address '0.0.0.0'
        option rpc_port '9091'
        option rpc_url '/transmission/'
        option rpc_host_whitelist_enabled 'false'
        option rpc_authentication_required 'false'
        option enabled '1'
        option rpc_whitelist_enabled 'false'

In regular Linux, transmission stores the config in a json file, in a dir called .config, it's 'hidden' , make sure to check for hidden files and dirs in your config dir.

1 Like

The service runs under unprivileged user/group:

Fix owner/permissions across the entire path to the config directory:

Can you explain me how to do this? I am new to Linux :slight_smile:

As I understood there is no any permission problem

root@Router:~# ls -l /mnt/sda1/transmission
drwxrwxrwx    2 root     root          4096 Dec  5 21:47 config
drwxrwxrwx    2 root     root          4096 Dec  7 21:44 downloads

But transmission still doesn't write anything to config directory.

Problem solved. Transmission daemon must be stopped before changing configuration and then started again. If change configuration first and then restart daemon, transmission will ignore changes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.