Transmission bypassing OpenVpn

hi. how to start traffic transmission bypassing openvpn through vpn-policy-routing on the router?

You'll have to assign/use/bind to an IP that you can then config thru PBR.

(I manually make routes and rules for my use cases, so I'm not familiar with the PBR app/package in OpenWrt, unfortunately.)

Is transmission running on OpenWrt or on some host in the lan?

1 Like

on the router

Then use the source ports that you have assigned to transmission and select OUTPUT chain when configuring the policy.

this does not work. traffic separation works great for clients but not on the router itself, apparently it's all because of the openvpn route. if you add "pull-filter ignore redirect-gateway" a line to the config of the ovpn to ignore the server’s routes, then what routes should be added manually to the openvpn config?

None, cause then the vpn connection will take precedence over the wan.

but by default, doesn’t everything go through VPN?

Only if the gateway is redirected to VPN.

it turns out that it is redirected when I run on the router openvpn

If you ignore the routes pushed by the server it will not install the default gateway and the traffic will continue to go through your ISP.

so in the end it’s impossible to configure?

Or, like @trendy suggests...turn the route off (IGNORE) and create it manually! :bulb:

no use something else I will not. I asked about routes.besides what routes and where

Please use full sentences. It sounds like you refuse to ignore the route; and you refuse to setup PBR.

If that's the case, please feel free to mark the thread as solved.

1 Like

yes it’s better not to create any sense at all.and without instructions what to do ok

Which procedure do you choose?

We can't guess what instructions you desire - you've been given 2 options.



I answered additional programs I will not use why then "vpn-policy-routing" option with port forwarding does not work!!

Port forwarding doesn't work because your reply traffic is routed thru the VPN. That is what you need to fix. :wink:

:x: In WAN <> OUT VPN

:white_check_mark: Assign IP to PBR, use with Transmission - In WAN <> Out WAN

I already understood this even before creating the topic. we went around!!