Transfer of config

Hello, I configured my Dlink dir-825 ages ago and it recently died. The firmware was openwrt 19 I guess.
Can someone help me to replicate the config from the dir-825 on the CUDY WR2100 on 23.0 firmware? I tried replicating the network and wireless files but it was not successful.
I know the wireless part would depend on the new hardware and that I can try figure it out on a second stage, however I am stuck on configuring the interface.

network:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc5:b419:3c8c::/48'

config device
	option name 'eth1'
	option macaddr '00:18:e7:f0:4a:c8'
	option ipv6 '0'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

config interface 'GuestNet'
	option device 'br-guest'
	option proto 'dhcp'

config interface 'IOTNet'
	option device 'br-iot'
	option proto 'dhcp'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'
	option ipv6 '0'

config device
	option name 'eth0.1'
	option macaddr '00:18:e7:f0:4a:c7'
	option ipv6 '0'

config device
	option name 'br-guest'
	option type 'bridge'
	list ports 'eth0.6'

config device
	option name 'br-iot'
	option type 'bridge'
	list ports 'eth0.7'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.3.51'
	option gateway '192.168.3.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'
	option enable_vlan4k '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '5t 0 1 2 3t'

config switch_vlan
	option device 'switch0'
	option vlan '6'
	option ports '5t 3t'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option ports '5t 3t'


wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:11.0'
	option htmode 'HT40'
	option cell_density '0'
	option country 'MU'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option network 'IOTNet'
	option ssid 'IotWifi'
	option encryption 'psk2'
	option key ###

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:12.0'
	option channel '153'
	option country 'MU'
	option cell_density '0'
	option htmode 'HT40'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'HomeNet'
	option encryption 'psk2'
	option key ###

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option network 'GuestNet'
	option ssid 'GuestWifi'
	option encryption 'psk2'
	option key ###
	option isolate '1'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'ap'
	option network 'lan'
	option ssid 'HomeNet'
	option encryption 'psk2'
	option key ###

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'GuestWifi'
	option encryption 'psk2'
	option key ###
	option network 'GuestNet'


You cannot transfer the vast majority of the settings... the DHCP and firewall file are usually safe to transfer over (depending on the versions of OpenWrt involved, of course). But the network and wireless files are not compatible.

If you need help setting up your new device and you have a backup of your old one, we can look at the default config from the new one and help you craft the new config based on reviewing the old one.

Hello, I see.
The dir-825 was acting as a dumb AP with 3 SSID (Homenet, IOT and Guest).

Current config on the CUDY:

network


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd74:1b2c:d7da::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'


wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2'
	option key ###

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2'
	option key ###