Traffic rules block dns

yes my laptop has manual dns - 8.8.8.8 / 8.8.4.4
and from winscp :thinking:

config rule
option src 'lan'
option name 'dns'
option dest 'wan'
option target 'REJECT'
list dest_ip '8.8.8.8'
list dest_ip '8.8.4.4'

and Ive just read that method, supposed to be good for all router..:

  1. Go to Static Routes under Advanced
  2. Click on Configuration
  3. Click on Advanced​
  4. Click on StaticRoute and add the following:
    Subnet IP: 8.8.8.8
    Subnet Mask: 255.255.255.255
    Gateway IP: Any valid local IP other than the router itself.
    Interface: LAN/br0
  5. Press Add
  6. Repeat for the Subnet IP 8.8.4.4

I've got it working perfectly just as I described.

config rule
	option dest 'wan'
	option src 'lan'
	option target 'REJECT'
	option dest_port '53'
	option name 'Block external DNS'
	list dest_ip '8.8.8.8'

you can omit either the dest port or the IP address (or have multiple IP addresses listed).

I verified it on my computer. At first it was working, but then I realized I had not actually applied the DNS settings on my computer! Once I made sure it was using 8.8.8.8, all DNS was blocked. Also, if you're working with wired + wireless, make sure that one of them is disabled so that you know which one you are using to get DNS.

I wouldn't recommend using the static routes option, but I guess it might work.

we have the same setup, dont know why it does not work

Try restarting the router to make sure all changes are applied.

Post your config files, too (/etc/config/network firewall dhcp)

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option flow_offloading '1'

config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'

config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config include 'miniupnpd'
option type 'script'
option path '/usr/share/miniupnpd/firewall.include'
option family 'any'
option reload '1'

config include 'bcp38'
option type 'script'
option path '/usr/lib/bcp38/run.sh'
option family 'IPv4'
option reload '1'

config zone
option name 'vpn'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'express_vpn'

config forwarding
option src 'lan'
option dest 'vpn'

config forwarding
option dest 'wan'
option src 'lan'

config rule
option src 'lan'
option name 'dns'
option dest 'wan'
option target 'REJECT'
list dest_ip '8.8.8.8'
list dest_ip '8.8.4.4'
option dest_port '53'

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd04:78ec:711e::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth1.1'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.2.1'

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'

config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 0t'

config interface 'express_vpn'
option proto 'none'
option ifname 'tun0'
option metric '10'

config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option localservice '1'
option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'
option ra_management '1'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

Is your vpn active? If so, that is the problem. You’re only filtering dns on the wan. You really want to do it on the vpn zone if the vpn is active.

yes active..
oh.... I did not know, sorry

and , Do I need to do the same on vpn zone? if I want to be sure my smart tv does not use google dns when Im on vpn?

Yes. That should make it work.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.