TPLINK TL-WR941ND delete all packages by mistake

Dear Sir

I have a TPLINK TL-WR941ND router with openwrt 17 works from long time
yesterday I delete all packages by mistake from ssh coneection,
and I lost connection to the router.
now pwr led is on and sys led is flashing and when insert network cabel its
coresponding led is on but no ip
no communication
I try normal reset and hardware reset ( connect power while press reset button )
but no way

Please help

If it has LEDE 17.01.x, does this reset method work for you?

  • Switch on router.
  • Wait a minute or two to power up.
  • Hold RESET button down.
  • After about 10 seconds, the Power LED should change colour. Release button immediately!

See also


I try but no way, My device do not take any ip ( due to packae delete )

I conatct tplink officail support but they told my to buy a new router

Any Help

If Factory Reset doesn't work, you may have to consider connecting a computer to router using a serial-TTL cable to reload LEDE/openwrt using TFTP.

Searching on Google: TL-WR941nd v3 unbrick example video:

Someone else with more knowledge of this router may be able to suggest other ideas.

1 Like

Have you checked the old description for doing a factory reset? It's more detailed.

Also, you don't need to use a serial cable to do a TFTP reinstall. It's described how to do it using ethernet in

1 Like

It really depends on the hardware revision here, v2/ v3 (including the latest OEM bootloaders) don't support push-button tftp recovery, making a serial connection mandatory.

1 Like

Have you tried to enter failsafe mode as suggested by @tmomas?
It cannot be damaged by deleting packages and should still work.


Dear all

Many thanks for your help
after many trials I could enter failsafe mode, as the sys led
Flashing to fast as descriped.
But I still can not ping the router in enter failsafe mode
So how to complete while I can not connect to it.
Should I go on serial connection OR
Any other ideas ??

You may need to give your PC a fixed IP address, something like

There is no DHCP server in failsafe mode., So your PC does not get proper IP.

If you have serial, you can naturally use that.

I already give my PC fixed Ip and connect it to
eth0 ( port 1 on the router )
But no ping from the router
No ssh
No telnet

Please show us your PC's network settings:

  • IP address and subnet mask of the interface connected to the router
  • IP routes

How exactly did you do that?

My pc:-
ip :
subnet :
I do not know * IP routes but I can ping
another pc on same subnet with up

about how do I delete packages :-1
I use somthing like this I do not remmber
opkg remove --autoremove
and it deads After that

Today I try TL-WR941nd v3 unbrick example video
as help from Mr. bill888
And now it works again very good

My question now I need to install zerotier on it which needs 291 kb while
I have only 88kb
So I need to remove unnecessary pkages to install zerotier
Please advive which pkages I should remove savetly ??

If your problem is solved, please consider marking the topic as [Solved] (Click the pencil behind the topic...).

For your new question, please open a new topic.

Thanks to every one helps me

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.