TPLink Archer C7 v4 - OVS and same mac address

Hi,

I tried bringing up TPLink Archer C7 V4 (Australia) and observed all the interfaces are having the same mac address.

output of ifconfig:
eth0      Link encap:Ethernet  HWaddr AB:81:C6:3E:E8:D9  
          inet6 addr: fe80::ae84:c6ff:fe3e:e8d9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:32559 errors:0 dropped:0 overruns:0 frame:0
          TX packets:582 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2689654 (2.5 MiB)  TX bytes:208261 (203.3 KiB)
          Interrupt:4 

eth0.1    Link encap:Ethernet  HWaddr AB:81:C6:3E:E8:D9  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:606 errors:0 dropped:0 overruns:0 frame:0
          TX packets:440 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:80408 (78.5 KiB)  TX bytes:192484 (187.9 KiB)

eth0.2    Link encap:Ethernet  HWaddr AB:81:C6:3E:E8:D9  
          inet addr:x.x.x.x  Bcast:x.x.x.x  Mask:255.255.254.0
          inet6 addr: fe80::ae84:c6ff:fe3e:e8d9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31629 errors:0 dropped:0 overruns:0 frame:0
          TX packets:128 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2002154 (1.9 MiB)  TX bytes:12137 (11.8 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:36 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:5603 (5.4 KiB)  TX bytes:5603 (5.4 KiB)

wlan0     Link encap:Ethernet  HWaddr AB:81:C6:3E:E8:D8  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan1     Link encap:Ethernet  HWaddr AB:81:C6:3E:E8:D9  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Configured OVS and observed after issuing the following configuration I am not  able to communicate via wired lan port but able to communicate via wireless interfaces.

1. Delete existing bridge.
     brctl delif br-lan eth0.1
     ifconfig  br-lan down
     brctl delbr br-lan
2. Create OVS bridge and attach interfaces
    ovs-vsctl add-br ovs-br
    ovs-vsctl add-port ovs-br eth0.1
    ifconfig  wlan0 up
    ifconfig  wlan1 up
    ovs-vsctl add-port ovs-br wlan0
    ovs-vsctl add-port ovs-br wlan1

/etc/config/network/
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdfa:78cc:8d7b::/48'

config interface 'lan'
        option ifname 'ovs-br'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

/etc/config/wireless/

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt4'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca956x_wmac'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt4'
        option encryption 'none'


ifconfig -a 

eth0      Link encap:Ethernet  HWaddr AC:84:C6:3E:E8:D9  
          inet6 addr: fe80::ae84:c6ff:fe3e:e8d9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6667715 errors:0 dropped:0 overruns:0 frame:0
          TX packets:54907 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:593282608 (565.7 MiB)  TX bytes:6154062 (5.8 MiB)
          Interrupt:4 

eth0.2    Link encap:Ethernet  HWaddr AC:84:C6:3E:E8:D9  
          inet addr:x.x.x.x  Bcast:x.x.x.x  Mask:255.255.254.0
          inet6 addr: fe80::ae84:c6ff:fe3e:e8d9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:187654 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44112 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:99769917 (95.1 MiB)  TX bytes:4601293 (4.3 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:259 errors:0 dropped:0 overruns:0 frame:0
          TX packets:259 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:44146 (43.1 KiB)  TX bytes:44146 (43.1 KiB)

ovs-br    Link encap:Ethernet  HWaddr AC:84:C6:3E:E8:D8  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fdfa:78cc:8d7b::1/60 Scope:Global
          inet6 addr: fe80::ae84:c6ff:fe3e:e8d9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:44844 errors:0 dropped:52 overruns:0 frame:0
          TX packets:73130 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4138301 (3.9 MiB)  TX bytes:94186639 (89.8 MiB)

ovs-system Link encap:Ethernet  HWaddr F6:FF:D2:A4:B6:F6  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr AC:84:C6:3E:E8:D8  
          inet6 addr: fe80::ae84:c6ff:fe3e:e8d8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:375 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:100736 (98.3 KiB)

wlan1     Link encap:Ethernet  HWaddr AC:84:C6:3E:E8:D9  
          inet6 addr: fe80::ae84:c6ff:fe3e:e8d9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43533 errors:0 dropped:0 overruns:0 frame:0
          TX packets:73093 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4517462 (4.3 MiB)  TX bytes:95590645 (91.1 MiB)


ovs-vsctl show
    Bridge ovs-br
        Port "eth0.1"
            Interface "eth0.1"
                error: "could not open network device eth0.1 (No such device)"
        Port "wlan1"
            Interface "wlan1"
        Port "wlan0"
            Interface "wlan0"
        Port ovs-br
            Interface ovs-br
                type: internal
    ovs_version: "2.8.2"

I tried attaching eth0 to ovs-br and remove eth0.1 from ovs-br but still problem persists
Any help in resolving this is highly appreciated.

All eth0 interfaces should be tagged since they go through the switch. If you have a VLAN 1 in your switch config, eth0.1 should be automatically created.

Do not reference plain eth0 in any of your config.

Duplicate MAC addresses usually don't cause a problem, but you can use option macaddr in the configuration if needed to have unique ones.

Thanks mk24 for replying.

Is there a way where I can attach eth0.1 to ovs-br interface and run dhcp server on ovs-br instead of eth0.1. How should I change the config files to achieve this.

Thanks
v.d

can you show me the script of ovs ?