TPLink Archer c7 v2 low GigE LAN throughput < 200 Mbit/s on 19.07.1

I just installed 19.07.1 on a TPLink Archer C7 v2. I'm using it as an access point. The wifi throughput seemed low. In testing things, I tried using iperf to verify only the gige LAN connection. I'm only seeing 100-200 mbit/s. Sometimes it seems to drop below 100 mbit/s.

I've swapped things around, tried different switches, cables, etc. The other machines I'm using for testing can saturate a gigE just fine getting around 950 mbit/s.

For reference if I run iperf over localhost on this device I see about 540 mbit/s, so the box seems somewhat limited.

I've never run OpenWRT on this device before. Previously it had the stock firmware.

If I'm only getting 200 mbit/s via the LAN connection, the wifi speeds for this device will be fairly limited.

I'm not seeing any errors counted against eth1. Nothing in dmesg. dmesg says eth1 connection negotiated as 1000 mbits/full duplex.

Thanks for any help/insights

Are you testing through the router, or is the iPerf test running with the router as either the source or termination point of the packets? If the router itself is one of the endpoints of the test, the results are CPU limited (see this post from earlier today).

If you are running throgh the router, are you testing 2 systems connected on the LAN -- and are they both wired (effectively though the built-in switch), wifi to wired, or Wifi-to-wifi? Or are you testing through the routing layer (i.e. a system on the WAN side and a system on the LAN side)?

I was testing with the router as the end point. I see from your explanation in the other thread that it is expected to be CPU limited in this case.

I wound up performing the above test because I was trying to see if I could tell where the bottleneck might be in WIFI-to-LAN throughput.

iperf on laptop -> 5g wifi on the archer 7 -> server on the same lan gives me about 73 mbit/s. I thought I was doing better than that with the OEM firmware.

C7 v2 with openwrt will always be inferior to OEM firmware in performance, but even 73 Mbps does seem low.

Does the laptop have 802.11ac 2x2 or 1x1 wifi card?
Does it report 867 Mbps wireless link speed to the C7 if it has a 2x2 card?

When you use iperf3 to test speed from one PC to another PC via the C7, using multiple streams instead of single stream may yield faster speeds. eg. add -P 10 to iperf3 command on client.

The BT Home Hub 5A modem-router uses same QCA9880-BR4A 5 GHz radio as Archer C7 v2, but has different slower 550MHz SoC (Lantiq). In access point mode, you can see recent iperf3 test results posted here

Single threaded speeds 'upto' 130 Mbps, and multi-thread return 'upto' 167 Mbps for 19.07.0-rc2. These are poor and less than half what OEM firmware could achieve.

Imho, if the C7 will only be used as an access point only, I would suggest using OEM firmware for best speeds and compatibility.

1 Like

@psherman and @bill888 - Thank you both for taking the time to reply. I learned a few things.

I installed OpenWRT on the TPLink C7 because I was looking for some tools to help diagnose why performance seems to have gone down recently.

Good to know it isn't something I'm necessarily doing something wrong.

Thanks for reminding me to check the wifi the laptop I was using for testing. I forgot that the wifi card in it was never upgraded (Thinkpad BIOS issues) so the card is an Intel 6300 N-card. It's supposed to be 3x3 with a theoretical max of 450 mbps.

Out of curiousity is the chipset/chipset manufacturer the main problem with OpenWRT (and presumably other open firmware) having significantly lower performance than OEM?

I understand that OEMs will always be able to spend more time tuning. It's time I looked for some new hardware, hopefully something that will work better with open firmware projects.

Going forward, while OpenWRT is installed, I need to see what I can do to get a better understanding of what clients might be monopolizing the bandwidth as well as the state of the RF environment.

I need to get a handle on what are the best tools to use.

With the little bit of monitoring that I did set up (muninlite), I noticed there was fairly constant traffic received at nearly the same rate on both wlan0 and wlan1 between 1am and 10:30am local time. Curiously it seems the traffic went away when I started looking. It seems like it was internal to my network, I didn't see an uptick in outbound internet bandwidth.


My understanding is lack of hardware acceleration is one of the main reasons for poor performance of open source. OEMs pay license fees to chipset makers to use their source code.

Intel 6300 3x3 wifi card is rated to 450 Mbps, but that is for both up and downstream. Actual maximum throughput is usually half that figure. ie. 225 Mbps in each direction.

I have the same router with the same issues.

When I was on the 15th version of the firmware, I was able to increase the speed (doubled it) by increasing the width of the 2Ghz band from 20 to 40Mhz. But now I've experiencing the same issues with 20Mhz or 40Mhz

With the intel 6300 -> c7, I've never seen a rate higher than 113 mbps using a single iperf. So that seems to be in line for what @bill888 reported above - max of around 130 mbps with OpenWRT on this chip. I haven't tried to do any tuning, that's essentially the out-of-the-box performance after installing 19.07.1

On a related note, now that I had access to some data, I found one of my large problems -- my ThinkPad P51 laptop when asleep and connected to gigE floods the network with ICMP6 Multicast Listener Report Max messages. This seems to be an old problem that was first reported in 2014, but seems like it has reappeared. The P51's gigE chip is an Intel i219-LM.

The clue was that outboard traffic on both wlan0 and wlan1 would go up and stay up all night and then drop off in the morning. There was a constant 3-4 mpbs of outbound traffic on both radios. I used muninlite on OpenWRT to give me some clues over time of what was happening.

Hmm... My observed limits on a C7 v2 or v3, on OpenWrt, have been on the order of 115-120mbit... but over wifi AND with cake SQM. Without SQM, over 5ghz wifi, I had seen up to 280mbit to an old Netgear N6200 USB adapter. Ethernet thru router I'd see up to 350mbit, limit being my "300/30" docsis cable connection being generous. All this just testing on DSLreports.

Doing testing on Windows? Dont have any link handy but somewhere on here someone reported a possible throttling in new Update versions (but not all) to >200mbit, dont know if it was verified.

Of course you could turn on OpenWrt hardware offloading, if SQM isnt a concern...

And, if multicast traffic is going to be prevalent w a wifi link, you probably should disable legacy rates (makes 6mbit instead of 1mbit be the multicast traffic speed) if you dont have any very old things out there. It would free more airtime that would otherwise get used up.