TPLink Archer c7 build issue

I am trying to convert my TPlink Archer c7 v2.0 router to SDN enabled one using OpenWRT+OpenFlow. I am new to this area. I was successful in installing the OpenWRT image in the router. But when I tried to add the OpenFlow feature and build, it is giving me error.

Steps followed:

git clone lede
cd lede
./scripts/feeds update -a
./scripts/feeds install -a
cd ~/lede
git clone
cd ~/lede/package/
ln -s ~/lede/openflow-openwrt/openflow-1.3/
cd ~/lede
ln -s ~/lede/openflow-openwrt/openflow-1.3/files

make menuconfig
Network > openFlow
[*]Network > tc
Kernel Modules > network support > kmod-tun
save and exit
make V=s

I tried it in 2 ways.

  1. By specifically selecting the tag lede v17.01 .
    git tag
    git checkout lede-17.01
  2. Without mentioning the tag so that it will take the latest version.
    [left fig] without mentioning any tags [right fig] with tag lede-17.01


Has anyone encountered a similar issue? Is there a known fix ?


Build instructions aren't the clearest at, are they!

On the left it looks like the build system can't verify the integrity of the package. MD5 or SHA256 in the line there that I spotted. Looks like an outdated Makefile in need of either PKG_MD5SUM or PKG_SHA256SUM

Some good info on a current package's Makefile at and Packaging guidelines

If you can, in the future, paste the error messages into ``` wrappers (code-block Markdown), they'd be a lot easier to read.