TPLink A7v5 WDS Repeater firmware crash

Hello, I finally built a new master/snapshot and I'm happy to say that WDS is working well and I've also enabled the entire gamut of 802.11 services (802.11k/v/r/w).
I am currently testing this on the two TP-Link Archer A7 v5 devices. Throughput is better than I was seeing in Mesh Mode but less than what I was seeing in 19.07 (but 19.07 WDS had a bug and was not working). Current throughput off main AP is around 255mbps up/down and the repeater in WDS mode is providing around 150-180 mbps up/down.
I have successfully tested roaming via the following devices: Iphone SE 2020, Samsung Galaxy S20+5G, OnePlus 8T+5G, Dell Windows 11 laptop running 2x2 Wifi AC card (Qualcomm Atheros). Every device is able to roam to the repeater.
Here is my wifi configs:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option channel '149'
        option band '5g'
        option htmode 'VHT80'
        option country 'US'
        option cell_density '0'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option wds '1'
        option ssid 'xxx'
        option key 'xxx'
        option ieee80211r '1'
        option ft_psk_generate_local '1'
        option dtim_period '3'
        option encryption 'psk2'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211w '1'
        option ft_over_ds '0'
        option ieee80211k '1'
        option ieee80211v '1'
        option wnm_sleep_mode '1'
        option bss_transition '1'
        option time_advertisement '2'
        option time_zone 'EST5EDT,M3.2.0,M11.1.0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT40'
        option country 'US'
        option cell_density '0'
        option noscan '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option wds '1'
        option ssid 'xxx'
        option key 'xxx'
        option ieee80211r '1'
        option ft_psk_generate_local '1'
        option dtim_period '3'
        option encryption 'psk2'
        option ieee80211w '1'
        option wpa_disable_eapol_key_retries '1'
        option ft_over_ds '0'
        option ieee80211k '1'
        option ieee80211v '1'
        option wnm_sleep_mode '1'
        option bss_transition '1'
        option time_advertisement '2'
        option time_zone 'EST5EDT,M3.2.0,M11.1.0'

And for the WDS Repeater

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option channel '149'
        option band '5g'
        option htmode 'VHT80'
        option country 'US'
        option cell_density '0'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'sta'
        option wds '1'
        option ssid 'xxx'
        option key 'xxx'
        option encryption 'psk2'
        option ieee80211w '1'
        option dtim_period '3'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT40'
        option country 'US'
        option cell_density '0'
        option noscan '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'sta'
        option wds '1'
        option ssid 'xxx'
        option key 'xxx'
        option disabled '1'
        option encryption 'psk2'
        option ieee80211w '1'
        option dtim_period '3'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid 'xxx'
        option key 'xxx'
        option ieee80211r '1'
        option ft_psk_generate_local '1'
        option network 'lan'
        option encryption 'psk2'
        option ieee80211w '1'
        option wds '1'
        option ft_over_ds '0'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211k '1'
        option ieee80211v '1'
        option wnm_sleep_mode '1'
        option bss_transition '1'
        option time_advertisement '2'
        option time_zone 'EST5EDT,M3.2.0,M11.1.0'
        option dtim_period '3'

config wifi-iface 'wifinet3'
        option device 'radio0'
        option mode 'ap'
        option ssid 'xxx'
        option key 'xxx'
        option ieee80211r '1'
        option ft_psk_generate_local '1'
        option network 'lan'
        option encryption 'psk2'
        option ieee80211w '1'
        option wds '1'
        option ft_over_ds '0'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211k '1'
        option ieee80211v '1'
        option wnm_sleep_mode '1'
        option bss_transition '1'
        option time_advertisement '2'
        option time_zone 'EST5EDT,M3.2.0,M11.1.0'
        option dtim_period '3'

Problem: However, what I am seeing is that the OnePlus 8T+5G device is getting really crappy speeds after it roams to the other AP (AP1 to AP2, or AP2 to AP1, same behavior). Only way to revive the speeds is to switch the Wi-Fi off on the OnePlus device for a few seconds and turn it back on.

FYI, I am running STP and IGMP snooping on br-lan interfaces on both devices so I can potentially turn on the WDS STA on the 2.4GHz band as well without causing a bridge loop (but keeping it disabled for now). I ran all my tests using only the 5GHz band.

EDIT: I was initially running sae-mixed encryption but iPhone was unable to join at all. All setup uses ath10k (non-ct drivers and firmware). Also, I am running wpad-full (wolfssl based).

EDIT2: Twelve hours into being stable, the repeater showed a stacktrace which I noticed only when I found myself being unable to connect to the WDS Repeater/AP2. Posted crash log below.

kernel log

[   67.068328] br-lan: port 4(wlan0) entered forwarding state
[   67.074042] br-lan: topology change detected, propagating
[   67.708357] br-lan: port 2(wlan0-1) entered forwarding state
[   67.714251] br-lan: topology change detected, propagating
[44247.704523] ath10k_pci 0000:00:00.0: firmware crashed! (guid n/a)
[44247.710844] ath10k_pci 0000:00:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[44247.720519] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[44247.733278] ath10k_pci 0000:00:00.0: firmware ver 10.2.4-1.0-00047 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 35bd9258
[44247.745878] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[44247.753445] ath10k_pci 0000:00:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal file max-sta 128 raw 0 hwcrypto 1
[44247.763352] ath10k_pci 0000:00:00.0: firmware register dump:
[44247.769249] ath10k_pci 0000:00:00.0: [00]: 0x4100016C 0x000015B3 0x0098CD41 0x00955B31
[44247.777511] ath10k_pci 0000:00:00.0: [04]: 0x0098CD41 0x00060530 0x00000020 0x004448AC
[44247.785744] ath10k_pci 0000:00:00.0: [08]: 0x0043F194 0x00000080 0x0043F2B4 0x00000002
[44247.793945] ath10k_pci 0000:00:00.0: [12]: 0x00000009 0x00000000 0x00958360 0x0095836B
[44247.802116] ath10k_pci 0000:00:00.0: [16]: 0x00958080 0x0094085D 0x00000000 0x00000000
[44247.810311] ath10k_pci 0000:00:00.0: [20]: 0x4098CD41 0x0040ACD4 0x00000000 0x00000000
[44247.818508] ath10k_pci 0000:00:00.0: [24]: 0x8099779B 0x0040AD34 0x00000008 0xC098CD41
[44247.826715] ath10k_pci 0000:00:00.0: [28]: 0x8099781C 0x0040AD54 0x004206AC 0x0C030000
[44247.834937] ath10k_pci 0000:00:00.0: [32]: 0x809994ED 0x0040AD74 0x004206AC 0x009C9DE4
[44247.843141] ath10k_pci 0000:00:00.0: [36]: 0x8098F8E2 0x0040ADA4 0x009C9DE4 0x004206AC
[44247.851358] ath10k_pci 0000:00:00.0: [40]: 0x809AB1DE 0x0040ADF4 0x00435F68 0xFFFFFFFF
[44247.859619] ath10k_pci 0000:00:00.0: [44]: 0x809A24C7 0x0040AE54 0x00449FC4 0x00449458
[44247.867825] ath10k_pci 0000:00:00.0: [48]: 0x80944C31 0x0040AE84 0x000000D8 0x00410420
[44247.876097] ath10k_pci 0000:00:00.0: [52]: 0x80942BE7 0x0040AED4 0x00410620 0x00000000
[44247.884378] ath10k_pci 0000:00:00.0: [56]: 0x809BFA3D 0x0040AEF4 0x004090A0 0x00409110
[44247.892568] ath10k_pci 0000:00:00.0: Copy Engine register dump:
[44247.898712] ath10k_pci 0000:00:00.0: [00]: 0x00057400   9   9   3   3
[44247.905384] ath10k_pci 0000:00:00.0: [01]: 0x00057800   7   7 329 330
[44247.912043] ath10k_pci 0000:00:00.0: [02]: 0x00057c00  18  18  81  82
[44247.918718] ath10k_pci 0000:00:00.0: [03]: 0x00058000   4   4   6   4
[44247.925394] ath10k_pci 0000:00:00.0: [04]: 0x00058400 7977 7977  46   6
[44247.932229] ath10k_pci 0000:00:00.0: [05]: 0x00058800   1   1  41  65
[44247.938901] ath10k_pci 0000:00:00.0: [06]: 0x00058c00   4   4   4   4
[44247.945563] ath10k_pci 0000:00:00.0: [07]: 0x00059000   0   0   0   0
[44247.960563] ath10k_pci 0000:00:00.0: failed to delete peer fa:ef:28:d7:cf:b8 for vdev 0: -143
[44247.969455] ath10k_pci 0000:00:00.0: found sta peer fa:ef:28:d7:cf:b8 (ptr 5f8b13e3 id 238) entry on vdev 0 after it was supposedly removed
[44247.982814] ------------[ cut here ]------------
[44247.987814] WARNING: CPU: 0 PID: 1239 at backports-5.15.8-1/net/mac80211/sta_info.c:1091 sta_set_sinfo+0xdb8/0xe04 [mac80211]
[44247.999525] Modules linked in: ath9k ath9k_common pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet ath9k_hw ath10k_pci ath10k_core ath pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mac80211 cfg80211 slhc nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c crc_ccitt compat ledtrig_usbport ledtrig_gpio sha256_generic libsha256 seqiv jitterentropy_rng drbg hmac cmac fsl_mph_dr_of ehci_platform ehci_fsl ehci_hcd gpio_button_hotplug usbcore nls_base usb_common crc32c_generic
[44248.070630] CPU: 0 PID: 1239 Comm: hostapd Not tainted 5.10.103 #0
[44248.077058] Stack : 80760000 80668e74 00000000 00000000 81d8fa7c 808a0000 806e0000 806424b8
[44248.085731]         80d83520 806e7de7 808a32d0 000004d7 8076d7e8 00000001 81d8fa30 20a9b323
[44248.094418]         00000000 00000000 806424b8 81d8f8d0 ffffefff 00000000 00000000 ffffffea
[44248.103075]         00000121 81d8f8dc 00000121 806ed9e8 80000000 00000009 00000000 81b091d0
[44248.111740]         00000009 8076d7e8 806e0000 00000000 00000018 8037cc54 00000000 808a0000
[44248.120400]         ...
[44248.122933] Call Trace:
[44248.125493] [<80066e94>] show_stack+0x30/0x100
[44248.130107] [<80085818>] __warn+0xc0/0x12c
[44248.134357] [<800858e0>] warn_slowpath_fmt+0x5c/0xac
[44248.139642] [<81b091d0>] sta_set_sinfo+0xdb8/0xe04 [mac80211]
[44248.145860] [<81a93acc>] cfg80211_check_station_change+0x1168/0x42e4 [cfg80211]
[44248.153547] 
[44248.155170] ---[ end trace 551eac29fd5f7bb7 ]---
[44248.159972] ath10k_pci 0000:00:00.0: could not request stats (-143)
[44248.299889] ieee80211 phy0: Hardware restart was requested
[44249.505814] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
[44249.536196] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
[44249.543492] ath10k_pci 0000:00:00.0: failed to enable peer stats info: -122
[44250.064809] ath10k_pci 0000:00:00.0: device successfully recovered

Any ideas based on my wireless config ?