Tplink 8980 system halted

Can you try using the following image, rename it to openwrt.bin
Can you also run all the commands from the wiki in the tftp + serial section


// Set temporally the IP address for the router:
setenv ipaddr
// Set IP address where the tftp server is listen:
setenv serverip

setenv bootargs 'board=WD8980'
// Retrieve the OpenWrt image
tftpboot $(loadaddr) openwrt.bin

// Erase old image and write the new one to disk and reboot:
sf erase 0x20000 0x7a0000
sf write $(loadaddr) 0x20000 0x$(filesize)

Adjusting IP addresses where appropriate

Can you describe what cables you have connected to your router and what IP your computer has? Just confirming you have the correct setup.

dude, it's in the screenshots above. When I get tftpboot it outputs: "error ethaddr not set".

yes, I fixed the ethaddr error. I installed u-boot. I flashed openwrt initram firmware again. now i am getting this error.

ethaddrr error: sf erase 0 0x80800000 solved with command.
uncompressing... lzma .... error: sf write 0x80800000 0x00000 0x7c0000 solved with command.
then i loaded the original firmware and it worked.
tftpboot 0x80800000 W9980.bin
sf erase 0x20000 0x7a0000
sf write 0x80800000 0x20000 0x7a0000


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.