TPLink 1043n v5 no connectivity between lan and wifi

Dear all,
i am desperately trying to access a lan pc from wifi. The devices lan and wifi are able to connect to the internet but for some reason it is not possible to ping or access any device, although they are all showing up in the overview page of the router.

I tried the initial config which bridges lan and wifi in the same ip range - which didnt work. And second i tried the setup from the routed-ap homepage at https://openwrt.org/docs/guide-user/network/wifi/routedap

I have no idea what the reason for this behavior might be - i hope you can help me out.
The configs are set up as described on the metnioned webpage, including the forwarding part - which i thought should adress the issue. The other thing is, that i am not able to ping any of my devices when accessing the router via ssh and run ping from there.

Thank you in advance!

network config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdcb:b0d1:ce50::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '70:4f:57:af:1b:e6'

config interface 'wan'
        option ifname 'eth0.2'
		option proto 'dhcp'
		
config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '70:4f:57:af:1b:e7'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config 'interface' 'wifi'
        option 'proto'      'static'
        option 'ipaddr'     '192.168.2.1'
        option 'netmask'    '255.255.255.0'
  • Create second WiFi identical to the one on LAN (i.e. make it a bridge).
  • You never specified a physical interface on your 'wifi' interface anyways, the config was incomplete

Well i thought it was complete - as i followed the instructions on the linked web page.
Anyways i reverted to defaults - which leads to lan access only.
I enabled wifi and added the lan network, which leads to the br(lan,wifi) bridge as you suggested?

Both have access to the internet and share the same adress range but still no connectivity between lan and wifi can be achieved.

I have the interface eth0.1 (lan), eth0.2 (wan) and a brlan (bridge) that consists of (eth0.1, wlan0)

Do i have to make additional adjustements to enable ping / connectivity between wlan0 and eth0.1 ?

To be clear, this seems different from Post No. 1. I [thought I] understood you wanted a second network or something...now is seems you just want the default config to work properly. I apologize for any confusion on my part.

  • A working WiFi bridged to LAN is the setup by default in OpenWrt - you don't need to follow any Wiki. All you should have to do is enable the AP. Perhaps you should make a bug report if this doesn't work for you.
  • The Isolate Clients setting is off, correct?
  • Perhaps it's a firewall setting on your client, instead of the OpenWrt.

Thank you very much for your quick answer.
Well yes i thought that the default configuration should work - but since it didnt i was going for two seperate networks with a route in between, thats what i tried to express in my first post - to be honest i just want to reach lan from wifi - it is not import how this is achieved :slight_smile:

Anyways i think i can exclude that it is a misconfiguration of the clients, since the router just replaced an old one, where connectivity was working.

I am right now running the default configuration with only bridged lan/wlan.

The situation is that even if only considering lan it is not possible to ping the other clients connected on the other ports. Although it is possible to ping the standardgateway from each individual client.

The isolate clients options of wlan is unchecked - didnt find any comparable checkbox for lan.

Very odd. Yea that's Layer 2. If your devices are getting IPs in the same subnet, from the OpenWrt device, then I'm out of ideas...

The firewall isn't preventing the devices on the switch from talking to each other - as nothing crosses the CPU.