TP-Link WR940N v6 EU Installation problems

Hi all,

I have bought several WR940N v6 routers and installed OpenWRT v18.06.8 successfully on 2 of them. But with the third router the installation doesn't work: I use TFTP, transferring the image is done, but after restarting the router the LED blinks blue and red ... pause ... blue and red ... pause ... and so on. Nothing happens.

Reflashing the original TP-Link firmware works.

Then I flashed the new OpenWRT v18.06.9 firmware -> same problem.
It seems like the router isn't starting up.

I tried several times with the same result: LED blinks blue and red...
Has anyone the same problem?

This device is NOT RECOMMENDED for future use with OpenWrt due to low flash/ram.
DO NOT BUY DEVICES WITH 4MB FLASH / 32MB RAM if you intend to flash an up-to-date and secure OpenWrt version (18.06 or later) onto it! See 4/32 warning for details.

Old version is enough for me.
Doesn't answer my question.

Sorry, I do not have time nor desire to investigate cheapest not recommended models.

Okay, nobody said you have to support me :wink:

No, I am ready to support, if I treat it reasonable. But in this case I can not do anything, because I do not have such router.

Okay, thank you. This sounds better.
As I said: I have successfully installed two routers - only the third one doesn't work.

Are you saying that you wish to close the thread, then (I usually mark "Solved" on such a comment; but I gleaned your true frustration and perhaps misunderstanding)?

You are aware that "support" for all intents and purposes in the community basically means...."getting help here in the forum, from developers, etc.". Your device has such a warning (in big red lettering) on its hardware and data pages.

I hope the best for your subsequent installing.

In all seriousness, though - maybe someone has the device and can offer a little assistance.

I've experienced this problem, not on this hardware (I'm in a group of first users that ran into 4/32 issues on devices with version 17)...since you seem reluctant to accept the issue...let's try to troubleshoot it and get to the situation...

  • Can you show us the free space on the 2 working devices plese? :slightly_smiling_face:
  • Is there a method on your device to TFTP into memory and boot from there (to make sure there's just nothing odd with flash blocks or something)?

(some models/devices react differently to an over-bounds flashing; further flash chips are not necessarily "identical" - not even between identical machines)

Can you use search in the forum?
If not then see this topic


Perfect, your patch works perfect.
But I'm a little bit afraid ... I downloaded the official release for this device in version 18.06.8 (same version) and this one is installed on 2 of 3 routers. And on the 3 router, i had to install your version.

But it works, so fine for me!
Thank you very much!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.