TP-Link WR841N cannot change ip address

Hi there, I've got a problem changing my openWRT-router's ip address from 192.168.1.1 to e.g. 192.168.160.200....

it always says some "revert message" how to change it anyway..... the routers' ip should be in the same subnet as the rest of my network so how just change the ip?
see my setup below:

System

Hostname

OpenWrt

Model

TP-Link TL-WR841N/ND v10

Architecture

Qualcomm Atheros QCA9533 ver 2 rev 0

Firmware Version

OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d)

Kernel Version

4.9.152

Local Time

Wed Jan 30 12:48:40 2019

Uptime

0h 27m 48s

Load Average

0.01, 0.19, 0.22

You have to quickly change page to new address

…or confirm that you want to apply the new settings nevertheless (unchecked).

3 Likes

And what happens when you hit "Apply Unchecked" on that "revert message" box???

Screenshot_2018-10-01_21-50-38

and...

  • You immediately get a new IP via DHCP; and
  • browse to new page?
1 Like

You could try this apply unchecked option.

If it doesn't work you could alternatively have the PC connected to the router via two adapters (e.g. wifi and cable) with one's IP set to the range of the new IP (e.g. 192.168.160.201), so if the first adapter doesn't get new IP, the router can still find the PC through the other one with static IP.

Another way would be to put primary and secondary static IPs.

Skjermbilde_2019-02-05_23-14-48

no after having tried to change ip the router becomes unreachable and can only be brought into line of reach by a reset..... than the router is back having ip 192.168.1.1.......:frowning:

That seems as if you let the 30 seconds expire...or didn't try to get a new IP via DHCP.

If you are unable (or scared) to do so within 30 seconds:

  • just edit the following line in /etc/config/network file: option ipaddr '192.168.1.1'
  • then run /etc/init.d/network reload

After changing you have to disconnect and reconnect your PC so it gets a new address in the proper range. Then type the new router address in the address bar.

You have to do this quickly. Or you can keep the PC pointed at 192.168.1.1, wait for it to time out, then click the red apply anyway button. Then you have unlimited time to change your PC.

1 Like

Hi, I already tried that.... Directly editing the /etc/config/network....... But in the consequence I could access the router any more..... Only way to go back is a hard reset and starting all over again..... Any further suggestions..... Network settings? Disabling or enabling DHCP?

That is the network setting. You must be doing something wrong.

https://openwrt.org/docs/guide-user/network/start

https://forum.openwrt.org/search?q=apply%20unchecked%20order%3Alatest_topic

I read somewhere on the forum that if you have the router in wireless bridge mode (or something like that, I don't recall), then you cannot change the LAN IP. Is that your case?

If the router goes unreachable on 192,168,1,1 then this suggests that the router changes it's IP but the DHCP server doesn't give the computer a new IP in the same range, and therefore they can't communicate.

when you get thus unreachable message, set a static IP for your computer in the same range, along with the proper subnet mask and see if you an reach or ping the router.

https://openwrt.org/supported_devices/432_warning
You may not have enough free space to save any settings.

1 Like
uci set network.lan.ipaddr="192.168.5.1"
uci commit network
/etc/init.d/network restart
2 Likes

Hi yeap not having enough free space is the most likely cause for the issue.... arrrgh