Tp-Link WR840 - Bricked


I bricked my router today, after a wrong flash (don´t know what happened).
Does anyone have the serial scheme and instructions for this router?


Try TFTP recovery:

I also have same router TL-WR840N V4 and it got bricked and I followed instructions to recover and did the following,

  1. downloaded the dd application and "firmware upgrade" (for TL-WR840N V4 from TP-Link website)
  2. used command to skip header from firmware upgrade { dd if=original.bin of=tp_recovery.bin bs=512 skip=1}
  3. downloaded tftp64 and uploaded tp_recovery.bin to my router and it worked.
    Now WLAN MAC address has become FF:FF:FF:FF:FF:FF which is causing trouble as I try to connect my phone to this router.
    my question is can I just change my WLAN MAC Address of my router to the original as printed on the ticket.

You want to set the Mac address on the router having the stock firmware ? Try this:

I want to change the WiFi MAC Address of my router and there is no option in the configuration page to change the WLAN MAC Address

check the uboot-envtools package


any simple solution? like writing MAC address in firmware bin file (editing via hex editor etc) then uploading to router via tftp

that is the simple solution, assuming it's actually set wrong (or unset) in the uboot environment.

Unfortunately, I am not that much familiar with the commands used in u-boot environment that's why asking for a simpler solution like editing bin file before uploading to router

trust me, editing a bin sure ain't easier than using a couple of commands on the cli prompt.

OK, I am going to try, by the way, thank you so much for your precious time. I hope I will always get help from experts like you.

Can you please guide me step by step (like downloading relevant tools/utilities, accessing u-boot and also download link as I am unable to find, by the way I am using Windows 10)

that's what's in

after spending hours and trying to understand what the article says, I uploaded latest tftp recovery.bin (openWrt of course) to my router, searched for updates ( and finally installed uboot-envtools and fwtool.
accesed router's root in putty and tried to run commands as article suggests, but unfortunately no "/etc/fw_env.config" found
error: can not parse config file /etc/fw_env.config
when I try to run
"opkg install uboot-envtools" command, it says its installed and up to date
when try to run
"vi /etc/fw_env.config" command, putty gets stuck on
root@OpenWrt:~# vi /etc/fw_env.config


  • /etc/fw_env.config 1/1 100%
    and I have to close putty after a long wait

it's an editor, you can wait forever for it to terminate :slight_smile:

next time, press < esc > : q Enter(key)

you need to populate the fw_env.config with the configuration matching your device.




That's everything you need to know about vi or vim.

:rofl: :joy: :rofl:

You made my day

root@OpenWrt:~# opkg install uboot-envtools
Package uboot-envtools (2018.03-3.1) installed in root is up to date.

root@OpenWrt:~# opkg install fwtool
Package fwtool (2) installed in root is up to date.

root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00020000 00010000 "boot"
mtd1: 007a0000 00010000 "firmware"
mtd2: 0017f777 00010000 "kernel"
mtd3: 00620888 00010000 "rootfs"
mtd4: 003d0000 00010000 "rootfs_data"
mtd5: 00010000 00010000 "config"
mtd6: 00030000 00010000 "factory"

**No "uboot"**
**No "uboot_env"**
**what should I do?**