Tp link wr1043nd V4: use wan port as lan port

Hi,
I want to setup a tp link wr1043nd v4 as an access point and I wish to use wan port as an aditional lan port. Accordingly to the guide about it in
https://wiki.openwrt.org/toh/tp-link/tl-wr1043nd

remove to following lines, to remove the wan specific configuration (vlan and interface)

V2.x /etc/config/network

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

and

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6'

and add the port 5 to the existing Vlan

config switch_vlan
        option device 'switch0'
        option vlan '1'
#add port 5 to the line below
        option ports '0 1 2 3 4'

The problem is that my network file looks slightly different, the mine is:

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

So I guess the way is to edit it like this

#config interface 'wan'
#option ifname 'eth0.2'
#option proto 'dhcp'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr '84:16:f9:e8:99:4f'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5 0t'

#config switch_vlan
#option device 'switch0'
#option vlan '2'
#option ports '5 0t'

But before editing the network file I ask you to confirm that it is right
Thanks in avance

Actually it should be possible to use network bridging to eliminate any risk of breaking switch configuration:

uci -q delete firewall.@zone[0].network
uci add_list firewall.@zone[0].network="lan"
uci add_list firewall.@zone[0].network="lan6"
uci commit firewall
service firewall restart

uci -q delete network.wan.ifname
uci -q delete network.wan6.ifname
uci -q delete network.lan
uci set network.lan="interface"
uci set network.lan.type="bridge"
uci set network.lan.ifname="eth0.1 eth0.2"
uci set network.lan.proto="dhcp"
uci -q delete network.lan6
uci set network.lan6="interface"
uci set network.lan6.ifname="@lan"
uci set network.lan6.proto="dhcpv6"
uci commit network
service network restart

uci set wireless.default_radio0.network="lan"
uci commit wireless
wifi reload

If you put all your ports on VLAN1:

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 5 0t'

then your interfaces must connect to "eth0.1". Or you could get rid of tagging:

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 5 0'

and use "eth0" directly.

However, I think you should not disable the WAN interface:

config device 'wan_dev'
    option name 'eth0'
    option macaddr '84:16:f9:e8:99:4f'

config interface 'wan'
    option ifname 'eth0'
    option proto 'dhcp'

config interface 'wan6'
    option ifname 'eth0'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 5 0'