TP-Link WR1043ND v4 Issue

As some of you might know, recently buildsfor this new device started being made, so I decided to test them out. But there's a little issue that I can't seem to diagnose whatsoever, either with logging or anything else.

On the stock firmware, even with hardware NAT disabled (as it's buggy), I get full speed on my line:

However, with LEDE, stock settings (both my custom build and the snapshot builds), my speeds are dropped to this:

This is a consistent result, and it doesn't change, almost feels like there is a hard cap somewhere in the 30 Mbps field with LEDE. As soon as I revert back to stock, I'm back at 90+ Mbps. I very much doubt this is a hardware NAT issue, as even my old 841ND held 80 Mbps both on stock firmware and on LEDE/OpenWRT/DD-WRT, and I have the HW NAT disabled on the stock firmware as it has a bug where the speed spikes to max then starts dropping suddenly, works fine with it off.

This is the most recent snapshot btw, as of this post. My custom build is also synced with all the changes up until now.

I know this is a very recent device, but if there's any suggestions... Thanks!

Edit: After some troubleshooting via WiFi, it seems WiFi devices get a slightly higher speed than my LAN device, but after testing a few more times, it's around the same. Supporting devices also don't sync to 144/300/400 Mbps as they did before on 802.11n/40Mhz and the 841ND but that's something to resolve later.

Edit 2: So, breakthrough. Connected my laptop to LAN, which synced at 1 Gbps (unlike my desktop because it uses a long cable to the router, but still regardless got 95 Mbps, whilst synced at 100 Mbps) and that worked just fine. I wonder if it's a Ethernet speed negotiation issue. Edit 3, which it isn't, as LEDE says it's synced at 100 Mbps Full-Duplex. The stock firmware, despite syncing at 100 Mbps, also attains full speed, so I don't know what could be happening for it to cut the speed so much. I suspected it was syncing at Half Duplex.

Edit 4: Confirmed that it is an issue relating to LAN devices synced at 100 Mbps. Now... I don't know of any solutions. The stock firmware and previous routers handle this just fine, with or without NAT acceleration. WiFi devices reach 60+ Mbps.

Edit 5: Seems to be WAN > LAN only. LAN > LAN (via USB/Samba) does not present this behavior.

1 Like

Flow control?

Tried a combination of settings in the NIC, nothing seemed to work. Tried a different NIC as well and a different OS. No dice, this also doesn't happen on the stock firmware and it only happens in clients synced at 100 Mbps.

Unless you mean flow control on the router NIC, in which case I don't know how to change.

Checking and adjusting flow control is done with ethtool

Can't seem to be able to do that:

root@lede:~# ethtool -A eth0 rx off
Cannot get device pause settings: Not supported

Definitely seems to be some kind of "control" but not sure why it only behaves this way WAN > LAN and not LAN > LAN. A lot of the ethtool settings just throw a not supported.

Edit, driver info:
root@lede:~# ethtool -i eth0
driver: ag71xx
version: 0.5.35
bus-info: ag71xx.0
supports-statistics: no
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no

Can no one with this router (if there's any people) reproduce this issue? Maybe it's happening on other routers? Would like to help resolve it if needed but I don't know what to log or what to do. It's frustrating because the TP-Link stock firmware wifi is complete crap (pardon my French) and I'd love to use a custom distro like LEDE. The cable that goes to my desktop is Cat5 100 Mbps only, and only this kind of cable seems to limit the WAN > Desktop connection to 20-30 Mbps, where as a 1 Gbps cable gives me full speed (100 Mbps). Definitely a sync issue but I don't see where.

Also reminding that stock firmware handles this fine, I get 95 Mbps WAN with my 100 Mbps cable. Also not NAT because I have HW NAT disabled on stock, and as I said, makes no sense cause the gigabit cable works fine on LEDE.

Is there any other way of diagnosing whether this is a flow control issue or not? It's not even a hard cap. I really wanted to use LEDE because the WiFi on the stock firmware is atrocious.

I consistently, at all times of day, get 95 Mbps on that server on the stock firmware. Also affects normal downloads.

Refer to post above for more info - only happens WAN > LAN@100Mbps, does not happen WAN > LAN@1000Mbps.

Facing similiar issue after flashing th 17.01.

But my setup is a little bit differet, I use router just as wireless bridge, so I have wifi bridged to the WAN port.
Ports are 1000baseT-FD.
Speed is about 12Mbit/s download and upto 10Mbit/s uploadon local network testing with iperf.

I'm also having similar issue on my WR1043NDv4. I usually get 50Mb on 100Mb/s ethernet connection, though sometimes I am able to get like 80Mb/s or 90Mb/s. On WiFi (transfers from WiFi client to 100Mb/s ethernet connection) I never got more then 50Mb/s, while my old v1 could reach full speeds with ease.

Facing similar wireless bad performance on my TL-WR1043ND v2 running 17.01. I recently moved to LEDE 17.01 from OpenWRT CC 15.0.1 and I haven't that kind of bad wireless performance.

v2 and v4 don't have the same wireless hardware but I suppose they are using same ath9k driver. Could be ath9k driver issues?

I don't think there is a problem with wireless performance. I did two basic tests.

  1. I copied big file from WiFi to LAN@100Mb/s connected laptop. I couldn't get more then 5Mb/s with 4Mb/s-something on average.
  2. I copied big files from WiFi to LAN@1000Mb/s connected computer and I got the same speeds as on v1.

This would validate the original report about problems with 100Mb/s connected ethernet devices.

v4 doesn't have support in Chaos Calmer so I can't test that. Sorry.

For me wireless is okay because the router is connected to the modem via gigabit. And I have options like 'noscan' activated so I can get the best speed possible. Only LAN clients synced to Fast Ethernet are buggy for me.

Exactly, same here.

You should probably open a new thread for your problem since it doesn't seem to be relevant to the issue discussed here.

I've got 1000baseT full-duplex uplink and the wirless is about 8-10Mbit/s on WIFI->WAN /bridged network/
If I connect to LAN port 100baseT FD laptop, I'm wire speed in LAN->WAN

Anyone actually found any solution or workaround to this problem?
@SpiderVice are you still affected by this bug?

I also have this problem
I consider that this might be related somehow.

Sorry to bring up post so old but it seems like the issue i'm having.
I just recently bought TL-1043ND v4 and the outcome is pure garbage.
My subscription is 1Gbps.

Here are my speeds - Ethernet straight to my Y700:

And here is what i get when plugged via router:

All configs are default except my Static IP Configuration...

I am a super noob in this area but have common understanding on how to do things, so please assist me ;///

Apart from the problem you are having, this router is not even near capable of doing 1 Gb/s without Fast Path implemented. It is not available by default.

Should I just return it and buy a new one ? I can double the price. Any recommendations ?

You should do whatever works best for you.
For Hardware recommendations you should look here: