TP-Link WR1043ND v2 and v3 unstable wifi - LOTS of testing within


I have two TP-Link devices, WR1043NDs (a V2 and a V3). I recently upgrade my Internet connection and got a Roku device.

After watching a movie on either the Roku or my laptop, within a few hours, the wireless connection will become extremely slow and ping times with shoot up into hundreds of ms with little data being sent. Devices further away will tend to drop and not reconnect. LAN speeds are unaffected. WAN speeds are unaffected. Sometimes this happens on its own without watching anything on the Roku or my laptop, but watching a Netflix movie is a good way to trigger the issue.

I have 6-8 wireless devices at any one time, ranging from modern laptops with AC cards, older laptops with N cards, an Android 8 device (Nexus), and IoT devices that include an ancient weather station that only support G speeds.

Running "wifi" in the ssh console from a wired machine will fix the issue temporarily, or rebooting the router.

Things I have tried in various combinations:
Disabling legacy rates
Disabling low ack dissociation
Playing with distance value (50 meters, 500 meters, 0 default)
Disabling ANI
Adjusting power levels (downward)
Changing channels
Moving router
Unplugging the weather station.
Propping up router to ensure airflow (it's on a desk)
Swapping hardware from V2 to V3 and restoring config
Tried latest snapshot as of a week ago

Other thoughts:
An older Android 6 device will also cause the issue just by being on the network, and will tend to kick off my laptop.

Nothing seems to help, so I've begrudgingly ordered a Ubiquiti AP and will disable wireless on this device. But I'd really like to know what is going on and help debug it if possible.

My wireless config:
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/qca955x_wmac'
option htmode 'HT40'
option country 'US'
option legacy_rates '0'

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'ssid'
option network 'lan'
option key 'my key'
option encryption 'psk2+ccmp'

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'iot'
option network 'guest'
option key 'service (iot device) key'
option encryption 'psk2+ccmp'

EDIT: I'd also like to point out that there is very little 2.4GHz interference in my area, and changing the channel did not help.

EDIT2: regression? (Workaround found) TL-WR1043nd v2 wireless range / stability

I've been running this device for years (since I got it in 2015 roughly) and I do seem to recall wireless performance was never an issue in the past.

Try 100 meters. I've learned that any value < 100 doesn't work.

Adjust upward.


By any chance, is this Bluetooth or WiFi-based?

Adjusting upward didn't help.

Weather station has 2.4GHz wifi and 900Mhz communication with the wireless stations.

I think it may be related to multi-SSID, problem is it's a pain in the butt to get all the other devices to change SSID (to test the same # of clients but on one SSID) so I haven't done it yet. But in the past I tried 3 (guest, iot, private wifi) and it was unstable.