TP-Link WR1043ND v.2.1, tftp

Hello !
I have a TP-Link WR1043ND v.2.1 with custom firmware of OpenWRT installed. It was set up by a wifi provider with their own firmware and leased out to us. I cancelled the contract with them, and they agreed that I keep the leased WR1043. Now, I would like to install a normal OpenWRT. The leased device was remote-controlled by the provider and I didn't have a login ID and password. But now, I haven't done anything yet, but it seems that DHCP server isn't working: my computer doesn't get IP address. I suppose it's bricked but I don't know why...
I tried to flash it using tftp, but I looked at

I am not sure if I am doing it right. I have an Macbook pro 2012,

did this:
$ sudo launchctl load -w /System/Library/LaunchDaemons/tftp.plist

Put the file (factory.bin) in /private/tftpboot
and renamed it to wr1043ndv2_tp_recovery.bin. Set the static IP and subnet mask in Then pushed and held the button while I turn the router on. But the router booted just normally, nothing changed.

I was wondering, when I flashed Unifi AP using tftp, I had to put IP address of the device somewhere, and the file name. But with WR1043ND, it doesn't say anything about it. Shouldn't I also type an IP address somewhere in this procedure, too ?

I would appreciate if someone could help me !

Assuming they haven't charged the uboot, the most common reason for tftp not getting the file, is a firewall blocking the TFTP requests.

The device will typically only look for a file to download via FTP from a specific, pre-configured IP address. So rather than specifying anything at the device end you have to make sure that your MacBook has that address, which it looks like you tried to do.

If you simply unplug and restore power the lights will run in a particular way. If you then try holding down the reset button while cycling power do you see some different behaviour to suggest the TFTP is trying to work?

This is an important hint from the device link you provided - can you see what is happening?

if you use Tftpd check log viewer for read request from your router, to make sure your rename is correct

That looks like it might need this sort of incantation:

You could also install Wireshark so you can see what is happening on the network device:

Thank you all for your replies and infos !
OK, I understand, the n IP address is preconfigured, so it was OK that I didn't type any address, then. The device should know how to connect with my PC, and get the file with a specific name at a specific location, without me doing anything. And yes, I did turn off the firewall.

No, the lights turn on/off/blinks just like you turn the device on without pressing the reset button. No difference. I also tried to press the reset button fast and many time, but it didn't make any difference either.
Now I tried
log stream --predicate '(process == "bootpd") || (process == "tftp")' -info
Nothing came up, so tftp is probably not working. I have wireshark but have never used, now I tried to see if I can use it, didn't figure out what to do;;

I just looked how much it costs on used market, it's not that cheap, that I would like to be able to bring it to life...

The TFTP logging on MacOS looks a bit hit and miss. If you can set up a client on some other device to show the file transfer in the logs you know you can see what is happening (eg a Windows PC: If you can get the file but see nothing in the logs then the logs aren't helping you figure out what's happening with the router.

But Wireshark will probably be an equally quick way to confirm what is happening if you can understand how to use it - it's not that difficult really as long as you only have Mac and router on the network port - if other stuff is there as well you'll be swamped with data.

Getting a serial port running so you can see what the device is trying to do can save hours of phaffing around in this sort of scenario. Do you feel able to get that working?

I hacked a very useful cable together by splitting out the wires from one of these old Nokia phone comms cables: (the blue ones work well - not black). I soldered the three needed wires to pin-connectors scavenged from an old PC CD-ROM cable.

You can buy other devices claiming to be what you'd need as well, but frankly I find it hard to understand what you're really getting due to the cut / paste / mangle approach of many listings.

Thank you for your hints ! Yeah, you are guessing right, I'm a bit intimidated by this serial port procedure, though I might have to get into it at some point because I have a few EOL Unifi APs. I don't have these cables...

I just need a device that can take SMA antennas that can be made into repeater mode, then I get a high-gain antenna/antennas (like +13--+20dbi), connect to it to catch a signal from a bit far a way (in the area, where RSSI is about -85 in 2.4G), and attach another access point to it to use wifi there, in another word, a very strong wifi repeater which can repeat in a longer distance.
But I have this WR1043ND for free, and it seems to be a good device, so I thought it would be nice if I can just use this one. But I think this device isn't trying to do tftp for some reason.... tftp logging on my Mac was doing it's job, I think, but I suppose nothing was happening, I got no output.
Perhaps I should give it up and buy something else.... do you have any recommendation for an alternative ? I just need to repeat one SSID.