TP-Link WR1043N v5 reboot loop at 18.06.2

Have a nice day everyone.
short: My WR1043N v5 is trapped in a reboot loop after messing around with 18.06.2's Interfaces section. Separation from electricity has no effect. The hardware reset button does not help (not pressing, not holding, neither in the moment of startup nor of turning it off). What can I do?


history: Long time ago, I think still in 2017, I bought two TP-Link TL-WR1043N v5 exclusively for (my first!) use with Open-Source firmware. I am no network expert. Then I waited for the adaptation of LEDE, OpenWrt et al. to it.
When the first LEDE snapshots supported the v5, I picked the latest one and made some progress. I learnt how to install LuCI and was able to configure it correctly for service behind an old AiO router in modem-only mode (full bridge mode, I suppose). Everything seemed to lead to a happy ending. There was just one problem: I could not get the old-style analog telephone working – which was a hard requirement.

I put the v5 on the shelf. Soon after the LEDE-OpenWrt remerger, the official 18.06.1 release supported my v5. Therefore I tried

openwrt-18.06.1-ar71xx-generic-tl-wr1043n-v5-squashfs-sysupgrade.bin
without the Keep settings option

but I was not able to set it up right for connecting to the WWW behind the AiO in pure modem mode again. (As a simple passthrough device to the AiOs full routing, it did its nonsensical job.) In the meanwhile, I bought a new (VoIP/SIP) telephone I can handle to a large extent.
Since, every effort in the Interfaces section of OpenWrt failed. I deeply wonder why I managed it with the LEDE snapshot, but not with official OpenWrt.

After reading about the 18.06.2 release, I flashed

openwrt-18.06.2-ar71xx-generic-tl-wr1043n-v5-squashfs-sysupgrade.bin
of course sans Keep settings option

and tried my best again. While I could not configure it in a correct manner, I mucked it up several times in a way that prevented LuCI access via web browser. Thus I had to fall back to v5's hardware reset button. It worked until last time: Now v5's LEDs indicate it boots and shuts down untiringly.

Putting it off the power cable is no solution. The reset button has not cured it in numerous attempts. Naturally, I read some pages of OpenWrt documentation (Failsafe Mode, Factory Reset, Recovery Mode, debricking guide), a bit of Wiki lecture and some forum thread titles. Nothing seemed serviceable in my situation.


Please help me with the foremost problem: v5's rescue.

Kind regards
HelplessTelephonyGuy

Did you try TFTP recovery as per
https://openwrt.org/toh/tp-link/tl-wr1043nd

You don't need to sign your messages by the way

After setting the static IP 192.168.0.66, how does the v5 get the IP address 192.168.0.86 like stated in that page?
In which folder path should I place the WR1043v5_tp_recovery.bin and how could the v5 find the file?
I suppose it has to be done per PuTTY or similar? But how?

In TFTP recovery mode, the router will use 192.168.0.86, and look for a TFTP server on 192.168.0.66.

So, yes, you will need to use TFTPD32 or similar, and specify the folder where the recovery file is.

The document for TP-Link Archer C7 probably gives a little more details (except that the file name should be different of course.
https://openwrt.org/toh/tp-link/archer-c5-c7-wdr7500

You’ll need a TFTP server on your “desktop”. Its configuration will say which folder on you desktop files are served from.

My bad, yes, TFTPD32 (or TFTPD64) is a popular TFTP server for Windows.
http://tftpd32.jounin.net/

In the meantime, I even figured out myself (hurray!) how a TFTP server would be established in theory. But I do not get how to use TFTPD64's JSON files (I thought starting one with Java RE would be enough) and Core FTP LE has not connected successfully yet. I am afraid I have no clue about TFTP at the moment.

Try https://openwrt.org/docs/guide-user/troubleshooting/tftpserver#tftp_server_on_windows

The Tftp Server tap is what you shroud use.

In the top box you browse for the folder where the image resides (with the name specified in the wiki)
In the second box you choose the Ethernet adapter that's connected to your router.

image

When you boot in recovery mode, you should see the file transfer in the lower box

tftpd64 ships as an .exe file that you would install like any other Windows application. No Java should be needed.

The Windows Firewall and most third-party firewalls you might have on a desktop will prevent a TFTP server from working. Turn them off. This is safe to do since the desktop should not be connected to the Internet (or anything other than the router being worked on) at the same time you're TFTP flashing.

When you put a DSL modem into "pure modem" or "bridge" mode you generally need to run pppoe from your router. And the internal ATAs that are used to use the ISP's phone service will generally not work. For that to work you need to have the modem act as a router, this is called double-NAT.

1 Like

It was not easy in my network, but I have succeeded in reviving the v5. Its LuCI can now be connected to. Thank all of you very much!

@mk24
I downloaded some ~ 30 MB ZIP with JSON files and source code only. Maybe that is a Linux release.

The next goal is setting v5@18.06.2 up right. That is something for another day. I will be back.

1 Like