TP LINK WR-902AC v3 config router

Hello, I have installed the latest 23.0.5.4 on my TP Link WR902ACv3 and want to get a similar config with OpenWrt as I had with the TP Link software on it.
Basically:

  • eth0 is dhcp client (WAN)
  • phy0-ap0 (2.4 Ghz) and phy0-ap1 (5 Ghz) (LAN)
    The idea is that all requests for clients on LAN are done via the wifi/wlan devices using WPA3 and the phy0-ap* devices have their own DHCP and DNS like 192.168.1.0/24 and eth0 is WLAN and dhcp client and NAT masqued.

Currently the default config is that eth0 is static or dhcp client and and has br0 as bridge and the 2 phy0 devices are directly linked to the eth0/br0 bridge.
Which means if I put the lan on dhcp client the wifi devices on LAN get the dhcp leases from the eth0 dhcp client network.
But I rather have the phy0 devices have their own DHCP and DNS config and are the LAN zone and eth0 is the WAN zone.

My current config:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd34:8236:9703::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '4 6t'
root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/10300000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT40'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'AP'
	option encryption 'sae-mixed'
	option key '****'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '40'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'AP-5'
	option encryption 'sae-mixed'
	option key '****

Does anyone how I can recreate the default TP link config of eth0/UTP as WAN and the wlan devices use their own DHCP/DNS (can be a bridge of the phy0 devices?) and nat the phy0 bridge/devices to the eth0/WAN?

Thanks for any help :slight_smile:

assuming the wifi works, move the ethernet port to the wan firewall zone.

make sure the WAN and LAN subnets aren't the same.

1 Like

Thanks! I think I got it now :slight_smile:
I did:

  • new device: create an empty new bridge with no ports and force link
  • new interface: for that bridge with DHCP server enabled and static ip
  • assigned that bridge to the 2 phy0 devices
  • new WAN interface using eth0.1 switch
  • remove br-0
  • checked firewall rules via LUCI to see if the new bridge for wifi is also allowed for NAT
  • tested it and works!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.