TP-Link WPA8630P powerline keeps rebooting

Hi short story i had it successfully installed openwrt working maybe more then a year until i decided to revert back to oem firmware again due to lan kept disconnecting every now again, now the thing is i got 2 of these plugs, i only tried to update one which are both on different ip addresses via webpage, both don't seem to work right now and are in constant reboot, any ideas where to start?

edit: forgot to add wiki page for recovery seems to be missing some details & some links take you in circles. Or how to prompt this failsafe buy pressing a button.

Are you talking about a v1 or a v2 device? Which region, i.e. what is your exact model number?

How did you conclude the devices are in constant report? LEDs? How does it look like?

I did return both, a v1 and a v2, back to stock a few weeks ago - it worked fine, there were no steps that I missed. Could you please be a bit more specific on this?

Hi thanks for replyi i have the Tl-WPA8630P kit which V2 on UK plug version.

The LED by looks of it goes into bootloop cycle it kinda appears on my PC lan port then dissappears. This is after trying to go back to original TP-Link firmware after a year or more

Oh, that's bad. IIRC, this device doesn't have recovery mode in the bootloader, so you need to disassemble the device and attach serial console to see what's going on.

A word of warning: There is an electrical hazard inside, i.e. mains voltage without further protection. Make sure you know what you're doing before attempting this procedure!

See the debricking section for more details:

Thankyou mate, that exactly what I've been searching for, l gonna try the failsafe mode first, before investing in a usb serial or SOIC8 flasher

Which failsafe mode? There is none.

this comes up on the link you sent on debricking guide, unless its for sometinhing else, then ill have to just order SOIC8 Programmer and then hope someone can upload me the full factory firmware

Yes, but this only works if OpenWrt is booting and I doubt that that's still the case. But it's anyway worth a try :slight_smile:

Failsafe Not working on either of them, even though i only tried to flash on one powerline to test. im gonna go ahead order SOIC8 SPI programer, can i use TP-link bin firmware or do i need someones factory backup for this to work?

edit: i just ordered this one i think its correct one

Always go with UART first. Flashing via a clip is the very last resort, you will usually need a dump of someone else's device and then you need to fix serial number and MAC address. A firmware upgrade does not contain all required partitions.

Yours is not completely dead, so try UART first.

Edit: please be aware that this specific flasher might fry your board as it outputs 5V on the logic pins instead of 3.3V. This can be fixed, you need to lift a pin and add two wires - I did that on mine.

I understood the board needs 3.3v from what i gathered and i need changing 5v to 3.3v, so from i understand now, i dont actually need full firmware reinstallation now, i actually thought this what was being refered to as UART for this method. So does this programmer do UART too. Cos im reading the debrick spi programing section.

Not done anything like this over 20 years since Motorola SB5100/5200 modem days.

According to the jumpers/description, it should do UART too, but I've never tried this on this boars. The voltage problem still applies though, I would do the 3.3V mod anyway.

Will do once it arrive tomorrow which does claim 3.3/5v on one of the pictures, i wont know until ive got it if already on 3.3v or 5v hoping there a small manual with it, not too sure about UART which i now understand is serial communication, and i just threw my old one out USB to serial rs232 & another one with parallel port in it from 20 years ago last week.

The programer finally arrived with no documentation just trying to figure out the 3.3V & 5v switch right now, or how this connects to UART.

I repeat: You have to mod this for proper 3.3V operation! The PCB design is really bad on this thing. See here:

Was gonna say this website ive found say its a 3.3v now im confused.

This website tells you the exact same thing: You need to mod it for proper 3.3V operation as it outputs 5V even if 3.3V are selected by the jumper.

Ok just pulled out my volt multimetre out it also showing as 5.05v looks like i need to follow the mod, time to find my thin wires & soldering iron, looks like simple 3 points to connect.

Yes, plus lifting of one pin.

If the flash chip is not completely damaged, the data could be read and then re-used over a new chip if replaced.