TP-LINK WP-8970 v1.2 - no "factory" image available for download

Hello everybody,
as a newby I read the Factory Install Page for my first time installation and learned, there are up to 4 images availabe (counting in the snapshot versions), and I'd need the "factory" version.

Unfortunately I only can find an "upgrade" version in the downloads, even some other models appear to have such a file. I even checked the 17.0.1 release, same result.

Then I read, my original router firmware since 2013 only accepts encrypted firmware. Does it mean, I can't use the web interface and only can install via TFTP?

Could someone help me please, how I can install it the very first time?

Thank you very much!


Never tried myself (I hacked my 8970 the hard way) but I think there is a setting you can set the wifi ssid name to that opens a port. Its something like

Wifi `telnetd -p 1023 -l login`

That starts a telnet demon on port 1023 that you can use to log in. You may be able to write openwrt after you log in (for me it bricked my device though ...)

I'll check the command when I get home ....

Thank you!

It’s in the page that @mbo2o linked

I've found that if you pad the file used for mtd2 out with 0xFF characters to the length of the partition it will come up ok on the first boot. The 15.05.1 image has some of this padding (not the full length but apparently enough) which is sufficient to force the formatting of the JFFS partition on the first reboot, so using this image to get OpenWrt installed (as per the old instructions) seems to work reliably; later versions can then be installed via LuCI. The 17.01.x and 18.06.x images don't have any of this padding :frowning: .