TP-Link WDR4300 - Unable to Reset [Unknown Password]

#1

Hi All,

Lets preface this all with me clarifying I know nothing about networking and am fumbling my way through this.

I recently bought a 2nd hand TP Link WDR4300 with the intention of flashing openwrt onto it - as I am looking to use the WISP function. It turns out that OpenWRT is already installed. Unfortunately, I was not provided a password to gain access to the LuCi GUI and have been attempting to work out how to restore to the openwrt firmware to default state in order to remove the password.

I have detailed the steps I have completed so far and the the assoicated documentation I have refered to.

I have connected to the LuCi via webrowser using 192.168.1.1.
The following information is provided:
Top Banner: TRC46E1F08DB7A (My understanding is that this should typically say OpenWRT ... )
Bottom of Page: Powered by LuCi Master (git-16.034.34990-8ae57f6)/OpenWRT Designated Driver r48626

have had a read on how to reset the router to stock openwrt firmware here.

I have also read how to put the router in fail safe mode here, using the System LED function.

I believe I have succeeded getting into fail safe as the light goes hyper fast.

Using cmder/PuTTY, i have tried to SSH into the router but am always asked to enter a password (which I obviously dont have). This is something that I have been unable to bypass and am currently stuck on.

If anyone could assist, that would be much appreciated.

#2

Check this

2 Likes
#3

While you are in failsafe mode, you should be able to connect via root and an empty password (hit enter, when asked).

If you're lucky, your device may have push-button tftp recovery available, but as this recovery functionality was only retrofitted in later OEM firmware upgrades, it's not available on all devices.

2 Likes
#4

One more thing to add here that you need to connect with static IP in failsafe mode. The router will default to 192.168.1.1 so your IP should be in the same subnet. After that just SSH into it and you’ll be able to reset it and also can perform sysupgrade thereafter.

1 Like
#5

Hi All,

I have run through the steps but with no luck. To assist in fault checking, please find my settings below.

Setting Router into Fail Safe (Video):
https://drive.google.com/file/d/12_amSa2nw9DuUoWEPR4S51b8KiJeBR7R/view?usp=sharing

PC IP Configuration:

Cmder transcript below:

image

Note, where password is requested. I have not entered anything and have pressed enter.

Hopefully someone can help out :slight_smile:

#7

try "telnet 192.168.1.1"
You will need PuTTY

#8

looks like it is reset... to factory

tried admin admin?

#9

I'd suggest to obtain serial access and flash OpenWrt firmware to make it work. In this case this seems to be the only option for you if there is no tftp available. Otherwise try to go back to stock through tplink tftp recovery method.

#10

Hi Rakesh,

Gave it a shot via telent:

When using Port 23, nothing works.

When using Port 22, the following is outputted:
Capture3

When using Cmder for telnet as Port 23, the following is outputted:

#11

Hi Wulfy23,

Do you mean try the below in the LucI GUI? Unfortunately it doesn't work.

Username: admin
Password: admin

1 Like
#12

Do tftp recovery ; follow steps in below link.

Flashing / Recovery using tftp only (without serial console)

https://openwrt.org/toh/tp-link/tl-wr1043nd
Or

#13

Hi Rakesh,

Thank you for your help. TFTP without serial worked!

I followed this video: https://www.youtube.com/watch?v=1hWT35w6sVI

The only thing was trying to flash OEM software didnt work for me and I actually ended up bricking the device. So I ended up just experimenting and tried using the latest OpenWRT firmware instead of the OEM firmware and it worked!

1 Like