TP-Link WDR3500 - Firmware installed, but no response from ping,ssh etc

I've tried to install LEDE 17.01.3 on my TP Link WDR3500. However i've been unable to access the router via an ethernet cable (known good) - I simply get 'no route to' when I try to access it via ssh. Ping also fails.
I've connected a serial interface to the router and can see that LEDE is indeed booting on the router - I've tried booting LEDE in failsafe mode and it configures the router's eth0 with an IP address of, however I still cannot access the router. I then tried enabling WiFi using UCI - which sort-of worked - I could connect to the LEDE AP, and DHCP will allocate my PC an IP address, but I still cannot access LEDE - ssh,ping and web browser all refuse to connect to
I'm really not sure what else to try! Can anyone help me out here?


Try the steps here for doing a hard reset…

Is the Linksys hardware the same as the TP-Link hardware?

I've already tried this:

The router is not bricked - it seems boots up fine to LEDE

The dd-wrt reference would be pretty bad advice in this case, given that the failsafe environment seems to work just fine. This means the router is not bricked at all, there are just some problematic configurations which interfere with normal operations - taking out the big hammer would be way more dangerous than simply fixing the issues with the access already available.

Basically there are three easy options from within failsafe mode:

  • invoke "firstboot", to reset the router's configuration to defaults (deleting all existing configuration, so back up if you need to). this might very well not help, but it's always good to test, as this would be the most gentle/ safe recovery approach.
  • Given that you both have a working serial console attached and can bring up the network (even if that's just wlan), you can transfer a working sysupgrade firmware image to your router (be it by pushing the file from a client to the router - or downloading it from the router to /tmp/), from there on you can simply "sysupgrade -n /tmp/" to flash a working firmware image (again).
  • depending on the OEM u-boot version installed on your router (the version of the last installed vendor firmware), the router provides a tftp based rescue mode (see the OpenWrt wiki for your router or the very similar tl-wdr3600/ tl-wdr4300 for details) , which can be fed with a factory firmware image.

Given the level of access you already have, one of these option should really work, before starting more dangerous recovery attempts.

A 30-30-30 reset isn't exactly a big hammer. It cures a lot of issues after good flashes, as well as bad.

The OP already tried "failsafe", so not much use in trying it again.

OK, I can confirm that the WDR3500 does have tftp rescue mode. I reloaded the LEDE firmware, but had the same issue as before. It would appear that LEDE does NOT work with the WDR3500. I have now reverted to the factory firmware.

Thanks everyone for your suggestions.

It could be helpful to see the serial bootlog you mentioned in your first post.

Please file a bugreport with all the info you can get, your device should work just fine.

The TL-WDR3500 is basically the same hardware as the TL-WDR3600/ TL-WDR4300 which are working well. The only difference is the additional switch chip (AR8327N) in the TL-WDR3600/ TL-WDR4300, which is missing from the TL-WDR3500 (handled by AR9344 directly, which drops it to 100 MBit/s max), this should be easily fixable in the switch setup.