TP-LINK WDR3500: Bricked after installation OpenWrt 19.07.2, how to revive him?

Hello have a problem,"bricked" router tp-link wdr 3500,first installed openwrt 19.7.02 openwrt,after tried install stock fw from tp-link and i got this suggestions how to fix?

There are specific instructions to flash the stock firmware.
In case you cannot access the device by network, you can use the serial console with a usb to TTL adapter.

download link not working and dont have that adapter or any instruments to make him self,lan not work to.

But you wrote that you have the stock firmware.

The tl-wdr3500 should have inherited a reliable push-button tftp recovery method from the tl-wdr3600, serial console access (while always useful) should not be required.

1 Like

should,but not have,have what we have :slight_smile:

Do we really need a 5.2MB video to convey the information "power LED is constantly on, all other lights are blinking in a 3 sec intervall"?


These are bog-simple to TFTP debrick.

Turn the power off. Hold down the reset button while turning on the power. Keep holding the button for about 5 seconds and the WPS light should come on-- now you have power and WPS LEDs on steady, the rest are out. If the LEDs do that it is ready and waiting to TFTP flash.


that TFTP debrick,he is requiring some special tools,wires and soldering skills?Just first time this happened to me.As tmomas mentioned i have just solid power LED,rest are blinking.Your metod not worked,i will buy that adapter and try do reflash with him.

No, just to connect the router with a PC and send the file with tftp.


What happens when you turn the power on with the reset button held down?

nothing,trying by this guide but logs not shows any activity,last chance is try with that USB-TTL adapter.

I'm going to try this one more time then I'm done here.

Does the WPS light come on after you turn on the power while holding down the reset button?

The WPS light is the second one from the right side, its icon is two arrows sort of pointing in a circle.

The guide you posted is good but it fails to point out that Windows 10 includes a standard firewall feature that will prevent a TFTP server from working. tftpd32 will start up and run normally, but any incoming requests from a router will be silently blocked by the OS and no activity will appear in the log section of the window. It is necessary to disable the default Windows Firewall, as well as any third-party firewalls of course.


mine os is not windows 10 just win 7,tried all variants,maybe its mine antivirus blocking these actions with tftp,easier maybe just turn off firewall in avast or do actions with that cable via putty.

Very simple question was repeatedly not answered. I'm through.

1 Like

WPS light is blinking with other LEDS,whats not blinking but stable is power led.

Hello little update, with this "bricked" device,arrived usb-ttl adapter,pins soldered to router main board,wires from ttl adapter connected to them with right order color/values,what next to do?work with putty/tftpd server on pc?