TP-Link WA901ND accessible only via failsafe mode

Hello OpenWRT experts,
I have some problems with my old TP-Link WA901ND access point: all of a sudden the device running OpenWRT Chaos Calmer v15.05 LuCI was no longer accessable, not by LAN nor by wifi. Before this failure the device had ran without any problems for several years.

I tried a reset, several methods described on the web to get access to the device, but only the failsafe mode provides access to the device. Within failsafe mode the device is running OpenWRT Barrier Breaker 14.07.

In failsafe mode I tried several methods to recover and get access in normal mode, but so far without any success. I was able to transfer a bin-file to the device and successfully flashed it to the device (according to output of update procedure). But after a reset the device is still not accessable.

After booting up the system seems to be in a kind of loop with LEDs flashing as following:
Directly after power on: power, system, WLAN on, LAN and QSS off
Next: power on, all others off
Next: power on, LAN flashing, all others off
Next: power, system, LAN on, WLAN, QSS off
Next: power, system, LAN, WLAN on, QSS off
Next: power, system, LAN, WLAN and QSS on for 1 second
Next: start again with first "Next-Step" given above

No wifi signal is transmitted and no LAN activities like DHCP requests etc.

Any idea how I can fix this problem and get access to update to a running firmware with access via wifi and/or LAN in normal mode?


This same issue me too.

@skzafar_syncnet - You're resurrecting a 3 year old post about a router that is no longer supported by OpenWrt and the specific thread deals with an upgrade from 14.07 > 15.05 (which are both now VERY obsolete and unsupported). If you're using the same WA901ND, it is time to get a new device that is supported by a modern version of OpenWrt. And if you're using 15.05 or really anything earlier than 19.07.10, you should be upgrading to 21.02.

If this doesn't apply to your situation, it would be useful if you described what hardware you've got, what version of OpenWrt is installed, and what you changed just prior to the issue presenting.