Tp-link w8970 internal 1gbit switch works in 100mbit mode

i see that lan/rj45 ports on switch are 100mbit (supposed to be 1gbit).

what could i do to help to debug and resolve that issue?

Are you using a CAT5e / CAT6 cable?
Is the computer at the other end of the cable capable of doing 1Gbps?

sure, let's start like that.

i tried cat5e and cat6 cables from AMP and Krone.

thinkpads: x220, x230, t420 and w530 (all of them have gigabit ethernet adapters)
macbook pro early 2015 with thunderbolt to ethernet (1gbit).
i also tried htpc with h170n-wifi motherboard (2x1gbit ports).

i could use mikrotik rb260gs - all of them could use gigabit connection/connect at gigabit speed.
same goes for archer c7 v2 running LEDE.

if i connect them to w8970 running lede or openwrt - it is connecting at 100mbit only.

In that case, that looks like a bug.

Is this the issue?

Because I'm getting this as well. I rolled back to original firmware. Same cable, same machine, same internet and with TP-Link firmware I get the correct speeds. I might try 17.01.2 and see if it's fixed but I doubt it.

17.01.2 still the same issue. Using port 4 as WAN and I cannot get more than 100mbps. I'd like to know how we can bump that to 1gig.

any way to fix it with closed source drivers?